vlan_1.9-3_i386.deb


Advertisement

Description

vlan - user mode programs to enable VLANs on your ethernet devices

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name vlan
Package version 1.9
Package release 3
Package architecture i386
Package type deb
Installed size 172 B
Download size 38.68 KB
Official Mirror ftp.br.debian.org
This package contains the user mode programs you need to add and remove
VLAN devices from your ethernet devices.
A typical application for a VLAN enabled box is a single wire firewall,
router or load balancer.
You need a VLAN Linux kernel for this.  Linux kernel versions >= 2.4.14
have VLAN support.

Alternatives

Package Version Architecture Repository
vlan_1.9-3_amd64.deb 1.9 amd64 Debian Main
vlan - - -

Requires

Name Value
iproute -
libc6 >= 2.6.1-1

Download

Type URL
Binary Package vlan_1.9-3_i386.deb
Source Package vlan

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install vlan deb package:
    # sudo apt-get install vlan

Files

Path
/etc/network/if-post-down.d/vlan
/etc/network/if-pre-up.d/vlan
/etc/network/if-up.d/ip
/sbin/vconfig
/usr/share/doc/vlan/NEWS.Debian.gz
/usr/share/doc/vlan/TODO.Debian
/usr/share/doc/vlan/changelog.Debian.gz
/usr/share/doc/vlan/changelog.gz
/usr/share/doc/vlan/copyright
/usr/share/doc/vlan/howto.html
/usr/share/doc/vlan/vlan.html
/usr/share/man/man5/vlan-interfaces.5.gz
/usr/share/man/man8/vconfig.8.gz

Changelog

2007-09-30 - Loic Minier <lool@dooz.org>
vlan (1.9-3) unstable; urgency=low
* Add XS-Vcs-Git and XS-Vcs-Browser fields to control.
* Fix and cleanup the vlan-interfaces.5 man page.
* Drop useless delta and cleanup Debian diff.
* Rewrite copyright file completely; some copyrights and licensing headers
are missing upstream and should be clarified with the help of upstream.
* Stop installing README; no useful additional information.
* Drop Debian specific exit codes for vconfig errors; use upstream exit
codes instead; document this change in NEWS.
* Big cleanup to build and rules; misc fixes for obsolete constructions.
* Cleanup CCFLAGS:
- Build without -D_GNU_SOURCE; makes no difference on the resulting
binaries, so simply rely on the upstream build.
- Build with -O2 unless DEB_BUILD_OPTIONS has noopt.
* Prepare to ship macvlan_config in the future.
* Add support for bonding in if-pre-up and if-post-down scripts; cleanup
these scripts; closes: #404630.
* Point to the vlan-interfaces(5) man page in the Debian README and
recommend setting vlan-raw-device.
* Add support for wlan in if-pre-up and if-post-down scripts;
closes: #398837.
* Document the bonding and wlan changes in NEWS.
* Install howto.html as documentation.
* Document that aliases are ignored by the vlan scripts; closes: #400827.
* Add debian/TODO list.
* Pass STRIP=true to the upstream build to avoid stripping; closes: #438253.
* Hide "bind-type" in help string as it doesn't seem to be implemented;
closes: #398807.
* Document that the default for REORDER_HDR is 1 since 2.6.18; thanks
Kristian Sørensen; closes: #436219.
2006-10-28 - Loic Minier <lool@dooz.org>
vlan (1.9-2) unstable; urgency=medium
* Bump up Standards-Version to 3.7.2.
* Bump up Debhelper compatibility level to 5.
* Comment out DH_VERBOSE.
* Add ${misc:Depends}.
* Add empty binary-indep target; thanks Aurelien Jarno; closes: #395758.
* Update description to clarify that 2.6 kernels are supported; thanks
Martin Michlmayr; closes: #344782.
* Drop debian/source.lintian-overrides.
* Drop debconf-utils from Depends.
* Drop obsolete debian/vlan-nice.patch and debian/vlan-fixes.patch, as well
as README.Debian which only referenced them.
2005-10-20 - Loic Minier <lool@dooz.org>
vlan (1.9-1) unstable; urgency=low
* New upstream release.
- Fix return error codes in vconfig. (Closes: #320452)
* Fix /etc/network/if-up.d/ip to not set rp_filter to 1 when it isn't
configured. (Closes: #330673) [debian/ip-if-up]
* Bump up Standards-Version to 3.6.2. [debian/control]
* Add myself to the uploaders. [debian/control]
* Update upstream URL.
2005-03-30 - Ard van Breemen <ard@kwaak.net>
vlan (1.8-2) unstable; urgency=low
* Fixed postdown scripts to remove vlan interfaces when vlan-raw-device is
set, independent of the interface name. This bug was introduced by fixing
#196890 not correctly.
closes: #292648
* Ignore any interface with a colon in its name.
closes: #272891
* When vlan-raw-device is set, don't try to be smart. br0.x (and any other
interface) can now be made.
closes: #272446
2004-08-14 - Ard van Breemen <ard@kwaak.net>
vlan (1.8-1) unstable; urgency=low
* New upstream
closes: #213656
* Fixed postdownscripts to detect and remove eth*.* interfaces correctly
closes: #196890
2003-08-23 - Roland Mas <lolando@debian.org>
vlan (1.6-1.1) unstable; urgency=low
* Non-maintainer upload according to the release manager's plan.
* Fixed multiline strings to fix building from sources
closes: #195064
2003-04-20 - Ard van Breemen <ard@kwaak.net>
vlan (1.6-1) unstable; urgency=low
* New upstream
closes:#172366
* Fix scripts
closes:#189383
closes:#148476
* Added documentation for /etc/network/interfaces
closes:#148480
* Removed kernel patches
closes:#166272
closes:#124836
* Fixed debian/rules to build under build and not under binary
closes:#172818
* Fixed manpage

See Also

Package Description
vlc-data_2.0.3-5+deb7u2_all.deb Common data for VLC
vlc-nox_2.0.3-5+deb7u2+b1_i386.deb multimedia player and streamer (without X support)
vlc-plugin-fluidsynth_2.0.3-5+deb7u2+b1_i386.deb FluidSynth plugin for VLC
vlc-plugin-jack_2.0.3-5+deb7u2+b1_i386.deb Jack audio plugins for VLC
vlc-plugin-notify_2.0.3-5+deb7u2+b1_i386.deb LibNotify plugin for VLC
vlc-plugin-pulse_2.0.3-5+deb7u2+b1_i386.deb PulseAudio plugin for VLC
vlc-plugin-sdl_2.0.3-5+deb7u2+b1_i386.deb SDL video and audio output plugin for VLC
vlc-plugin-svg_2.0.3-5+deb7u2+b1_i386.deb SVG plugin for VLC
vlc-plugin-zvbi_2.0.3-5+deb7u2+b1_i386.deb VBI teletext plugin for VLC
vlc_2.0.3-5+deb7u2+b1_i386.deb multimedia player and streamer
vlock_2.2.2-3_i386.deb Virtual Console locking program
vlogger_1.3-3.1_all.deb virtual web logfile rotater/parser
vm-bonus-el_35.2+nmu1_all.deb vm-bogofilter add-on for VM
vm_8.1.0-1_all.deb A mail user agent for Emacs
vmfs-tools_0.2.5-1_i386.deb Tools to access VMFS filesystems
Advertisement
Advertisement