vim_7.3.547-7_i386.deb


Advertisement

Description

vim - Vi IMproved - enhanced vi editor

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name vim
Package version 7.3.547
Package release 7
Package architecture i386
Package type deb
Installed size 1.75 KB
Download size 759.98 KB
Official Mirror ftp.br.debian.org
Vim is an almost compatible version of the UNIX editor Vi.
Many new features have been added: multi level undo, syntax
highlighting, command line history, on-line help, filename
completion, block operations, folding, Unicode support, etc.
This package contains a version of vim compiled with a rather
standard set of features.  This package does not provide a GUI
version of Vim.  See the other vim-* packages if you need more
(or less).

Alternatives

Package Version Architecture Repository
vim_7.4.488-3~bpo70+1_amd64.deb 7.4.488 amd64 Debian Backports Main
vim_7.4.488-3~bpo70+1_i386.deb 7.4.488 i386 Debian Backports Main
vim_7.3.547-7+deb7u4_i386.deb 7.3.547 i386 Debian Security Updates Main
vim_7.3.547-7+deb7u4_amd64.deb 7.3.547 amd64 Debian Security Updates Main
vim_7.3.547-7_amd64.deb 7.3.547 amd64 Debian Main
vim - - -

Requires

Name Value
libacl1 >= 2.2.51-8
libc6 >= 2.11
libgpm2 >= 1.20.4
libselinux1 >= 1.32
libtinfo5 -
vim-common = 2:7.3.547-7
vim-runtime = 2:7.3.547-7

Provides

Name Value
editor -

Download

Type URL
Binary Package vim_7.3.547-7_i386.deb
Source Package vim

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install vim deb package:
    # sudo apt-get install vim

Files

Path
/usr/bin/vim.basic
/usr/share/bug/vim/presubj
/usr/share/bug/vim/script
/usr/share/doc/vim
/usr/share/lintian/overrides/vim

Changelog

2013-02-09 - James McCoy <jamessan@debian.org>
vim (2:7.3.547-7) unstable; urgency=low
* Add vim-lesstif.preinst to handle transitioning /usr/share/doc/vim-lesstif
from a symlink to a directory.  (Closes: #700069)
* Add clarification to short description of vim-nox.  (Closes: #699780)
2012-11-22 - James McCoy <jamessan@debian.org>
vim (2:7.3.547-6) unstable; urgency=low
* Always enable ACL support.  (Closes: #693462)
2012-09-15 - James McCoy <jamessan@debian.org>
vim (2:7.3.547-5) unstable; urgency=low
* Use xz compression for all binary packages.  (Closes: #687265)
* Backport patches 7.3.652 and 7.3.661 to fix crash in Python bindings when
GCC 4.7 is used to build Vim.  (Closes: #678122)
2012-07-23 - James McCoy <jamessan@debian.org>
vim (2:7.3.547-4) unstable; urgency=low
* Add remove-py_config.patch, removing the dependence on Python's config.c.
(Closes: #681599)
2012-06-26 - James McCoy <jamessan@debian.org>
vim (2:7.3.547-3) unstable; urgency=low
* Add netrw-syntax-fix.patch to fix a syntax error in NetRead's ftp
handling.  (Closes: #678513)
2012-06-21 - James McCoy <jamessan@debian.org>
vim (2:7.3.547-2) unstable; urgency=low
* Work around GCC 4.7 optimization bug, #678122, by explicitly using gcc-4.6
2012-06-06 - James McCoy <jamessan@debian.org>
vim (2:7.3.547-1) unstable; urgency=low
* Merge upstream tag v7-3-547
* Change ruby(-dev) Build-Depends to use unversioned package names in order
to build with the default ruby version.
* Add spell-check support to Debian control syntax file.
2012-05-24 - James McCoy <jamessan@debian.org>
vim (2:7.3.524-1) unstable; urgency=low
* Merge upstream tag v7-3-524
+ Recognize git commit files in submodules. (Closes: #663735)
+ Fix NetRW's munging of options when opening files.  (Closes: #661720)
+ 7.3.485: Use environment's LDFLAGS when building xxd.  (Closes: #663605)
+ Update recognized keywords for dircolors syntax.  (Closes: #660632)
* Exclude the tools directory from the install.
+ Stop shipping scripts which use Perl4 functionality.  (Closes: #659431)
+ Remove lintian overrides for csh scripts.
+ Remove patch debian/awk-shebang.patch
* Remove EOLed Lenny/Maverick releases, add Quantal release to runtime
files.
* Remove upstream/po-syntax-cpo.patch, merged upstream.
* Remove upstream/debian-runtime-*.patch, merged upstream.
* Remove upstream/fr-manpage-fixes.patch, merged upstream.
* Remove upstream/xdefaults-syntax-define.patch, merged upstream.
* Add lintian override for binaries-have-file-conflict.  vim-runtime diverts
vim-tiny's doc/help.txt and doc/tags.
* Remove unused menu-icon-missing override.
2012-02-10 - James McCoy <jamessan@debian.org>
vim (2:7.3.429-2) unstable; urgency=low
* Ignore failures in test61 since it is highly sensitive to timing.
Slow/heavily loaded systems will cause the test to fail.  (Closes:
#625941)
* Install bug scripts with correct permissions.
+ Use dh_bugfiles to simplify process
+ Bump debhelper B-D to >= 7.2.3~

See Also

Package Description
vimhelp-de_7.3.101122-2_all.deb Vi IMproved - Documentation files (German translation)
vinagre_3.4.2-2_i386.deb remote desktop client for the GNOME Desktop
vinetto_0.6.0~alpha-1_all.deb A forensics tool to examine Thumbs.db files
vino_3.4.2-1+b1_i386.deb VNC server for GNOME
viridian_1.2-3_all.deb play audio streams from an Ampache server
virt-goodies_0.4-1_all.deb A collection of helpful virtualisation related tools
virt-manager_0.9.1-4_all.deb desktop application for managing virtual machines
virt-top_1.0.7-1+b1_i386.deb show stats of virtualized domains
virt-viewer_0.5.3-1_i386.deb Displaying the graphical console of a virtual machine
virt-what_1.12-1_i386.deb detect if we are running in a virtual machine
virtaal_0.7.1-1_all.deb graphical localisation editor
virtinst_0.600.1-3+deb7u2_all.deb Programs to create and clone virtual machines
virtualbox-dkms_4.1.42-dfsg-1+deb7u1_all.deb x86 virtualization solution - kernel module sources for dkms
virtualbox-fuse_4.1.42-dfsg-1+deb7u1_i386.deb x86 virtualization solution - virtual filesystem
virtualbox-guest-dkms_4.1.42-dfsg-1+deb7u1_all.deb x86 virtualization solution - guest addition module source for dkms
Advertisement
Advertisement