vile_9.8g-2_i386.deb


Advertisement

Description

vile - VI Like Emacs - vi work-alike

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name vile
Package version 9.8g
Package release 2
Package architecture i386
Package type deb
Installed size 915 B
Download size 403.64 KB
Official Mirror ftp.br.debian.org
vile is a text editor which is extremely compatible with vi in terms of
``finger feel''.  In addition, it has extended capabilities in many areas,
notably multi-file editing and viewing, syntax highlighting, key rebinding,
an optional embedded perl interpreter, and real X window system support.
This package contains the character-mode binary.  Required support files
are contained in vile-common.  Source code highlighting filters are in
vile-filters.  An X11 binary is in the xvile package.

Alternatives

Package Version Architecture Repository
vile_9.8g-2_amd64.deb 9.8g amd64 Debian Main
vile - - -

Requires

Name Value
libc6 >= 2.11
libncurses5 >= 5.5-5~
libperl5.14 >= 5.14.2
libtinfo5 -
vile-common = 9.8g-2

Provides

Name Value
editor -

Download

Type URL
Binary Package vile_9.8g-2_i386.deb
Source Package vile

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install vile deb package:
    # sudo apt-get install vile

Files

Path
/usr/bin/vile
/usr/share/doc/vile
/usr/share/lintian/overrides/vile
/usr/share/menu/vile

Changelog

2012-06-03 - Brendan O'Dea <bod@debian.org>
vile (9.8g-2) unstable; urgency=low
* Recommend xfonts-75dpi and xfonts-100dpi for xvile, which specifies
fonts from both in XVile.ad and vilemenu.rc (thanks to Jonathan
Nieder, closes: #563250).
2012-03-12 - Brendan O'Dea <bod@debian.org>
vile (9.8g-1) unstable; urgency=low
* New upstream release.
* Use dpkg-buildflags to pass compiler/linker flags to configure.  Add
build-depends on dpkg-dev.
2011-12-29 - Brendan O'Dea <bod@debian.org>
vile (9.8f-2) unstable; urgency=low
* Apply 9.8f2 patch from Tom to fix a regression with nohl when no
majormode is in effect.
2011-11-28 - Brendan O'Dea <bod@debian.org>
vile (9.8f-1) unstable; urgency=low
* Revert changes to configure.
* Switched maintainer/uploader roles back again.
* New upstream release.
* Revise DEFAULT_XSHELL handling again.
2011-08-21 - Brendan O'Dea <bod@debian.org>
vile (9.8e-3) unstable; urgency=low
* Revise setting of DEFAULT_XSHELL, passing to the build step for xvile
rather than through configure flags.
2011-08-20 - Brendan O'Dea <bod@debian.org>
vile (9.8e-2) unstable; urgency=low
* Dump config.log when configure is killed in an attempt to divine why
s390/armel builds are failing.
2011-04-11 - Brendan O'Dea <bod@debian.org>
vile (9.8e-1) unstable; urgency=low
* New upstream release.
2010-12-29 - Brendan O'Dea <bod@debian.org>
vile (9.8d-1) unstable; urgency=low
* New upstream release.
2010-12-28 - Brendan O'Dea <bod@debian.org>
vile (9.8c-1) unstable; urgency=low
* New upstream release.
* Remove deprecated DH_COMPAT in debian/rules, adding debian/compat.
* Move to standards version 3.9.1.
2010-09-27 - Brendan O'Dea <bod@debian.org>
vile (9.8b-2) unstable; urgency=low
* Remove debian/compat in favour of exported DH_COMPAT in debian/rules.

See Also

Package Description
vilistextum_2.6.9-1.1_i386.deb a HTML to text converter
vim-addon-manager_0.5.2_all.deb manager of addons for the Vim editor
vim-athena_7.3.547-7_i386.deb Vi IMproved - enhanced vi editor - with Athena GUI
vim-common_7.3.547-7_i386.deb Vi IMproved - Common files
vim-conque_2.3-1_all.deb plugin for running interactive commands in a Vim buffer
vim-doc_7.3.547-7_all.deb Vi IMproved - HTML documentation
vim-gnome_7.3.547-7_i386.deb Vi IMproved - enhanced vi editor - with GNOME2 GUI
vim-gtk_7.3.547-7_i386.deb Vi IMproved - enhanced vi editor - with GTK2 GUI
vim-gui-common_7.3.547-7_all.deb Vi IMproved - Common GUI files
vim-latexsuite_20120125.768-2_all.deb view, edit and compile LaTeX documents from within Vim
vim-lesstif_7.3.547-7_all.deb Vi IMproved - enhanced vi editor (transitional package)
vim-migemo_20110227-7_all.deb VIM plugin for C/Migemo
vim-nox_7.3.547-7_i386.deb Vi IMproved - enhanced vi editor - with scripting languages support
vim-puppet_2.7.23-1~deb7u3_all.deb syntax highlighting for puppet manifests in vim
vim-rails_4.5~20110829-1_all.deb vim development tools for Rails development
Advertisement
Advertisement