tupi_0.1+git12-6_i386.deb


Advertisement

Description

tupi - 2D Animation design and authoring tool

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name tupi
Package version 0.1+git12
Package release 6
Package architecture i386
Package type deb
Installed size 5.04 KB
Download size 2.01 MB
Official Mirror ftp.br.debian.org
Tupi: 2D Magic is a design and authoring tool for digital artists interested
in 2D Animation, offering an interface experience focused on 8-100 years old
kids. It's source code is based on the KTooN project.
Some of its main features are: basic illustration tools (shapes, fill, text),
gradient tools, onion skin, brushes editor, pencil with smoothness support,
basic object library (for svg files and raster images) and many others.
Using its modules of Animation and Reproduction you can export 2D projects
to several formats as OGG, MPEG, AVI, MOV and SWF. Additionally, the
option of exporting Image arrays as output is available.

Alternatives

Package Version Architecture Repository
tupi_0.1+git12-6_amd64.deb 0.1+git12 amd64 Debian Main
tupi - - -

Requires

Name Value
libavcodec-extra-53 >= 6:0.8.2-2
libavcodec53 >= 6:0.8.2-2
libavformat53 >= 6:0.8.2-2
libavutil51 >= 6:0.8.2-2
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libgl1 -
libgl1-mesa-glx -
libqt4-network >= 4:4.5.3
libqt4-opengl >= 4:4.5.3
libqt4-svg >= 4:4.5.3
libqt4-xml >= 4:4.5.3
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libstdc++6 >= 4.4.0
tupi-data = 0.1+git12-6
zlib1g >= 1:1.1.4

Replaces

Name Value
ktoon -

Download

Type URL
Binary Package tupi_0.1+git12-6_i386.deb
Source Package tupi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install tupi deb package:
    # sudo apt-get install tupi

Files

Path
/usr/bin/tupi
/usr/lib/tupi/libplugincommon.so
/usr/lib/tupi/libplugincommon.so.1
/usr/lib/tupi/libplugincommon.so.1.0
/usr/lib/tupi/libplugincommon.so.1.0.0
/usr/lib/tupi/libtupi.so
/usr/lib/tupi/libtupi.so.1
/usr/lib/tupi/libtupi.so.1.0
/usr/lib/tupi/libtupi.so.1.0.0
/usr/lib/tupi/libtupibase.so
/usr/lib/tupi/libtupibase.so.1
/usr/lib/tupi/libtupibase.so.1.0
/usr/lib/tupi/libtupibase.so.1.0.0
/usr/lib/tupi/libtupifwcore.so
/usr/lib/tupi/libtupifwcore.so.1
/usr/lib/tupi/libtupifwcore.so.1.0
/usr/lib/tupi/libtupifwcore.so.1.0.0
/usr/lib/tupi/libtupifwgui.so
/usr/lib/tupi/libtupifwgui.so.1
/usr/lib/tupi/libtupifwgui.so.1.0
/usr/lib/tupi/libtupifwgui.so.1.0.0
/usr/lib/tupi/libtupifwsound.so
/usr/lib/tupi/libtupifwsound.so.1
/usr/lib/tupi/libtupifwsound.so.1.0
/usr/lib/tupi/libtupifwsound.so.1.0.0
/usr/lib/tupi/libtupinet.so
/usr/lib/tupi/libtupinet.so.1
/usr/lib/tupi/libtupinet.so.1.0
/usr/lib/tupi/libtupinet.so.1.0.0
/usr/lib/tupi/libtupistore.so
/usr/lib/tupi/libtupistore.so.1
/usr/lib/tupi/libtupistore.so.1.0
/usr/lib/tupi/libtupistore.so.1.0.0
/usr/lib/tupi/bin/tupi
/usr/lib/tupi/bin/tupi.bin
/usr/lib/tupi/plugins/libcoloringtool.so
/usr/lib/tupi/plugins/libcompoundtool.so
/usr/lib/tupi/plugins/libcontourselectiontool.so
/usr/lib/tupi/plugins/liberasertool.so
/usr/lib/tupi/plugins/libffmpegplugin.so
/usr/lib/tupi/plugins/libfilltool.so
/usr/lib/tupi/plugins/libgenericexportplugin.so
/usr/lib/tupi/plugins/libgeometrictool.so
/usr/lib/tupi/plugins/libinktool.so
/usr/lib/tupi/plugins/libkgstengine.so
/usr/lib/tupi/plugins/libopacitytool.so
/usr/lib/tupi/plugins/libpenciltool.so
/usr/lib/tupi/plugins/libpolylinetool.so
/usr/lib/tupi/plugins/libpositiontool.so
/usr/lib/tupi/plugins/librotationtool.so
/usr/lib/tupi/plugins/libscaletool.so
/usr/lib/tupi/plugins/libschemetool.so
/usr/lib/tupi/plugins/libselecttool.so
/usr/lib/tupi/plugins/libsheartool.so
/usr/lib/tupi/plugins/libsmilexportplugin.so
/usr/lib/tupi/plugins/libtexttool.so
/usr/lib/tupi/plugins/libviewtool.so
/usr/share/applications/tupi.desktop
/usr/share/doc/tupi/changelog.Debian.gz
/usr/share/doc/tupi/changelog.gz
/usr/share/doc/tupi/copyright
/usr/share/man/man1/tupi.1.gz
/usr/share/menu/tupi
/usr/share/pixmaps/tupi.png
/usr/share/pixmaps/tupi_32x32.xpm

Changelog

2012-06-05 - Dmitry Smirnov <onlyjob@member.fsf.org>
tupi (0.1+git12-6) unstable; urgency=low
* new patch for ruby1.9 compatibility (Closes: #676121)
* removed '©' characters from debian/copyright
* debian source compression to '.xz'
* DM-Upload-Allowed: yes! (Thanks to Aron Xu)
2012-03-01 - Dmitry Smirnov <onlyjob@member.fsf.org>
tupi (0.1+git12-5) unstable; urgency=low
* [patch] desktop icon replaced with smaller one
(Closes: #660933 "too big menu icon makes menu very slow")
* [patch] "Encoding=UTF-8" removed from .desktop file (lintianisation)
* d-control: standards to current 3.9.3
* d-copyright: DEP-5 URL is updated
2012-02-18 - Dmitry Smirnov <onlyjob@member.fsf.org>
tupi (0.1+git12-4) unstable; urgency=low
* Fix upgrade for versions prior to 0.1+git12-3 by adding Breaks/Replaces
(Closes: #660329 "Conflicts/Replaces missing in tupi-data")
2012-02-03 - Dmitry Smirnov <onlyjob@member.fsf.org>
tupi (0.1+git12-3) unstable; urgency=medium
* patch for FTBFS on arm(el|hf), thanks to peter green
(Closes: #658422 "FTBFS on armel and armhf")
* patch to fix path-to-executable in crash handler
* new tupi-dbg package
* compat & debhelper to version 9
* debian/rules:
+ give '-silent' to lupdate
+ print LDFLAGS
+ --with-debug
2012-01-25 - Dmitry Smirnov <onlyjob@member.fsf.org>
tupi (0.1+git12-2) unstable; urgency=low
* corrected binary installation path argument for 'configure' script
* added symbolic link for crash handler (fixes relaunch button)
* added symbolic link for examples (sample project)
* qt4-linguist-tools added to Build-Depends
* debian/rules
+ remove .qm files by clean rule
+ regenerate .qm files (translation binaries) during build
+ refreshing .ts files (translation sources) during build
+ updated get-orig-source
* fixed de_DE translation (Closes: #657427 "Crash with LANG="de_DE.UTF-8")
2012-01-12 - Dmitry Smirnov <onlyjob@member.fsf.org>
tupi (0.1+git12-1) unstable; urgency=low
* Debian release. (Closes: #650734, #619741)
* New upstream release (2012-01-01)
* debian/control:
+ Replaces: ktoon
+ Long description kindly provided by upstream
* debian/rules
+ clean autogenerated files
+ provide LDFLAGS / --as-needed to avoid needless linking
* debian/copyright: reformatting & update
* debian/ cleanup
* patch to fix FTBFS with libav-0.8
(thanks to Gustav Gonzalez)
* data separated into tupi-data package
(as suggested by Aron Xu)
2011-11-29 - Dmitry Smirnov <onlyjob@member.fsf.org>
tupi (0.1+git11-1) UNRELEASED; urgency=low
* New upstream release (2011-11-28)

See Also

Package Description
turnin-ng_1.1-1_all.deb assignment submitter and manager
turtleart_98-1_all.deb a LOGO-like tool for teaching programming
tuxcmd-modules_0.6.70+ds-4_i386.deb VFS modules for tuxcmd file manager
tuxcmd_0.6.70+dfsg-1_i386.deb twin-panel (commander-style) file manager using GTK+ 2
tuxfootball_0.3.1-2_i386.deb great 2D soccer (sometimes called football) game
tuxguitar-alsa_1.2-13+deb7u1_i386.deb tuxguitar plugin for sound playback using ALSA
tuxguitar-fluidsynth_1.2-13+deb7u1_i386.deb tuxguitar plugin for sound playback using fluidsynth
tuxguitar-jack_1.2-13+deb7u1_i386.deb tuxguitar plugin for sound playback using JACKD
tuxguitar-jsa_1.2-13+deb7u1_all.deb tuxguitar plugin for sound playback using Java Sound API
tuxguitar-oss_1.2-13+deb7u1_i386.deb tuxguitar plugin for sound playback using OSS
tuxguitar_1.2-13+deb7u1_all.deb Multitrack guitar tablature editor and player (gp3 to gp5)
tuxmath_1.8.0-4_i386.deb math game for kids with Tux
tuxonice-userui_1.1-1_i386.deb user-space interfaces for TuxOnIce
tuxpaint-config_0.0.12-3_i386.deb Configuration tool for Tux Paint
tuxpaint-data_0.9.21-1.1_all.deb Data files for Tux Paint, a paint program for children
Advertisement
Advertisement