trousers_0.3.9-3+wheezy1_i386.deb


Advertisement

Description

trousers - open-source TCG Software Stack (daemon)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name trousers
Package version 0.3.9
Package release 3+wheezy1
Package architecture i386
Package type deb
Installed size 450 B
Download size 151.72 KB
Official Mirror ftp.br.debian.org
TrouSerS is an implementation of the Trusted Computing Group's Software Stack
(TSS) specification. You can use TrouSerS to write applications that make use
of your TPM hardware. TPM hardware can create, store and use RSA keys securely
(without ever being exposed in memory), verify a platform's software state
using cryptographic hashes and more.
TrouSerS aims to be compliant with the 1.1b and 1.2 TSS specifications
available from the Trusted Computing Group website at
<http://www.trustedcomputinggroup.org/>.

Alternatives

Package Version Architecture Repository
trousers_0.3.9-3+wheezy1_amd64.deb 0.3.9 amd64 Debian Main
trousers - - -

Requires

Name Value
adduser -
libc6 >= 2.7
libssl1.0.0 >= 1.0.0
libtspi1 >= 0.3.1
lsb-base >= 3.0-6

Download

Type URL
Binary Package trousers_0.3.9-3+wheezy1_i386.deb
Source Package trousers

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install trousers deb package:
    # sudo apt-get install trousers

Files

Path
/etc/tcsd.conf
/etc/init.d/trousers
/lib/udev/rules.d/45-trousers.rules
/usr/sbin/ps_convert
/usr/sbin/ps_inspect
/usr/sbin/tcsd
/usr/share/doc/trousers/AUTHORS
/usr/share/doc/trousers/NICETOHAVES
/usr/share/doc/trousers/README.gz
/usr/share/doc/trousers/README.selinux
/usr/share/doc/trousers/TODO
/usr/share/doc/trousers/TODO.Debian
/usr/share/doc/trousers/changelog.Debian.gz
/usr/share/doc/trousers/changelog.gz
/usr/share/doc/trousers/copyright
/usr/share/doc/trousers/examples/system.data.auth
/usr/share/doc/trousers/examples/system.data.noauth
/usr/share/lintian/overrides/trousers
/usr/share/man/man5/tcsd.conf.5.gz
/usr/share/man/man8/tcsd.8.gz

Changelog

2013-02-18 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.9-3+wheezy1) testing-proposed-updates; urgency=low
* Reload udev rules before triggering event during postinst
(Closes: #581505)
2012-07-05 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.9-3) unstable; urgency=low
* Fix regression introduced in previous patch, preventing removal
(Closes: #680375)
2012-07-04 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.9-2) unstable; urgency=low
* Add workaround for upgrade failure for versions before 0.3.8-3
(Closes: #679621)
2012-06-18 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.9-1) unstable; urgency=low
* Imported Upstream version 0.3.9
* Refreshed Debian patches
* Removed patch 04-gcc46.patch, not required anymore
2012-06-16 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.8-3) unstable; urgency=low
* Fix typo in init script (Closes: #676828)
* Really save the pid of the daemon in /var/run.tcsd.pid (Closes: #676829)
2012-04-05 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.8-2) unstable; urgency=low
* Add 05-gcc47.patch to fix FTBFS with gcc 4.7 (Closes: #667400)
2012-02-26 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.8-1) unstable; urgency=low
* Imported Upstream version 0.3.8
* Switch to DH version 9
- Enable multiarch support
- Enable hardening flags
* Bump Standards Version to 3.9.3
* Update symbols file
* Trigger udev to fix device permissions when installing daemon
(Closes: #659872)
Thanks to Laurent Bigonville for the patch.
2011-12-17 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.7-2) unstable; urgency=low
* Apply following patches, thanks to Laurent Bigonville:
* Add $network to init script depends (Closes: #649954)
* Do not use --background in init script (Closes: #649901)
* Also add --oknodo on start
2011-11-21 - Pierre Chifflier <pollux@debian.org>
trousers (0.3.7-1) unstable; urgency=low
* Imported Upstream version 0.3.7
* Adopt package (set new maintainer) (Closes: #543932)
* Add pkg-config to build-depends
* Update symbols for libtspi1
* Use dh --with autoreconf
* Update patches to work with dh_autoreconf
2011-08-22 - Regis Boudin <regis@debian.org>
trousers (0.3.5-4) unstable; urgency=low
* QA upload.
* Bum Strandards-Version to 3.9.2.
* Remove la file completely. Pass -X.la to dh_install to not fail.

See Also

Package Description
trovacap-data_0.2.2-1_all.deb tool to find Italian ZIP codes - ZIP codes database
trovacap_0.2.2-1_i386.deb tool to find Italian ZIP codes
trscripts_1.16_all.deb Scripts for reencoding text files and BDF-fonts
trueprint_5.3-4_i386.deb pretty printing of source code
trustedqsl_1.13-3_i386.deb QSL log signing for the Logbook of the World (LoTW)
tryton-client_2.2.3-1+deb7u1_all.deb Tryton Application Platform (Client)
tryton-modules-account-be_2.2.0-2_all.deb Tryton Application Platform (Financial and Accounting Module for Belgium)
tryton-modules-account-de-skr03_2.2.0-2_all.deb Tryton Application Platform (Financial and Accounting Module for Germany)
tryton-modules-account-invoice-history_2.2.0-2_all.deb Tryton Application Platform (Financial and Accounting Module)
tryton-modules-account-invoice-line-standalone_2.2.0-2_all.deb Tryton Application Platform (Financial and Accounting Module)
tryton-modules-account-invoice_2.2.2-2_all.deb Tryton Application Platform (Financial and Accounting Module)
tryton-modules-account-product_2.2.0-2_all.deb Tryton Application Platform (Financial and Accounting Module)
tryton-modules-account-statement_2.2.1-1_all.deb Tryton Application Platform (Financial and Accounting Module)
tryton-modules-account_2.2.3-1_all.deb Tryton Application Platform (Financial and Accounting Module)
tryton-modules-all_16_all.deb Tryton Application Platform (modules metapackage)
Advertisement
Advertisement