tk-dev_8.5.0-2.1_all.deb


Advertisement

Description

tk-dev - The Tk toolkit for Tcl and X11 (default version) - development files

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name tk-dev
Package version 8.5.0
Package release 2.1
Package architecture all
Package type deb
Installed size 6 B
Download size 4.40 KB
Official Mirror ftp.br.debian.org
Tk is a cross-platform graphical toolkit which provides the Motif
look-and-feel and is implemented using the Tcl scripting language.
This package is a dependency package, which depends on Debian's default
Tk version (currently 8.5).

Alternatives

Package Version Architecture Repository
tk-dev_8.5.0-2.1_all.deb 8.5.0 all Debian Main
tk-dev - - -

Requires

Name Value
tcl-dev = 8.5.0-2.1
tk = 8.5.0-2.1
tk8.5-dev >= 8.5.0-1

Download

Type URL
Binary Package tk-dev_8.5.0-2.1_all.deb
Source Package tcltk-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install tk-dev deb package:
    # sudo apt-get install tk-dev

Files

Path
/usr/include/tk
/usr/lib/libtk.a
/usr/lib/libtk.so
/usr/lib/libtkstub.a
/usr/lib/tkConfig.sh
/usr/share/doc/tk-dev/README.Debian
/usr/share/doc/tk-dev/changelog.Debian.gz
/usr/share/doc/tk-dev/copyright

Changelog

2013-03-19 - Anton Gladky <gladk@debian.org>
tcltk-defaults (8.5.0-2.1) unstable; urgency=low
* Non-maintainer upload.
* Add Replaces/Conflicts to tcl-dev against tk-tile. (Closes: #703330)
2011-02-06 - Sergei Golovan <sgolovan@debian.org>
tcltk-defaults (8.5.0-2) unstable; urgency=low
* Upload of 8.5 to unstable (closes: #515984).
* Changed symlink targets for /usr/lib/tclConfig.sh and /usr/lib/tkConfig.sh
to /usr/lib/tcl8.5/tclConfig.sh and /usr/lib/tk8.5/tkConfig.sh because
the latter files are architecture dependent.
* Added ${misc:Depends} to the binary packages dependency lists because
the package is built using debhelper.
* Bumped standards version to 3.9.1. No changes.
2010-03-17 - Francesco Paolo Lovergine <frankie@debian.org>
tcltk-defaults (8.5.0-1) experimental; urgency=low
[ Sergei Golovan ]
* Changed the default Tcl/Tk version to 8.5. This means depending on
tcl8.5 and tk8.5 packages (closes: #515984, #516178).
* Removed useless call to dh_desktop in debian/rules.
* Made tcltk-depends adding substvars only if they are present in
debian/control file to suppress dh_gencontrol warnings about unused
substitution variables.
* Added note about ${tclsh:Depends} and ${wish:Depends} to tcltk-depends
manpage.
[ Francesco Paolo Lovergine ]
* Bumped standards version to 3.8.4. No changes.
2008-01-30 - Sergei Golovan <sgolovan@debian.org>
tcltk-defaults (8.4.16-2) unstable; urgency=low
* Fixed clean rule in debian/rules.
* Removed empty directory /usr/share/aclocal from tk-dev package.
* Bumped standards version to 3.7.3.
* Overridden lintian warnings about conflicts of tcl and tk with multiple
versions of Tcl and Tk packages since these conflicts just show which
versions became Tcl/Tk policy compliant.
2007-10-19 - Sergei Golovan <sgolovan@debian.org>
tcltk-defaults (8.4.16-1) unstable; urgency=low
* Initial release of the default Tcl/Tk packages. Corresponds to tcl8.4
8.4.16-2 and tk8.4 8.4.16-2 (and newer).

See Also

Package Description
tk-doc_8.5.0-2.1_all.deb The Tk toolkit for Tcl and X11 (default version) - manual pages
tk-html3_3.0~fossil20110109-2_i386.deb Render HTML and CSS content with tk
tk-table_2.10-1_i386.deb Table extension for Tcl/Tk
tk-tktray_1.3.9-2_i386.deb Freedesktop system tray icon support for Tcl/Tk on X11
tk2_1.1-9.1_all.deb Tk GUI for the ICOM IC-R2 receiver
tk5_0.6-6.1_all.deb Experimental Software for the ICOM IC-R5 Receiver
tk707_0.7.21-9.1_i386.deb drum sequencer for a sound card or MIDI device
tk8.4-dev_8.4.19-5_i386.deb Tk toolkit for Tcl and X11, v8.4 - development files
tk8.4-doc_8.4.19-5_all.deb Tk toolkit for Tcl and X11, v8.4 - manual pages
tk8.4_8.4.19-5_i386.deb Tk toolkit for Tcl and X11, v8.4 - run-time files
tk8.5-dev_8.5.11-2_i386.deb Tk toolkit for Tcl and X11, v8.5 - development files
tk8.5-doc_8.5.11-2_all.deb Tk toolkit for Tcl and X11, v8.5 - manual pages
tk8.5_8.5.11-2_i386.deb Tk toolkit for Tcl and X11, v8.5 - run-time files
tk_8.5.0-2.1_all.deb The Tk toolkit for Tcl and X11 (default version) - run-time files
tkabber-plugins_0.11.1-1_all.deb standard plugins for Tkabber, an XMPP (Jabber) client
Advertisement
Advertisement