texmaker_3.3.4-1_i386.deb


Advertisement

Description

texmaker - cross-platform LaTeX editor

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name texmaker
Package version 3.3.4
Package release 1
Package architecture i386
Package type deb
Installed size 4.44 KB
Download size 2.00 MB
Official Mirror ftp.br.debian.org
Texmaker is a clean, highly configurable LaTeX editor with good hot key
support and extensive LaTeX documentation. Texmaker integrates many tools
needed to develop documents with LaTeX, in just one application. It has
some nice features such as syntax highlighting, insertion of 370 mathematical
symbols with only one click, and "structure view" of the document for easier
navigation.

Alternatives

Package Version Architecture Repository
texmaker_3.3.4-1_amd64.deb 3.3.4 amd64 Debian Main
texmaker - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:4.1.1
libpoppler-qt4-3 >= 0.18
libqt4-network >= 4:4.5.3
libqt4-xml >= 4:4.5.3
libqtcore4 >= 4:4.8.0
libqtgui4 >= 4:4.8.0
libqtwebkit4 >= 2.1.0~2011week13
libstdc++6 >= 4.1.1
texmaker-data = 3.3.4-1
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package texmaker_3.3.4-1_i386.deb
Source Package texmaker

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install texmaker deb package:
    # sudo apt-get install texmaker

Files

Path
/usr/bin/texmaker
/usr/share/applications/texmaker.desktop
/usr/share/doc/texmaker/AUTHORS
/usr/share/doc/texmaker/changelog.Debian.gz
/usr/share/doc/texmaker/changelog.gz
/usr/share/doc/texmaker/copyright
/usr/share/doc/texmaker/html/index.html
/usr/share/man/man1/texmaker.1.gz
/usr/share/menu/texmaker
/usr/share/pixmaps/texmaker.png
/usr/share/pixmaps/texmaker.xpm

Changelog

2012-06-01 - Andreas Tille <tille@debian.org>
texmaker (3.3.4-1) unstable; urgency=low
* New upstream version (patches updated)
* debhelper 9 (control+compat)
(hardening flags probably need patching build system)
2012-03-12 - Andreas Tille <tille@debian.org>
texmaker (3.3.2-1) unstable; urgency=low
* New upstream version (patches updated) 
2012-02-28 - Andreas Tille <tille@debian.org>
texmaker (3.3.1-1) unstable; urgency=low
* New upstream version (incl. adapting patch)
* debian/control: Standards-Version: 3.9.3 (no changes needed)
* Removed quilt dependency (control+rules)
* debian/copyright: Fixed DEP5 issues using
cme fix dpkg-copyright
2012-02-10 - Andreas Tille <tille@debian.org>
texmaker (3.2.2-1) unstable; urgency=low
* New upstream version
* debian/control: Recommends: ibus-qt4 as advised on upstream download
page
2011-12-23 - Andreas Tille <tille@debian.org>
texmaker (3.2-1) unstable; urgency=low
* New upstream version (updated patches and removed patches
applied upstream)
2011-11-08 - Andreas Tille <tille@debian.org>
texmaker (3.1-1) unstable; urgency=low
* New upstream version
Closes: #647948
* Fixed Vcs fields
* debian/patches/10_spelling_dict.patch: Set variable provided by
upstream in config instead of patching real code
* debian/patches/20_spelling_default_dict.patch: Seems that there
is another place to fix spelling directory:
Closes: #638286
2011-05-06 - Andreas Tille <tille@debian.org>
texmaker (3.0.2-2) unstable; urgency=low
* Enable separate arch all/any builds as it was requested
by Ubuntu (Thanks for the patch to Maia Kozheva <sikon@ubuntu.com>)
Closes: #625819
2011-04-30 - Andreas Tille <tille@debian.org>
texmaker (3.0.2-1) unstable; urgency=low
* New upstream version
* Standards-Version: 3.9.2 (no changes needed)
* debian/patches/20_gcc_4.6.patch: Fix FTBFS with 4.6 (thanks for the
patch to Maia Kozheva <sikon@ubuntu.com>)
Closes: #624611
* debian/rules: Make sure icons are properly named (thanks for the
patch to Maia Kozheva <sikon@ubuntu.com>)
Closes: #624613
2011-04-05 - Andreas Tille <tille@debian.org>
texmaker (3.0-1) unstable; urgency=low
* New upstream version
(adapted patch, removed patches applied upstream)
* debian/texmaker-data.install: Adapt to new version
* debian/control: Added missing
Depends: texmaker-data (= ${source:Version})
2011-03-14 - Andreas Tille <tille@debian.org>
texmaker (2.3-1) unstable; urgency=low
* New upstream version (adapted patches)
* Build-Depends: libqtwebkit-dev =adapted Ubuntu patch which
Closes: #618140
* Debhelper 8 (control+compat)

See Also

Package Description
texpower_2012.20120611-2_all.deb TeX Live: transitional dummy package
texstudio_2.3+debian-3_i386.deb Latex Editor
textdraw_0.2-2_i386.deb Tool to draw/modify/move geometric figures & text for ASCII art
textedit.app_4.0+20061029-3.4_i386.deb Text editor for GNUstep
texworks-help-en_0.5~svn1007-1_all.deb English help files for TeXworks
texworks-scripting-lua_0.5~svn1007-1_i386.deb Plugin to bring Lua scripting to TeXworks
texworks-scripting-python_0.5~svn1007-1_i386.deb Plugin to bring Python scripting to TeXworks
texworks_0.5~svn1007-1_i386.deb Environment for authoring TeX (LaTeX, ConTeXt, etc) documents
tf5_5.0beta8-4+b1_i386.deb text-based MU* and chatserver client
tf_4.0s1-17_i386.deb Tinyfugue MUD client for TinyMUDs, DikuMUDs, and LPMUDs
tfdocgen_1.0-1_i386.deb TiLP framework documentation generator
tftp-hpa_5.2-4_i386.deb HPA's tftp client
tftp_0.17-18_i386.deb Trivial file transfer protocol client
tftpd-hpa_5.2-4_i386.deb HPA's tftp server
tftpd_0.17-18_i386.deb Trivial file transfer protocol server
Advertisement
Advertisement