swapspace_1.10-4_i386.deb


Advertisement

Description

swapspace - dynamic swap space manager

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name swapspace
Package version 1.10
Package release 4
Package architecture i386
Package type deb
Installed size 140 B
Download size 28.61 KB
Official Mirror ftp.br.debian.org
Small, stable system add-on that continuously and automatically adapts
available virtual memory space to your actual memory needs.  Claims disk space
for use as swap space when needed; frees it up for use by the filesystem when
not needed.

Alternatives

Package Version Architecture Repository
swapspace_1.10-4_amd64.deb 1.10 amd64 Debian Main
swapspace - - -

Requires

Name Value
libc6 >= 2.7-1
lsb-base >= 3.2-14

Conflicts

Name Value
swapd -

Download

Type URL
Binary Package swapspace_1.10-4_i386.deb
Source Package swapspace

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install swapspace deb package:
    # sudo apt-get install swapspace

Files

Path
/etc/swapspace.conf
/etc/init.d/swapspace
/usr/sbin/swapspace
/usr/share/doc/swapspace/README.gz
/usr/share/doc/swapspace/changelog.Debian.gz
/usr/share/doc/swapspace/copyright
/usr/share/man/man8/swapspace.8.gz

Changelog

2008-09-17 - Eugene V. Lyubimkin <jackyf.devel@gmail.com>
swapspace (1.10-4) unstable; urgency=low
* New maintainer. (Closes: #499116)
* debian/rules:
- Converted to debhelper v7.
- Some cleanup.
- Turned off verbose building mode.
- Moved dh_installman parameter to debian/manpages.
- Added quilt makefile.
- Made 'nostrip' and 'noopt' in DEB_BUILD_OPTIONS really working.
* debian/control:
- Added build-dependency on quilt.
- Bumped debhelper dependency to (>= 7).
- Bumped 'Standards-Version' to 3.8.0.
- Added dependency on lsb-base (>= 3.2-14) for status_of_proc in
initscript.
- Short descriptions now starts with the non-capital letter.
- As package conflicts with swapd that is optional, swapspace went to
extra (by policy).
* debian/copyright:
- Renewed download place.
* debian/swapspace.init:
- Implemented 'status' option as required by LSB.
- Replaces 'echo's by proper LSB functions lsb_daemon_msg, lsb_end_msg.
- Removed displayed by swapspace daemon output as it breaks LSB script
output.
- Added '--oknodo' option to STARTCMD to make 'start' return 0 when daemon
is already running.
* debian/patches:
- Started to use quilt patching system.
- Converted useful stuff from diff.gz to 100-makefile-debian-flags.patch.
- 100-makefile-debian-flags.patch: corrected to use Debian-specified build
flags.
* debian/watch:
- Added.
* debian/compat:
- Bumped to 7.
2008-04-17 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.10-3) unstable; urgency=low
* Fixed FTBFS: cc1: error: unrecognized command line option. Closes: #475988
2008-04-05 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.10-2) unstable; urgency=low
* NMU acknowledgement. Closes: #468748, #438078 
* Updated homepage. Closes: #474100
* Fixed the following lintian messages:
- swapspace source: debian-rules-ignores-make-clean-error line 44
- swapspace source: out-of-date-standards-version 3.7.2 (current is 3.7.3)
- swapspace: description-contains-homepage
2008-04-04 - Petter Reinholdtsen <pere@debian.org>
swapspace (1.10-1.1) unstable; urgency=low
* Non-maintainer upload to solve release goal.
* Add LSB dependency header to init.d scripts (Closes: #468748).
* Make sure package build properly with DEB_BUILD_OPTIONS=nostrip
(Closes: #438078).
2006-08-16 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.10-1) unstable; urgency=low
* New upstream release.
- Fixed "dies when memory low". Closes: #383214.
2006-08-14 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.8-2) unstable; urgency=low
* Applied patch from upstream author to deal with the format of
/proc/meminfo when it doesn't end with a unit, like "kB".
Closes: #377449.
2006-07-22 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.8-1) unstable; urgency=low
* New upstream release.
2006-07-09 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.6-2) unstable; urgency=high
* Fixed "Fails to start with /proc/meminfo parse error", closes: #377449.
Patch by Robert August Vincent II <bob@html.com>.
2006-06-15 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.6-1) unstable; urgency=low
* New upstream release.
2006-06-13 - Anibal Monsalve Salazar <anibal@debian.org>
swapspace (1.5-1) unstable; urgency=low
* Initial debian release, closes: #322282.

See Also

Package Description
swat_3.6.6-6+deb7u7_i386.deb Samba Web Administration Tool
swatch_3.2.3-1_all.deb Log file viewer with regexp matching, highlighting & hooks
swath_0.4.3-3_i386.deb Thai word segmentation program
swe-basic-data_1.77.00.0005-2_all.deb basic data files for the libswe package
swe-standard-data_00004-1_all.deb standard data for the Swiss Ephemeris
sweep-dev_0.9.3-6_all.deb Audio editor and live playback tool (development)
sweep_0.9.3-6_i386.deb Audio editor and live playback tool
sweeper_4.8.4-1_i386.deb history and temporary file cleaner
sweethome3d_3.5+dfsg-1_all.deb Interior 2D design application with 3D preview
swell-foop_3.4.2-3_i386.deb Colored ball puzzle game
swfdec-gnome_0.8.11~git20120629-1+deb7u1_all.deb dummy package for transition to Gnash
swfdec-mozilla_0.8.11~git20120629-1+deb7u1_all.deb dummy package for transition to browser-plugin-gnash
swfmill_0.3.2-1_i386.deb xml2swf and swf2xml processor
swftools_0.9.2+ds1-3_i386.deb Collection of utilities for SWF file manipulation/creation
swh-lv2_1.0.15+20111107.gitec6b85e-1_i386.deb Steve Harris's SWH plugins ported to LV2
Advertisement
Advertisement