subtitleeditor_0.33.0-1_i386.deb


Advertisement

Description

subtitleeditor - Graphical subtitle editor with sound waves representation

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name subtitleeditor
Package version 0.33.0
Package release 1
Package architecture i386
Package type deb
Installed size 996 B
Download size 281.84 KB
Official Mirror ftp.br.debian.org
Subtitle Editor is a GTK+2 tool to edit subtitles.  It can be used for new
subtitles or as a tool to transform, edit, correct and refine existing
subtitles.
This program also shows sound waves, which makes it easier to synchronise
subtitles to voices.
This package has this features
o Multiple document interface.
o Internationalization support.
o Video player integrated in the main window (based on GStreamer).
o Can play preview with external video player (using MPlayer or other).
o Style Editor.
o Move subtitle.
o Scale.
o Split and joint subtitle.
o Edit text and adjust time (start, end).
o Generate Waveform from Video.
Supported formats:
o Sub Station Alpha.
o Advanced Sub Station Alpha.
o SubRip.
o MicroDVD.
o MPL2.
o MPsub (MPlayer subtitle).
o SubViewer 2.0.
o Plain-Text.
o Adobe Encore DVD.

Alternatives

Package Version Architecture Repository
subtitleeditor_0.33.0-1_amd64.deb 0.33.0 amd64 Debian Main
subtitleeditor - - -

Requires

Name Value
gstreamer0.10-plugins-base -
gstreamer0.10-plugins-good -
gstreamer0.10-x -
libatkmm-1.6-1 >= 2.22.1
libc6 >= 2.3.6-6~
libcairomm-1.0-1 >= 1.6.4
libenchant1c2a -
libgcc1 >= 1:4.1.1
libglademm-2.4-1c2a >= 2.6.0
libglib2.0-0 >= 2.12.0
libglibmm-2.4-1c2a >= 2.31.22
libgstreamer-plugins-base0.10-0 >= 0.10.12
libgstreamer0.10-0 >= 0.10.9
libgtk2.0-0 >= 2.24.0
libgtkmm-2.4-1c2a >= 1:2.24.0
libpangomm-1.4-1 >= 2.27.1
libsigc++-2.0-0c2a >= 2.0.2
libstdc++6 >= 4.6
libsubtitleeditor0 = 0.33.0-1

Download

Type URL
Binary Package subtitleeditor_0.33.0-1_i386.deb
Source Package subtitleeditor

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install subtitleeditor deb package:
    # sudo apt-get install subtitleeditor

Files

Path
/usr/bin/subtitleeditor
/usr/share/applications/subtitleeditor.desktop
/usr/share/doc/subtitleeditor/README
/usr/share/doc/subtitleeditor/TODO
/usr/share/doc/subtitleeditor/changelog.Debian.gz
/usr/share/doc/subtitleeditor/changelog.gz
/usr/share/doc/subtitleeditor/copyright
/usr/share/icons/hicolor/16x16/apps/subtitleeditor.png
/usr/share/icons/hicolor/22x22/apps/subtitleeditor.png
/usr/share/icons/hicolor/24x24/apps/subtitleeditor.png
/usr/share/icons/hicolor/32x32/apps/subtitleeditor.png
/usr/share/icons/hicolor/scalable/apps/subtitleeditor.svg
/usr/share/locale/ca/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/cs/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/da/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/de/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/en_GB/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/es/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/fr/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/gl/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/hu/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/it/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/nl/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/pl/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/pt/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/pt_BR/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/pt_PT/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/ru/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/sr/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/tr/LC_MESSAGES/subtitleeditor.mo
/usr/share/locale/zh_CN/LC_MESSAGES/subtitleeditor.mo
/usr/share/man/man1/subtitleeditor.1.gz
/usr/share/menu/subtitleeditor
/usr/share/pixmaps/subtitleeditor.svg
/usr/share/pixmaps/subtitleeditor.xpm

Changelog

2012-03-31 - Philip Rinn <rinni@gmx.net>
subtitleeditor (0.33.0-1) unstable; urgency=low
* New maintainer.
* New upstream release:
+ Remove all patches
* Bump Standards-Version to 3.9.3 (no changes necessary).
* Bump debhelper compat to 9.
* Emptying the dependency_libs field in .la files.
* Convert to 3.0 (quilt) source format (closes: #664344):
+ Remove build dependency dpatch
* Convert debian/copyright to Machine-readable format (DEP-5).
* Add debian/patches/01-glib-single-include.patch:
+ Don't include invidiual glib headers (closes: #665613)
* Enable hardened build flags.
2009-12-24 - Filippo Giunchedi <filippo@debian.org>
subtitleeditor (0.30.0-1.1) unstable; urgency=low
* Non-maintainer upload.
* debian/patches/fix_gcc_4.4_ftbfs.dpatch: Fix FTBFS with gcc 4.4 new
headers, thanks Martin Michlmayr (Closes: #526155)
2009-03-19 - Anibal Avelar <aavelar@cofradia.org>
subtitleeditor (0.30.0-1) unstable; urgency=low
* New upstream release (Closes: #492595, #507687):
+ Fixed many upstream bugs
+ Translations update
* Updated the debian/control file with new description
* Forced the libpcre3-dev version to 7.6-2 to avoid the old bug fixed in
this version (Closes: #464704)
* Updated the debian/watch file to point to the new upstream version 
* Fixed the URL in debian/watch with a better format
* Added a patch to fix the bad linkage with some libraries.
* Added the dependency with the intltool package
* Added the dependency with the libglibmm-2.4-dev package
* Added the dependency with dpatch package to apply the linkage patch.
* Removed the option --enable-aspell from debian/rules in configure line.
* Added packages libsubtitleeditor0 and libsubtitleeditor-dev because 
now the program creates libraries like /usr/lib/*.so.*.
* Updated debian/rules to add the dh_install --sourcedir support.
* Updated to Standards-Version 3.8.1
+ Added a debian/libsubtitleeditor0.postinst file due a ldconfig warning 
+ Added a subtitleeditor.desktop file without the deprecated Encoding key 
+ Added a call to dpkg-gensymbols in debian/rules to avoid warnings about 
"unable to find dependency information for shared library"
2008-05-26 - Anibal Avelar <aavelar@cofradia.org>
subtitleeditor (0.21.1-2) unstable; urgency=low
* Added the subtitleeditor.desktop file coming from the upstream program
removing the debian/subtitleeditor.desktop file.
* Removed the dependency with the autotools-dev package in debian/control. 
It's totally unnecessary.
* Cleaned the debian/dirs file. Were removed all dirs below /usr dir.
* Removed the versioned dependency in debian/control to the libpcre3-dev 
package to avoid the problem with different version on sid and lenny.
* Cleaned the debian/copyright file to be brief.
* Fixed a little grammar problem uploaded the latest time in the 
debian/changelog file.
2008-05-22 - Anibal Avelar <aavelar@cofradia.org>
subtitleeditor (0.21.1-1) unstable; urgency=low
* New upstream release:
+ Fixed the debian/subtitleeditor.desktop file.
(Closes: #480481)
+ Removed the patch for gcc 4.3 due to the program changed the layout.
* Removed the versioned dependency in debian/control to the libpcre3-dev 
package to avoid the problem with different version on sid and lenny.
(Closes: #464704)
* Updated the debian/wach file to point to the new upstream path.
* Removed the patch-system because it isn't used by the moment. Removed the
dependency with dpatch in the debian/control file.
* Added the dependencies with the packages gstreamer0.10-x,
gstreamer0.10-plugins-base and libgstreamer-plugins-base0.10-0 
to the binary package. The three packages are necessary in runtime to 
get a good performance.
* Added the "Suggests" section in the debian/control file.

See Also

Package Description
subtle_0.11.3224-xi-1_i386.deb grid-based manual tiling window manager
subunit_0.0.8+bzr176-1_all.deb command line tools for processing Subunit streams
subversion-tools_1.6.17dfsg-4+deb7u10_all.deb Assorted tools related to Subversion
subversion_1.6.17dfsg-4+deb7u10_i386.deb Advanced version control system
suck_4.3.2-11_i386.deb small newsfeed from an NNTP server with standard NNTP commands
suckless-tools_38-2_i386.deb simple commands for minimalistic window managers
sucrack_1.2.3-0.9_i386.deb multithreaded su bruteforcer
sucrose-0.96_0.96.1-2.1_all.deb Sugar graphical shell - Sucrose 0.96
sudo-ldap_1.8.5p2-1+nmu3+deb7u1_i386.deb Provide limited super user privileges to specific users
sudo_1.8.5p2-1+nmu3+deb7u1_i386.deb Provide limited super user privileges to specific users
sudoku_1.0.1-4_i386.deb console based sudoku
sugar-artwork-0.84_0.84.4-3_i386.deb Sugar graphical shell - artwork
sugar-artwork-0.88_0.88.1-4_i386.deb Sugar graphical shell - artwork
sugar-artwork-0.96_0.96.2-1_i386.deb Sugar graphical shell - artwork
sugar-calculate-activity_40-2_all.deb calculate activity for the Sugar graphical shell
Advertisement
Advertisement