ssvnc_1.0.29-2_i386.deb


Advertisement

Description

ssvnc - Enhanced TightVNC viewer with SSL/SSH tunnel helper

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name ssvnc
Package version 1.0.29
Package release 2
Package architecture i386
Package type deb
Installed size 1.20 KB
Download size 479.60 KB
Official Mirror ftp.br.debian.org
VNC stands for Virtual Network Computing. It is, in essence, a remote
display system which allows you to view a computing `desktop'
environment not only on the machine where it is running, but from
anywhere on the Internet and from a wide variety of machine
architectures.
SSVNC is two things:
* An enhanced version of the TightVNC client with support for more
encodings and color modes, support for x11vnc and UltraVNC
extensions, dynamic screen resizing, an improved popup menu, etc.
* A GUI that helps set up an SSL (using stunnel) or SSH tunnel to
connect to the VNC server through, as well as forwarding of ports for
audio (esound/aRts), SMB, CUPS etc.

Alternatives

Package Version Architecture Repository
ssvnc_1.0.29-2_amd64.deb 1.0.29 amd64 Debian Main
ssvnc - - -

Requires

Name Value
bind9-host -
host -
libc6 >= 2.7
libice6 >= 1:1.0.0
libjpeg8 >= 8c
libsm6 -
libssl1.0.0 >= 1.0.0
libx11-6 -
libxaw7 -
libxext6 -
libxmu6 -
libxpm4 -
libxt6 -
openssh-client -
openssl -
procps -
psmisc -
stunnel4 -
tk -
xterm -
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package ssvnc_1.0.29-2_i386.deb
Source Package ssvnc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ssvnc deb package:
    # sudo apt-get install ssvnc

Files

Path
/usr/bin/sshvnc
/usr/bin/ssvnc
/usr/bin/ssvncviewer
/usr/bin/tsvnc
/usr/lib/ssvnc/lim_accept.so
/usr/lib/ssvnc/sshvnc
/usr/lib/ssvnc/ssvnc
/usr/lib/ssvnc/ssvnc_cmd
/usr/lib/ssvnc/tsvnc
/usr/lib/ssvnc/ultravnc_dsm_helper
/usr/lib/ssvnc/unwrap.so
/usr/lib/ssvnc/vncstorepw
/usr/lib/ssvnc/vncviewer
/usr/lib/ssvnc/util/ss_vncviewer
/usr/lib/ssvnc/util/ssvnc.tcl
/usr/lib/ssvnc/util/stunnel-server.conf
/usr/lib/ssvnc/util/ultraftp.jar
/usr/share/applications/ssvnc.desktop
/usr/share/doc/ssvnc/README.gz
/usr/share/doc/ssvnc/README.src.gz
/usr/share/doc/ssvnc/ReleaseNotes.gz
/usr/share/doc/ssvnc/changelog.Debian.gz
/usr/share/doc/ssvnc/changelog.gz
/usr/share/doc/ssvnc/copyright
/usr/share/man/man1/sshvnc.1.gz
/usr/share/man/man1/ssvnc.1.gz
/usr/share/man/man1/ssvncviewer.1.gz
/usr/share/man/man1/tsvnc.1.gz

Changelog

2011-11-11 - Magnus Holmgren <holmgren@debian.org>
ssvnc (1.0.29-2) unstable; urgency=low
* Also get CPPFLAGS from dpkg-buildflags. Pass it as EXTRA_DEFINES to
vnc_unixsrc/*/Makefile.
2011-11-10 - Magnus Holmgren <holmgren@debian.org>
ssvnc (1.0.29-1) unstable; urgency=low
* New upstream release.
* Install ReleaseNotes as upstream changelog file.
* Simply build-depend on libjpeg-dev instead of libjpeg62-dev |
libjpeg-dev (Closes: #644808).
* Install a symlink in /usr/bin instead of including the main vncviewer
binary twice in the package.
* Add build-arch and build-indep targets to debian/rules.
* nostrip.patch: Remove strip command from the Makefile, allowing
DEB_BUILD_OPTONS=nostrip to work.
* Get CFLAGS and LDFLAGS from dpkg-buildflags.
* buildflags.patch: Pass CFLAGS and LDFLAGS through via ./Makefile as
CDEBUGFLAGS and LOCAL_LDFLAGS to vnc_unixsrc/*/Makefile. This results
in -fno-strict-aliasing (added by xmkmf by default) being dropped, but
that doesn't seem to cause any problems.
* format-security.patch: Fix some flaws uncovered by -Wformat-security.
* Bump Standards-Version to 3.9.2.
2011-02-06 - Magnus Holmgren <holmgren@debian.org>
ssvnc (1.0.28-1) unstable; urgency=low
* New upstream release (Closes: #592873, "Connection from UVNC
Single-Click does not start vncviewer when -acceptpopups is set").
* Convert to source format 3.0 (quilt), changing /bin/sh into /bin/bash
(see below) in the install target instead.
* debian/copyright: Update years of copyright; remove notice that the
UltraVNC DSM helper module is not included (which it is since
1.0.24-1).
* Remove redundant bash dependency; bash isn't going to be non-essential
any time soon.
* Up Standards-Version to 3.9.1.
2010-05-23 - Magnus Holmgren <holmgren@debian.org>
ssvnc (1.0.27-1) unstable; urgency=low
* New upstream release.
* bashisms.dpatch: Don't try to fix all bashisms; instead change /bin/sh
to /bin/bash and depend on bash, which is small in this context.
2010-02-06 - Magnus Holmgren <holmgren@debian.org>
ssvnc (1.0.25-1) unstable; urgency=low
* New upstream release.
* confusing_-h.dpatch and bashisms.dpatch: adjusted.
2009-10-31 - Magnus Holmgren <holmgren@debian.org>
ssvnc (1.0.24-1) unstable; urgency=low
* New upstream release.
* ssvnc -help now prints a help message instead of passing -help to the
tcl interpreter.
* confusing_-h.dpatch (new): Improve upstream's handling of -help a bit
(Closes: 544250).
* ultraftp_path.dpach (new): Use hardcoded (and correct for this
package) path to ultraftp.jar if SSVNC_ULTRA_FTP_JAR is unset, so that
file transfers work even if ssvncviewer is executed directly.
* bashisms.dpatch (new): Fix most bashisms (all that matter).
* Drop no_openssl.dpatch and build ultravnc_dsm_helper; OpenSSL
exception has been granted. Build-depend on libssl-dev.
* Promote stunnel4 from Recommends to Depends (Closes: #553411), depend
directly on openssl, depend on tk instead of tk8.4, and tweak java
recommendations.
* Add README.source.
* Bump Standards-Version to 3.8.3.
2009-08-01 - Magnus Holmgren <holmgren@debian.org>
ssvnc (1.0.23-1) unstable; urgency=low
* Initial release (Closes: #504134).

See Also

Package Description
stackapplet_1.4.0-2_all.deb panel applet to track reputation on StackExchange sites
staden-io-lib-utils_1.12.4-1_i386.deb programs for maniuplating DNA sequencing files
stalin_0.11-5_i386.deb An extremely aggressive Scheme compiler
stalonetray_0.8.1-1_i386.deb Standalone freedesktop.org and KDE systray implementation
stardata-common_0.8_i386.deb Common framework to manage astronomy packages
stardict-common_3.0.1-9.2_all.deb International dictionary - data files
stardict-czech_20110701-1_all.deb Stardict package for Czech dictionary of foreign words
stardict-gnome_3.0.1-9.2_i386.deb International dictionary for GNOME 2
stardict-gtk_3.0.1-9.2_i386.deb International dictionary written in GTK+ 2.x
stardict-plugin-espeak_3.0.1-9.2_i386.deb International dictionary - eSpeak TTS plugin
stardict-plugin-festival_3.0.1-9.2_i386.deb International dictionary - Festival TTS plugin
stardict-plugin-spell_3.0.1-9.2_i386.deb International dictionary - spell plugin
stardict-plugin_3.0.1-9.2_i386.deb International dictionary - common plugins
stardict-tools_3.0.2-3+b1_i386.deb dictionary conversion tools of stardict
stardict-xmlittre_1.0-1_all.deb French Littré dictionary for stardict
Advertisement
Advertisement