python-tweepy_1.7.1-2+deb7u1_all.deb


Advertisement

Description

python-tweepy - Twitter library for Python

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name python-tweepy
Package version 1.7.1
Package release 2+deb7u1
Package architecture all
Package type deb
Installed size 159 B
Download size 24.24 KB
Official Mirror ftp.br.debian.org
Tweepy is a Twitter and Identi.ca library for Python
that can be used in desktop and web applications. It has the
following features:
- OAuth support
- Covers the entire Twitter API
- Streaming API support
- Cache system (memory, file)
- Easy to use

Alternatives

Package Version Architecture Repository
python-tweepy_2.3-1~bpo70+1_all.deb 2.3 all Debian Backports Main
python-tweepy_2.3-1~bpo70+1_all.deb 2.3 all Debian Backports Main
python-tweepy_1.7.1-2+deb7u1_all.deb 1.7.1 all Debian Main
python-tweepy - - -

Requires

Name Value
python << 2.8
python >= 2.6.6-7~
python-oauth -

Download

Type URL
Binary Package python-tweepy_1.7.1-2+deb7u1_all.deb
Source Package tweepy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-tweepy deb package:
    # sudo apt-get install python-tweepy

Files

Path
/usr/lib/python2.6/dist-packages/tweepy/__init__.py
/usr/lib/python2.6/dist-packages/tweepy/api.py
/usr/lib/python2.6/dist-packages/tweepy/auth.py
/usr/lib/python2.6/dist-packages/tweepy/binder.py
/usr/lib/python2.6/dist-packages/tweepy/cache.py
/usr/lib/python2.6/dist-packages/tweepy/cursor.py
/usr/lib/python2.6/dist-packages/tweepy/error.py
/usr/lib/python2.6/dist-packages/tweepy/models.py
/usr/lib/python2.6/dist-packages/tweepy/parsers.py
/usr/lib/python2.6/dist-packages/tweepy/streaming.py
/usr/lib/python2.6/dist-packages/tweepy/utils.py
/usr/lib/python2.6/dist-packages/tweepy-1.7.1.egg-info/PKG-INFO
/usr/lib/python2.6/dist-packages/tweepy-1.7.1.egg-info/SOURCES.txt
/usr/lib/python2.6/dist-packages/tweepy-1.7.1.egg-info/dependency_links.txt
/usr/lib/python2.6/dist-packages/tweepy-1.7.1.egg-info/top_level.txt
/usr/lib/python2.6/dist-packages/tweepy-1.7.1.egg-info/zip-safe
/usr/lib/python2.7/dist-packages/tweepy/__init__.py
/usr/lib/python2.7/dist-packages/tweepy/api.py
/usr/lib/python2.7/dist-packages/tweepy/auth.py
/usr/lib/python2.7/dist-packages/tweepy/binder.py
/usr/lib/python2.7/dist-packages/tweepy/cache.py
/usr/lib/python2.7/dist-packages/tweepy/cursor.py
/usr/lib/python2.7/dist-packages/tweepy/error.py
/usr/lib/python2.7/dist-packages/tweepy/models.py
/usr/lib/python2.7/dist-packages/tweepy/parsers.py
/usr/lib/python2.7/dist-packages/tweepy/streaming.py
/usr/lib/python2.7/dist-packages/tweepy/utils.py
/usr/lib/python2.7/dist-packages/tweepy-1.7.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/tweepy-1.7.1.egg-info/SOURCES.txt
/usr/lib/python2.7/dist-packages/tweepy-1.7.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/tweepy-1.7.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/tweepy-1.7.1.egg-info/zip-safe
/usr/share/doc/python-tweepy/README
/usr/share/doc/python-tweepy/README.Debian
/usr/share/doc/python-tweepy/changelog.Debian.gz
/usr/share/doc/python-tweepy/changelog.gz
/usr/share/doc/python-tweepy/copyright
/usr/share/doc/python-tweepy/tests.py
/usr/share/pyshared/tweepy/__init__.py
/usr/share/pyshared/tweepy/api.py
/usr/share/pyshared/tweepy/auth.py
/usr/share/pyshared/tweepy/binder.py
/usr/share/pyshared/tweepy/cache.py
/usr/share/pyshared/tweepy/cursor.py
/usr/share/pyshared/tweepy/error.py
/usr/share/pyshared/tweepy/models.py
/usr/share/pyshared/tweepy/parsers.py
/usr/share/pyshared/tweepy/streaming.py
/usr/share/pyshared/tweepy/utils.py
/usr/share/pyshared/tweepy-1.7.1.egg-info/PKG-INFO
/usr/share/pyshared/tweepy-1.7.1.egg-info/SOURCES.txt
/usr/share/pyshared/tweepy-1.7.1.egg-info/dependency_links.txt
/usr/share/pyshared/tweepy-1.7.1.egg-info/top_level.txt
/usr/share/pyshared/tweepy-1.7.1.egg-info/zip-safe

Changelog

2014-04-10 - Miguel Landaeta <nomadium@debian.org>
tweepy (1.7.1-2+deb7u1) stable; urgency=low
* Change Twitter API defaults to be able to keep using the library
(Closes: #736174):
- On Tuesday, June 11, 2013 Twitter retired API v1.
https://blog.twitter.com/2013/api-v1-is-retired
- On January 14th, 2014, connections to api.twitter.com were
restricted to TLS/SSL connections only. 
https://dev.twitter.com/discussions/24239
2011-04-19 - Miguel Landaeta <miguel@miguel.cc>
tweepy (1.7.1-2) unstable; urgency=low
* Python transition:
- Add support for python2.7.
- Drop support for python2.5.
* Bump Standards-Version to 3.9.2. No changes were required.
2011-03-28 - Miguel Landaeta <miguel@miguel.cc>
tweepy (1.7.1-1) unstable; urgency=low
* Initial release. (Closes: #581602).

See Also

Package Description
python-twill_0.9-3_all.deb Simple scripting language for Web browsing
python-twisted-bin_12.0.0-1_i386.deb Event-based framework for internet applications
python-twisted-conch_12.0.0-1_all.deb Twisted SSH Implementation
python-twisted-core_12.0.0-1_all.deb Event-based framework for internet applications
python-twisted-libravatar_1.1-3_all.deb Libravatar module for Twisted
python-twisted-lore_12.0.0-1_all.deb Documentation generator with HTML and LaTeX support
python-twisted-mail_12.0.0-1_all.deb SMTP, IMAP and POP protocol implementation
python-twisted-names_12.0.0-1_all.deb DNS protocol implementation with client and server
python-twisted-news_12.0.0-1_all.deb NNTP protocol implementation with client and server
python-twisted-runner_12.0.0-1_i386.deb Process management, including an inetd server
python-twisted-web2_8.1.0-3_all.deb An HTTP/1.1 Server Framework
python-twisted-web_12.0.0-1_all.deb HTTP protocol implementation together with clients and servers
python-twisted-words_12.0.0-1_all.deb Chat and Instant Messaging
python-twisted_12.0.0-1_all.deb Event-based framework for internet applications (dependency package)
python-txaws_0.2.3-1_all.deb Twisted-based Asynchronous Libraries for Amazon Web Services
Advertisement
Advertisement