python-turbogears2_2.1.5-2_all.deb


Advertisement

Description

python-turbogears2 - Python web application framework

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name python-turbogears2
Package version 2.1.5
Package release 2
Package architecture all
Package type deb
Installed size 364 B
Download size 89.71 KB
Official Mirror ftp.br.debian.org
TurboGears2 is a framework to develop web applications in Python.
TurboGears2 application are developed according to a
model-view-controller (MVC) architecture composed of several
components: an Object Relational Mapper (or ORM, to code the model),
a template engine (to write views), and an URL mapper (to associate
URLs to Python methods acting as controllers).
TurboGears2 relies on the best available individual components and
combines them into a coherent and well-documented whole. TurboGears2
includes parts that join the components together and make them work
together seamlessly, but does not obscure each included project. This
allows one to take advantage of existing documentation, articles, mailing
lists and other resources that have built up in the communities for
each project.
TurboGears2 is the next major version of TurboGears, and builds on
the Pylons framework.
This package contains all you would need to run (but not develop) web
applications powered by TurboGears2; to develop them you should
also install the python-tg.devtools packages.

Alternatives

Package Version Architecture Repository
python-turbogears2_2.1.5-2_all.deb 2.1.5 all Debian Main
python-turbogears2 - - -

Requires

Name Value
python -
python-babel >= 0.9.4
python-genshi >= 0.5.1
python-pylons >= 0.9.7
python-repoze.tm2 >= 1.0a4
python-repoze.what-plugins -
python-support >= 0.90.0
python-toscawidgets >= 0.9.4
python-turbojson >= 1.2.1-3
python-weberror >= 0.10.1
python-webflash >= 0.1a8

Download

Type URL
Binary Package python-turbogears2_2.1.5-2_all.deb
Source Package turbogears2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-turbogears2 deb package:
    # sudo apt-get install python-turbogears2

Files

Path
/usr/share/doc/python-turbogears2/changelog.Debian.gz
/usr/share/doc/python-turbogears2/copyright
/usr/share/pyshared/TurboGears2-2.1.5.egg-info/PKG-INFO
/usr/share/pyshared/TurboGears2-2.1.5.egg-info/SOURCES.txt
/usr/share/pyshared/TurboGears2-2.1.5.egg-info/dependency_links.txt
/usr/share/pyshared/TurboGears2-2.1.5.egg-info/entry_points.txt
/usr/share/pyshared/TurboGears2-2.1.5.egg-info/not-zip-safe
/usr/share/pyshared/TurboGears2-2.1.5.egg-info/requires.txt
/usr/share/pyshared/TurboGears2-2.1.5.egg-info/top_level.txt
/usr/share/pyshared/tests/base.py
/usr/share/pyshared/tests/test_caching.py
/usr/share/pyshared/tests/test_configuration.py
/usr/share/pyshared/tests/test_controllers.py
/usr/share/pyshared/tests/test_generic_json.py
/usr/share/pyshared/tests/test_i18n.py
/usr/share/pyshared/tests/test_jsonify.py
/usr/share/pyshared/tests/test_jsonify_sqlalchemy.py
/usr/share/pyshared/tests/test_render.py
/usr/share/pyshared/tests/test_rest_controller_dispatch.py
/usr/share/pyshared/tests/test_tg_controller_dispatch.py
/usr/share/pyshared/tests/test_util.py
/usr/share/pyshared/tests/test_validation.py
/usr/share/pyshared/tests/fixtures/__init__.py
/usr/share/pyshared/tests/fixtures/model.py
/usr/share/pyshared/tests/test_stack/__init__.py
/usr/share/pyshared/tests/test_stack/test_authz.py
/usr/share/pyshared/tests/test_stack/config/test_config.py
/usr/share/pyshared/tests/test_stack/config/controllers/root.py
/usr/share/pyshared/tests/test_stack/dispatch/test_config.py
/usr/share/pyshared/tests/test_stack/dispatch/test_url_dispatch.py
/usr/share/pyshared/tests/test_stack/dispatch/controllers/root.py
/usr/share/pyshared/tests/test_stack/lib/__init__.py
/usr/share/pyshared/tests/test_stack/lib/base.py
/usr/share/pyshared/tests/test_stack/lib/helpers.py
/usr/share/pyshared/tests/test_stack/lib/templatetools/__init__.py
/usr/share/pyshared/tests/test_stack/lib/templatetools/jinja_filters.py
/usr/share/pyshared/tests/test_stack/rendering/test_decorators.py
/usr/share/pyshared/tests/test_stack/rendering/test_dotted_rendering.py
/usr/share/pyshared/tests/test_stack/rendering/test_pagination.py
/usr/share/pyshared/tests/test_stack/rendering/test_rendering.py
/usr/share/pyshared/tests/test_stack/rendering/test_toscawidgets.py
/usr/share/pyshared/tests/test_stack/rendering/controllers/root.py
/usr/share/pyshared/tests/test_stack/rendering/templates/mako_base.mak.py
/usr/share/pyshared/tests/test_stack/rendering/templates/mako_custom_format.mak.py
/usr/share/pyshared/tests/test_stack/rendering/templates/mako_inherits.mak.py
/usr/share/pyshared/tests/test_stack/rendering/templates/mako_noop.mak.py
/usr/share/pyshared/tg/__init__.py
/usr/share/pyshared/tg/amfify.py
/usr/share/pyshared/tg/configuration.py
/usr/share/pyshared/tg/decorators.py
/usr/share/pyshared/tg/error.py
/usr/share/pyshared/tg/exceptions.py
/usr/share/pyshared/tg/flash.py
/usr/share/pyshared/tg/i18n.py
/usr/share/pyshared/tg/jsonify.py
/usr/share/pyshared/tg/paginate.py
/usr/share/pyshared/tg/release.py
/usr/share/pyshared/tg/render.py
/usr/share/pyshared/tg/util.py
/usr/share/pyshared/tg/wsgiapp.py
/usr/share/pyshared/tg/commands/__init__.py
/usr/share/pyshared/tg/commands/info.py
/usr/share/pyshared/tg/controllers/__init__.py
/usr/share/pyshared/tg/controllers/decoratedcontroller.py
/usr/share/pyshared/tg/controllers/dispatcher.py
/usr/share/pyshared/tg/controllers/restcontroller.py
/usr/share/pyshared/tg/controllers/tgcontroller.py
/usr/share/pyshared/tg/controllers/util.py
/usr/share/pyshared/tg/controllers/wsgiappcontroller.py
/usr/share/pyshared/tg/dottednames/chameleon_genshi_lookup.py
/usr/share/pyshared/tg/dottednames/genshi_lookup.py
/usr/share/pyshared/tg/dottednames/jinja_lookup.py
/usr/share/pyshared/tg/dottednames/mako_lookup.py
/usr/share/python-support/python-turbogears2.public

Changelog

2012-06-28 - Laszlo Boszormenyi (GCS) <gcs@debian.hu>
turbogears2 (2.1.5-2) unstable; urgency=low
* Add required Python Babel dependency for internationalization.
2012-06-08 - Laszlo Boszormenyi (GCS) <gcs@debian.hu>
turbogears2 (2.1.5-1) unstable; urgency=low
* New upstream release.
2012-02-26 - Laszlo Boszormenyi (GCS) <gcs@debian.hu>
turbogears2 (2.1.4-2) unstable; urgency=low
* Loosen dependency on WebOb.
2012-02-08 - Laszlo Boszormenyi (GCS) <gcs@debian.hu>
turbogears2 (2.1.4-1) unstable; urgency=low
* New upstream release (closes: #608730), refresh patch to apply clean.
* New maintainer (closes: #658926), update packaging bits.
* Use 3.0 (quilt) package format.
2012-02-01 - Stefano Zacchiroli <zack@debian.org>
turbogears2 (2.0.3-3) unstable; urgency=low
* Orphan package.
2010-03-21 - Stefano Zacchiroli <zack@debian.org>
turbogears2 (2.0.3-2) unstable; urgency=low
* add quilt support (build-dep, CDBS snippet, README.source)
* add patch routes-mapper-minimize-by-default which enables Routes
mapper minimization: it is required by TG2, but it has been disabled
in python-routes (>= 1.12). Thanks to Piotr O┼╝arowski for the patch!
(Closes: #574640)
* bump Standards-Version to 3.8.4, no changes needed
* fix unneeded build-dep on python-dev
2009-08-24 - Stefano Zacchiroli <zack@debian.org>
turbogears2 (2.0.3-1) unstable; urgency=low
* new upstream release
* debian/control:
- bump turbojson dependency to the last (debian) revision with sane
dependencies, i.e. 1.2.1-3 (Closes: #541022)
- bump Standards-Version to 3.8.3 (no changes needed)
2009-08-02 - Stefano Zacchiroli <zack@debian.org>
turbogears2 (2.0.1-2) unstable; urgency=low
* first upload to unstable
* debian/control: clarify in description the respective roles of
python-{turbogears2,tg.devtools}
2009-07-03 - Stefano Zacchiroli <zack@debian.org>
turbogears2 (2.0.1-1) experimental; urgency=low
* New upstream release
- debian/control: build deps/recommends accordingly
2009-06-20 - Stefano Zacchiroli <zack@debian.org>
turbogears2 (2.0-3) experimental; urgency=low
[ Stefano Zacchiroli ]
* adopting package
* new upstream release
* resurrect packaging from last Python Modules Team work, with the
blessing of the last maintainer there; thanks Gustavo Noronha Silva!
* empty README.Debian, now obsolete
* debian/control
- set Maintainer to Python Modules Team, Uploaders to me
- recommend python-tg.devtools, to get "paster quickstart"
- revamp Description
- sync (build-)dependencies with what currently required
(Closes: #530879, #532729)
- bump Standards-Version to 3.8.2 (no changes needed)
* debian/watch: make it point to current download site
* debian/rules: remove simple-patchsys, as we have no patches anymore
[ Sandro Tosi ]
* debian/control
- switch Vcs-Browser field to viewsvn

See Also

Package Description
python-turbojson_1.3.2-2_all.deb plugin to use JSON templates in Python templating engines
python-turbokid_1.0.5-1_all.deb TurboGears template plugin to use kid templates
python-tvdb-api_1.7.1-1_all.deb API interface to TheTVDB.com
python-tweepy-doc_1.7.1-2+deb7u1_all.deb Documentation for python-tweepy module
python-tweepy_1.7.1-2+deb7u1_all.deb Twitter library for Python
python-twill_0.9-3_all.deb Simple scripting language for Web browsing
python-twisted-bin_12.0.0-1_i386.deb Event-based framework for internet applications
python-twisted-conch_12.0.0-1_all.deb Twisted SSH Implementation
python-twisted-core_12.0.0-1_all.deb Event-based framework for internet applications
python-twisted-libravatar_1.1-3_all.deb Libravatar module for Twisted
python-twisted-lore_12.0.0-1_all.deb Documentation generator with HTML and LaTeX support
python-twisted-mail_12.0.0-1_all.deb SMTP, IMAP and POP protocol implementation
python-twisted-names_12.0.0-1_all.deb DNS protocol implementation with client and server
python-twisted-news_12.0.0-1_all.deb NNTP protocol implementation with client and server
python-twisted-runner_12.0.0-1_i386.deb Process management, including an inetd server
Advertisement
Advertisement