python-support_1.0.15_all.deb


Advertisement

Description

python-support - automated rebuilding support for Python modules

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name python-support
Package version 1.0.15
Package architecture all
Package type deb
Installed size 163 B
Download size 32.84 KB
Official Mirror ftp.br.debian.org
This package contains the 'update-python-modules' script, which takes
care of byte-compilation of Python-only modules.
Private modules are automatically rebuilt upon major Python upgrades,
avoiding the need for strong dependencies.
Public modules are automatically made available for all installed
Python versions.

Alternatives

Package Version Architecture Repository
python-support_1.0.15_all.deb 1.0.15 all Debian Main
python-support - - -

Requires

Name Value
dpkg >= 1.14.19
python >= 2.5
python-minimal -

Conflicts

Name Value
debhelper << 5.0.38

Download

Type URL
Binary Package python-support_1.0.15_all.deb
Source Package python-support

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-support deb package:
    # sudo apt-get install python-support

Files

Path
/usr/bin/dh_pysupport
/usr/lib/python2.6/dist-packages/python-support.pth
/usr/lib/python2.7/dist-packages/python-support.pth
/usr/sbin/update-python-modules
/usr/share/debhelper/autoscripts/postinst-python-support
/usr/share/debhelper/autoscripts/prerm-python-support
/usr/share/doc/python-support/README.gz
/usr/share/doc/python-support/changelog.gz
/usr/share/doc/python-support/copyright
/usr/share/lintian/overrides/python-support
/usr/share/man/man1/dh_pysupport.1.gz
/usr/share/man/man8/update-python-modules.8.gz
/usr/share/python-support/python-support.private
/usr/share/python-support/private/movemodules
/usr/share/python-support/private/parseversions
/usr/share/python-support/private/pysupport.py
/usr/share/python/runtime.d/python-support.rtinstall
/usr/share/python/runtime.d/python-support.rtremove
/usr/share/python/runtime.d/python-support.rtupdate

Changelog

2012-06-30 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.15) unstable; urgency=low
[ Jakub Wilk ]
* parseversions:
+ Make comparison of field names case-insensitive.
+ Recognize X-Python-Version.
[ Piotr Ożarowski ]
* update-python-modules manpage: fix --install option's description
(closes: #671942)
* movemodules:
- doesn't raise string exceptions anymore (closes: #585332)
* Standards version is 3.9.3, no changes required
2011-06-27 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.14) unstable; urgency=low
* update-python-modules: remove directory if it's replaced with a file
(often happens with .egg-info file/dirs)
* Add deprecation warning: dh_python2 (from python package) should be used
instead. Migration guide is available on wiki page:
http://wiki.debian.org/Python/PythonSupportToDHPython2
* Vcs-* fields now point to anonscm.debian.org
* Standards version is 3.9.2, no changes required.
2011-04-15 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.13) unstable; urgency=low
[ Loïc Minier ]
* tests/testparseversions.py: don't hardcode expected versions; instead,
compare with pyversions' output.
* pysupport.py: don't hardcode supported and old versions; instead, parse
debian_defaults; NB: this removes some very old python versions from the
list (2.1 and 2.2), but these weren't ever support and aren't supported in
the previous stable release anyway.  Depend on python-minimal as
debian_defaults is accessed directly.
[ Piotr Ożarowski ]
* Upload to unstable (closes: #622906)
* Add lintian override for depends-on-python-minimal
2010-10-18 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.12) experimental; urgency=low
* Add support for python2.7.
* Move python2.4 to old versions.
2010-10-19 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.11) unstable; urgency=low
* Move python2.4 to old versions.
2010-09-14 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.10) unstable; urgency=low
* Binary packages with name starting with "python3-" are now ignored by
dh_pysupport
* Standards version is 3.9.1, no changes required.
2010-06-27 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.9) unstable; urgency=low
* dh_pysupport: generates correct dependencies if multiple packages need
pythonX.Y (closes: #576517, thanks to Jakub Wilk for the patch)
* update-python-modules:
- remove /usr/lib/pymodules files symlinked to /usr/share/pyshared that
no longer belong to any python-support based package
- doesn't raise string exceptions anymore (closes: #585332)
2010-04-20 - Piotr Ożarowski <piotr@debian.org>
python-support (1.0.8) unstable; urgency=low
[ Jakub Wilk ]
* movemodules: ignore indentation and trailing whitespace when comparing
PKG-INFO and *.egg-info files. This is work-around for bug #575377.
[ Piotr Ożarowski ]
* Standards version is 3.8.4, no changes required.
* Use 3.0 (native) source package format

See Also

Package Description
python-surfer_0.3+git15-gae6cbb1-1.1_all.deb visualize Freesurfer's data in Python
python-svipc_0.14-2_i386.deb interprocess communication (shared memory...) for Python
python-svn_1.7.5-1.1_i386.deb A(nother) Python interface to Subversion
python-swift_1.4.8-2+deb7u1_all.deb OpenStack Object Storage - libraries
python-swiginac_1.5.1.1-1+b2_i386.deb Python interface to GiNaC
python-syfi_1.0.0.dfsg-1_i386.deb Finite element method (FEM) C++ library - Python bindings
python-symeig_1.5-2_all.deb Symmetrical eigenvalue routines for NumPy
python-sympy_0.7.1.rc1-3_all.deb Computer Algebra System (CAS) in Python
python-tables-doc_2.3.1-3_all.deb hierarchical database for Python based on HDF5 - documentation
python-tables_2.3.1-3_i386.deb hierarchical database for Python based on HDF5
python-tagpy_0.94.8-4_i386.deb Python module for manipulating tags in music files
python-talloc-dev_2.0.7+git20120207-1_i386.deb talloc Python bindings - development files
python-talloc_2.0.7+git20120207-1_i386.deb hierarchical pool based memory allocator - Python bindings
python-tastypie_0.9.10-2_all.deb webservice API framework for Django
python-tau_2.16.4-1.4+b1_i386.deb Tuning and Analysis Utilities - support for python bindings
Advertisement
Advertisement