libwvstreams4.6-extras_4.6.1-5_i386.deb


Advertisement

Description

libwvstreams4.6-extras - C++ network libraries for rapid application development

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name libwvstreams4.6-extras
Package version 4.6.1
Package release 5
Package architecture i386
Package type deb
Installed size 1.23 KB
Download size 503.09 KB
Official Mirror ftp.br.debian.org
WvStreams is a library suite that is comprised of several parts.  Included
in the extras package are:
* WvIPStreams: which includes WvTCPStream and WvUDPStream
* WvCrypto streams: a REALLY easy way to add SSL support to applications
These are the base classes used to build programs such as the ever popular
WvDial, TunnelVision, FastForward, KWvDial, retchmail, and many more yet
to come.  ;)

Alternatives

Package Version Architecture Repository
libwvstreams4.6-extras_4.6.1-5_amd64.deb 4.6.1 amd64 Debian Main
libwvstreams4.6-extras - - -

Requires

Name Value
libc6 >= 2.2.3
libdbus-1-3 >= 1.2.14
libgcc1 >= 1:4.1.1
libpam0g >= 0.99.7.1
libssl1.0.0 >= 1.0.0
libstdc++6 >= 4.1.1
libwvstreams4.6-base -
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package libwvstreams4.6-extras_4.6.1-5_i386.deb
Source Package wvstreams

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwvstreams4.6-extras deb package:
    # sudo apt-get install libwvstreams4.6-extras

Files

Path
/usr/lib/libwvdbus.so.4.6
/usr/lib/libwvstreams.so.4.6
/usr/lib/libwvutils.so.4.6
/usr/share/doc/libwvstreams4.6-extras/changelog.Debian.gz
/usr/share/doc/libwvstreams4.6-extras/changelog.gz
/usr/share/doc/libwvstreams4.6-extras/copyright
/usr/share/lintian/overrides/libwvstreams4.6-extras

Changelog

2012-07-13 - Johann Felix Soden <johfel@debian.org>
wvstreams (4.6.1-5) unstable; urgency=low
* QA upload.
* Disable some gcc-4.7 optimization flags to fix wrong magic_number bug.
Thanks to Peter Drysdale <drysdalepete@gmail.com>. (Closes: #674006) 
* Disable parallel build.
* Add Build-Depends: graphviz.
2012-05-18 - Ana Beatriz Guerrero Lopez <ana@debian.org>
wvstreams (4.6.1-4) unstable; urgency=low
* QA upload.
* Remove Qt3 support. (Closes: #604389)
2012-04-20 - gregor herrmann <gregoa@debian.org>
wvstreams (4.6.1-3) unstable; urgency=low
* QA upload.
* Fix "ftbfs with GCC-4.7": add patch 06_gcc-4.7.diff from Paul Tagliamonte
(missing include).
(Closes: #667418)
2011-05-20 - Luca Falavigna <dktrkranz@debian.org>
wvstreams (4.6.1-2) unstable; urgency=low
* QA upload.
* Switch to format 3.0 (quilt).
* debian/patches/05_gcc.diff:
- Fix FTBFS with new gcc (Closes: #621990).
* Drop obsolete Conflicts/Replaces fields.
* Bump Standards-Version to 3.9.2.
2009-11-05 - Hideki Yamane (Debian-JP) <henrich@debian.or.jp>
wvstreams (4.6.1-1) unstable; urgency=low
* QA upload.
* New upstream release
* debian/rules
- enable "--with-dbus" (Closes: #551869)
* debian/libwvstreams4.6-extra.install
- add "debian/tmp/usr/lib/libwvdbus.so*" to inclde libwvdubs.so.4.6
* debian/control
- add "(= ${binary:Version})" to libwvstreams-dev package to fix 
"weak-library-dev-dependency" 
- add Build-Depends: libdbus-1-dev to correspond to "--with-dbus" in rules.
2009-08-25 - Luca Falavigna <dktrkranz@debian.org>
wvstreams (4.6-2) unstable; urgency=low
* QA upload.
* Conflicts/Replaces libuniconf4.4 for libuniconf4.6 binary package
to allow clean upgrade from a previous version (Closes: #540320).
* Bump Standards-Version to 3.8.3, no changes needed.
2009-07-29 - Barry deFreese <bdefreese@debian.org>
wvstreams (4.6-1) unstable; urgency=low
* QA upload.
* New upstream release.
+ Move old source changes to quilt.
+ Rename binaries for new upstream version.
* 01_kfreebsd_ftbfs.diff - Fix FTBFS on kFreeBSD. (Closes: #537883).
+ Thanks to Petr Salinger for the fix!
* Copy in config.{sub,guess} on configure, rm them on clean.
+ Add autotools-dev build-dep.
* Clean up rules file.
* Add Homepage.
* Remove duplicate sections from debian/control.
* Update debian/copyright.
* Bump Standards Version to 3.8.2. (No changes needed).
2009-02-07 - Moritz Mühlenhoff <jmm@debian.org>
wvstreams (4.4.1-1.1) unstable; urgency=high
* Non-maintainer upload.
* Fix return type checking of X509_REQ_verify (Closes: #513539)
2009-01-28 - Barry deFreese <bdefreese@debian.org>
wvstreams (4.4.1-1) unstable; urgency=low
* QA upload.
+ Set maintainer to Debian QA Group <packages@qa.debian.org>.
+ Remove Simon Law. (Closes: #487140).
* Acknowledge NMUs. (Closes: #440245).
* Remove duplicate build-dep on doxygen.
* Update {Source-Version} to ${binary:Version}.
* Make clean not ignore errors.
* Add suggests on tk8.4 || wish to libwvstreams-dev package.
* Add watch file.
* Bump debhelper build-dep and compat to 5.
* Bump Standards Version to 3.8.0.
2008-04-05 - Peter Eisentraut <petere@debian.org>
wvstreams (4.4.1-0.2) unstable; urgency=low
* Non-maintainer upload.
* Fixed dependency information LSB header in init.d script
(closes: #470067)

See Also

Package Description
libwww-bugzilla-perl_1.5-1_all.deb Perl module to manipulate a Bugzilla database
libwww-cnic-perl_0.38-1_all.deb interface to the CentralNic domain registry system
libwww-curl-perl_4.15-1+b2_i386.deb Perl bindings to libcurl
libwww-facebook-api-perl_0.4.18-1_all.deb Facebook API implementation
libwww-finger-perl_0.104-1_all.deb get useful data from e-mail addresses
libwww-freshmeat-perl_0.22-1_all.deb module to automate searches on Freshmeat.net
libwww-google-calculator-perl_0.07-1_all.deb Perl interface for Google calculator
libwww-indexparser-perl_0.91-1_all.deb Fetch and parse the directory index from a web server
libwww-mechanize-autopager-perl_0.02-2_all.deb plugin for WWW::Mechanize for automatic pagination
libwww-mechanize-formfiller-perl_0.10-2_all.deb framework to automate HTML forms
libwww-mechanize-gzip-perl_0.12-1_all.deb Perl module to fetch webpages with gzip-compression
libwww-mechanize-perl_1.71-1_all.deb module to automate interaction with websites
libwww-mechanize-ruby-doc_2.3-2_all.deb Transitional package for ruby-mechanize
libwww-mechanize-ruby1.8_2.3-2_all.deb Transitional package for ruby-mechanize
libwww-mechanize-ruby1.9.1_2.3-2_all.deb Transitional package for ruby-mechanize
Advertisement
Advertisement