libwebkit1.1-cil_0.3-6_all.deb


Advertisement

Description

libwebkit1.1-cil - CLI binding for the WebKit library

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name libwebkit1.1-cil
Package version 0.3
Package release 6
Package architecture all
Package type deb
Installed size 60 B
Download size 23.82 KB
Official Mirror ftp.br.debian.org
WebKit is a web content engine, derived from KHTML and KJS from KDE, and
used primarily in Apple's Safari browser.  It is made to be embedded in
other applications, such as mail readers, or web browsers.
This package provides the webkit-sharp assembly that allows CLI programs to
use WebKit library.

Alternatives

Package Version Architecture Repository
libwebkit1.1-cil_0.3-6_all.deb 0.3 all Debian Main
libwebkit1.1-cil - - -

Requires

Name Value
cli-common >= 0.5.1
libglib2.0-cil >= 2.12.10
libgtk2.0-cil >= 2.12.10
libmono-corlib4.0-cil >= 2.10.1
libwebkitgtk-1.0-0 >= 1.3.9

Download

Type URL
Binary Package libwebkit1.1-cil_0.3-6_all.deb
Source Package webkit-sharp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libwebkit1.1-cil deb package:
    # sudo apt-get install libwebkit1.1-cil

Files

Path
/usr/lib/cli/webkit-sharp-1.1/webkit-sharp.dll
/usr/lib/cli/webkit-sharp-1.1/webkit-sharp.dll.config
/usr/share/cli-common/packages.d/libwebkit1.1-cil.installcligac
/usr/share/doc/libwebkit1.1-cil/changelog.Debian.gz
/usr/share/doc/libwebkit1.1-cil/changelog.gz
/usr/share/doc/libwebkit1.1-cil/copyright

Changelog

2012-01-21 - Jo Shields <directhex@apebox.org>
webkit-sharp (0.3-6) unstable; urgency=low
* [efaf7b7] Switch from manual Quilt to DebSrc 3.0 (quilt).
* [2b47da5] Update debian/rules for DH8-compatible "--with cli"
2011-08-09 - Chow Loong Jin <hyperair@ubuntu.com>
webkit-sharp (0.3-5) unstable; urgency=low
[ Chow Loong Jin ]
* [dca377b] Update build-dep for libwebkit-dev transition
* [5d41787] Update dllmap for libwebkit rename to libwebkitgtk
* [f8bca7f] Fix soname in dllmap (should be 0)
[ Julian Taylor ]
* [f00a55c] point watchfile to github
the tarball there is the same as the old unavailable one except
it has no pregenerated autotools files and on extra xml doc not used
in the package
* [2b16f09] use dh-autoreconf
2011-07-15 - Iain Lane <laney@debian.org>
webkit-sharp (0.3-4) unstable; urgency=low
[ Julian Taylor ]
* [83bcc7d] drop unnecessary dependency on libmono-dev
* [7117082] fix Vcs-Browser link
[ Iain Lane ]
* [37cd01a] Use quilt for patching
* [6dc4cd2] Use source format 1.0
* [1c8b4f5] Use debhelper overrides instead of --before etc
* [b8eb2be] Standards-Version → 3.9.2, no changes required
2010-09-27 - Jo Shields <directhex@apebox.org>
webkit-sharp (0.3-3) unstable; urgency=low
* [7143bb1] Remove postinst scripts for monodoc-webkit-manual. We use
dpkg triggers to handle manuals now, and having these lying around
can not only cause a needless second call to update the monodoc
search index - it can cause package installation to fail on clean
systems where GTK# has not yet run its postinst.
* [c891291] Migrate webkit-sharp from SVN to Git, and set Vcs-* fields
in debian/control.
2010-01-03 - Jo Shields <directhex@apebox.org>
webkit-sharp (0.3-2) unstable; urgency=low
* debian/control:
+ Use GTK#'s -dev package
+ Fix typo (Closes: #557394)
+ Add missing build-depend on libglib2.0-cil-dev
2009-11-04 - Jo Shields <directhex@apebox.org>
webkit-sharp (0.3-1) unstable; urgency=low
* New upstream release
* debian/libwebkit1.1-cil.install,
debian/libwebkit1.1-cil.installcligac,
debian/control:
+ Bump package name to 1.1, to reflect new ABI
* debian/README.source:
+ Add dpatch documentation, for those who need it
* debian/rules,
debian/control,
debian/libwebkit-cli-dev:
+ Add new -dev package, containing only the pkgconfig file
* debian/rules,
debian/control:
+ Use mono-csc from mono-devel 2.4.2.3+
* debian/copyright:
+ Refresh
* debian/control:
+ Bump to Standards 3.8.3
+ Upstream now require Webkit 1.1.15, so version the build-dep
+ Add myself to Uploaders
+ Change section to cli-mono to appease archive overlords
+ Add misc:depends to doc package
* debian/rules:
+ Bump DEB_CLI_ABI_VERSION to 1.1
+ Bump DEB_CLI_API_VERSION to 0.3
+ Use API version for svn export (it ought to be reliable-ish)
+ Use policy-compliant tarball location
* debian/patches/fix_dllmap.dpatch:
+ Refresh
* debian/monodoc-webkit-manual.postinst,
debian/monodoc-webkit-manual.postrm:
+ Stop mangling monodoc.xml, it's not needed these days
2009-05-14 - Mirco Bauer <meebey@debian.org>
webkit-sharp (0.2-3) unstable; urgency=low
* Rebuild against libwebkit-dev 1.1.6-2
* debian/patches/fix_dllmap.dpatch:
+ Map webkit-1.0 to libwebkit-1.0.so.2
2009-03-02 - Jo Shields <directhex@apebox.org>
webkit-sharp (0.2-2) unstable; urgency=low
* Update for Mono 2.0 transition
* No-change bump to standards 3.8.0
2008-06-15 - Mirco Bauer <meebey@debian.org>
webkit-sharp (0.2-1) unstable; urgency=low
* Initial release.  (Closes: #485806)

See Also

Package Description
libwebkitgtk-1.0-0_1.8.1-3.4_i386.deb Web content engine library for GTK+
libwebkitgtk-1.0-common_1.8.1-3.4_all.deb Web content engine library for GTK+ - data files
libwebkitgtk-3.0-0_1.8.1-3.4_i386.deb Web content engine library for GTK+
libwebkitgtk-3.0-common_1.8.1-3.4_all.deb Web content engine library for GTK+ - data files
libwebkitgtk-3.0-dev_1.8.1-3.4_i386.deb Web content engine library for GTK+ - Development files
libwebkitgtk-dev_1.8.1-3.4_i386.deb Web content engine library for GTK+ - Development files
libwebp-dev_0.1.3-3+nmu1_i386.deb Lossy compression of digital photographic images
libwebp2_0.1.3-3+nmu1_i386.deb Lossy compression of digital photographic images
libwebrtc-audio-processing-0_0.1-2_i386.deb AudioProcessing module from the WebRTC project
libwebrtc-audio-processing-dev_0.1-2_i386.deb development files for the webrtc-audio-processing library
libwebservice-cia-perl_1.4-1_all.deb get information from the CIA World Factbook via Perl
libwebservice-musicbrainz-perl_0.93-1_all.deb XML based Web service API to the MusicBrainz database
libwebservice-solr-perl_0.19-1_all.deb Perl interface for the Solr (Lucene) web service
libwebservice-validator-css-w3c-perl_0.2-1_all.deb interface to the W3C CSS Validator
libwebservice-validator-html-w3c-perl_0.28-1_all.deb Perl interface to access the W3C's online HTML validator
Advertisement
Advertisement