libvips-dev_7.28.5-1+deb7u1_i386.deb


Advertisement

Description

libvips-dev - image processing system good for very large images (dev)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name libvips-dev
Package version 7.28.5
Package release 1+deb7u1
Package architecture i386
Package type deb
Installed size 3.30 KB
Download size 988.08 KB
Official Mirror ftp.br.debian.org
VIPS is an image processing system designed with efficiency in mind.
It is good with large images (images larger than the amount of RAM in
your machine), and for working with colour.  It can perform many
image manipulation tasks much faster than other packages such as
ImageMagick and the GIMP and includes some special features such as
creating single "mosaic" images from multiple parts.
VIPS consists of two main components: an image processing library
with some command-line tools and a spreadsheet-like graphical user
interface.  The graphical interface is available in the nip2 package.
This package includes all development files needed to compile
applications that use the vips library.

Alternatives

Package Version Architecture Repository
libvips-dev_7.28.5-1+deb7u2_i386.deb 7.28.5 i386 Debian Security Updates Main
libvips-dev_7.28.5-1+deb7u2_amd64.deb 7.28.5 amd64 Debian Security Updates Main
libvips-dev_7.28.5-1+deb7u1_amd64.deb 7.28.5 amd64 Debian Main
libvips-dev - - -

Requires

Name Value
fftw3-dev -
gettext -
libcfitsio3-dev -
libexif-gtk-dev -
libfftw3-dev -
libfontconfig1-dev -
libfreetype6-dev -
libglib2.0-dev -
libice-dev -
libjpeg-dev -
liblcms2-dev -
libmagickcore-dev -
libmagickwand-dev -
libmatio-dev -
libopenexr-dev -
libopenslide-dev -
liborc-0.4-dev -
libpango1.0-dev -
libpng-dev -
libtiff5-alt-dev -
libvips15 = 7.28.5-1+deb7u1
libxml2-dev -
pkg-config -
python-all-dev -
python-dev >= 2.6.6-3~
zlib1g-dev -

Download

Type URL
Binary Package libvips-dev_7.28.5-1+deb7u1_i386.deb
Source Package vips

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libvips-dev deb package:
    # sudo apt-get install libvips-dev

Files

Path
/usr/include/vips/VDisplay.h
/usr/include/vips/VError.h
/usr/include/vips/VImage.h
/usr/include/vips/VMask.h
/usr/include/vips/almostdeprecated.h
/usr/include/vips/arithmetic.h
/usr/include/vips/basic.h
/usr/include/vips/buf.h
/usr/include/vips/cimg_funcs.h
/usr/include/vips/colour.h
/usr/include/vips/conversion.h
/usr/include/vips/convolution.h
/usr/include/vips/debug.h
/usr/include/vips/deprecated.h
/usr/include/vips/disp.h
/usr/include/vips/dispatch.h
/usr/include/vips/enumtypes.h
/usr/include/vips/error.h
/usr/include/vips/foreign.h
/usr/include/vips/format.h
/usr/include/vips/freq_filt.h
/usr/include/vips/generate.h
/usr/include/vips/header.h
/usr/include/vips/histograms_lut.h
/usr/include/vips/image.h
/usr/include/vips/inplace.h
/usr/include/vips/interpolate.h
/usr/include/vips/intl.h
/usr/include/vips/mask.h
/usr/include/vips/memory.h
/usr/include/vips/morphology.h
/usr/include/vips/mosaicing.h
/usr/include/vips/object.h
/usr/include/vips/operation.h
/usr/include/vips/other.h
/usr/include/vips/private.h
/usr/include/vips/rect.h
/usr/include/vips/region.h
/usr/include/vips/relational.h
/usr/include/vips/resample.h
/usr/include/vips/semaphore.h
/usr/include/vips/thread.h
/usr/include/vips/threadpool.h
/usr/include/vips/transform.h
/usr/include/vips/type.h
/usr/include/vips/util.h
/usr/include/vips/vector.h
/usr/include/vips/version.h
/usr/include/vips/video.h
/usr/include/vips/vips
/usr/include/vips/vips.h
/usr/include/vips/vips7compat.h
/usr/include/vips/vipsc++.h
/usr/include/vips/vipscpp.h
/usr/lib/i386-linux-gnu/libvips.a
/usr/lib/i386-linux-gnu/libvips.so
/usr/lib/i386-linux-gnu/libvipsCC.a
/usr/lib/i386-linux-gnu/libvipsCC.so
/usr/lib/i386-linux-gnu/pkgconfig/vips-7.28.pc
/usr/lib/i386-linux-gnu/pkgconfig/vipsCC-7.28.pc
/usr/share/doc/libvips-dev/AUTHORS
/usr/share/doc/libvips-dev/NEWS.gz
/usr/share/doc/libvips-dev/README.gz
/usr/share/doc/libvips-dev/THANKS
/usr/share/doc/libvips-dev/TODO.gz
/usr/share/doc/libvips-dev/changelog.Debian.gz
/usr/share/doc/libvips-dev/changelog.gz
/usr/share/doc/libvips-dev/copyright

Changelog

2013-12-20 - Jay Berkenbilt <qjb@debian.org>
vips (7.28.5-1+deb7u1) stable; urgency=low
* Fix crash on tiff with jpeg compression.  Thanks to Mathieu Malaterre
<malat@debian.org> for diagnosing this bug, getting a fix from
upstream, and preparing a patch.  (Closes: #689523, #714984, #731948)
2012-05-29 - Jay Berkenbilt <qjb@debian.org>
vips (7.28.5-1) unstable; urgency=low
* New upstream release
* multiarch, hardening
* Support bigtiff
2012-03-18 - Jay Berkenbilt <qjb@debian.org>
vips (7.28.2-1) unstable; urgency=low
* New upstream release
2012-03-05 - Jay Berkenbilt <qjb@debian.org>
vips (7.26.7-4) unstable; urgency=low
* Explicitly disable v4l on kfreebsd architectures.  Hopefully it's
really right this time.  (Closes: #654430)
2012-03-05 - Jay Berkenbilt <qjb@debian.org>
vips (7.26.7-3) unstable; urgency=low
* Correctly implement previous change (fix omission in rules file)
2012-03-05 - Jay Berkenbilt <qjb@debian.org>
vips (7.26.7-2) unstable; urgency=low
* Update png dependency to libpng-dev.  (Closes: #662536)
* Explicitly disable v4l on kfreebsd architectures.  (Closes: #654430)
2011-12-31 - Jay Berkenbilt <qjb@debian.org>
vips (7.26.7-1) unstable; urgency=low
* New upstream release
* Fix python packaging issue.  Thanks Jakub Wilik <jwilk@debian.org>.
(Closes: #642746)
2011-09-03 - Jay Berkenbilt <qjb@debian.org>
vips (7.26.3-1) unstable; urgency=low
* New upstream release
* Migrate from dh_pycentral to dh_python2.  (Closes: #617141)
* Remove remaining .la files which were installed with the python
module.  (Closes: #633181)
* New upstream release includes updated German translation.  (Closes:
#625255)
2011-06-11 - Jay Berkenbilt <qjb@debian.org>
vips (7.24.5-4) unstable; urgency=high
* Fixed ImageMagick dependencies; previous fix missed dependencies of
libvips-dev. (Closes: #629904, #630014)
2011-05-07 - Jay Berkenbilt <qjb@debian.org>
vips (7.24.5-3) unstable; urgency=low
* Updated libmagick build dependencies to use non-version-specific
packages for better upgradability. (Closes: #625602, #625552)

See Also

Package Description
libvips-doc_7.28.5-1+deb7u1_all.deb image processing system good for very large images (doc)
libvips-tools_7.28.5-1+deb7u1_i386.deb image processing system good for very large images (tools)
libvips15_7.28.5-1+deb7u1_i386.deb image processing system good for very large images
libvirt-bin_0.9.12.3-1+deb7u1_i386.deb programs for the libvirt library
libvirt-dev_0.9.12.3-1+deb7u1_i386.deb development files for the libvirt library
libvirt-doc_0.9.12.3-1+deb7u1_all.deb documentation for the libvirt library
libvirt-glib-1.0-0_0.0.8-1_i386.deb libvirt glib mainloop integration
libvirt-glib-1.0-dev_0.0.8-1_i386.deb libvirt glib mainloop integration
libvirt-ocaml-dev_0.6.1.2-1_i386.deb OCaml bindings for libvirt
libvirt-ocaml_0.6.1.2-1_i386.deb OCaml bindings for libvirt
libvirt-ruby1.8_0.4.0-1_all.deb Transitional package for ruby-libvirt
libvirt-ruby_0.4.0-1_all.deb Transitional package for ruby-libvirt
libvirt0_0.9.12.3-1+deb7u1_i386.deb library for interfacing with different virtualization systems
libvirtodbc0_6.1.4+dfsg1-7_i386.deb high-performance database - ODBC libraries
libvirtuoso5.5-cil_6.1.4+dfsg1-7_i386.deb high-performance database - Mono assemblies
Advertisement
Advertisement