libts-dev_1.0-11_i386.deb


Advertisement

Description

libts-dev - touch screen library, development files

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name libts-dev
Package version 1.0
Package release 11
Package architecture i386
Package type deb
Installed size 53 B
Download size 11.41 KB
Official Mirror ftp.br.debian.org
Tslib is an abstraction layer for touchscreen panel events, as well as a
filter stack for the manipulation of those events.
This package contains the static library and header files used in
development.

Alternatives

Package Version Architecture Repository
libts-dev_1.0-11_amd64.deb 1.0 amd64 Debian Main
libts-dev - - -

Requires

Name Value
libts-0.0-0 = 1.0-11

Replaces

Name Value
libts0 -

Download

Type URL
Binary Package libts-dev_1.0-11_i386.deb
Source Package tslib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libts-dev deb package:
    # sudo apt-get install libts-dev

Files

Path
/usr/include/tslib.h
/usr/lib/i386-linux-gnu/libts.so
/usr/lib/i386-linux-gnu/pkgconfig/tslib-0.0.pc
/usr/share/doc/libts-dev/changelog.Debian.gz
/usr/share/doc/libts-dev/changelog.gz
/usr/share/doc/libts-dev/copyright

Changelog

2012-03-24 - Neil Williams <codehelp@debian.org>
tslib (1.0-11) unstable; urgency=low
* Upload multi-arch support to unstable. (Closes: #664817)
2012-02-07 - Neil Williams <codehelp@debian.org>
tslib (1.0-10) experimental; urgency=low
[ Hector Oron ]
* Set Architecture to linux-any, instead of any.
[ Neil Williams ]
* Convert to MultiArch paths
* Upload to experimental for plugin testing.
2011-07-05 - Neil Williams <codehelp@debian.org>
tslib (1.0-9) unstable; urgency=low
[ Timo Juhani Lindfors ]
* Add patch allow_EV_VERSION_0 to continue supporting Linux 2.6.36 and
older. Previously kernel support depended on the kernel headers that
tslib was built against. (Closes: #623095)
* Do not refuse to work with old kernels. We can safely work with
kernels that use EV_VERSION 0x010000 API since we use no features from
0x010001 yet. (Closes: #623095)
[ Hector Oron ]
* Add myself to Uploaders field. 
[ Neil Williams ]
* Clean m4/internal and adjust for the new symbols generated
(lintian). Update standards version.
2011-04-05 - Neil Williams <codehelp@debian.org>
tslib (1.0-8) unstable; urgency=low
* Drop .la file as per Policy 10.2 (Closes: #620658)
* Migrate to source format 3.0 quilt from dpatch
2009-03-25 - Neil Williams <codehelp@debian.org>
tslib (1.0-7) unstable; urgency=low
* Migrate conffile and manpage into tsconf data package and
migrate TSLIB_PLUGINDIR to /usr/lib/ts0/ so that plugin filenames
remain unique. (Closes: #519872)
2009-03-06 - Neil Williams <codehelp@debian.org>
tslib (1.0-6) unstable; urgency=low
* Improve manpages to document change of Xorg driver to hal.
* Migrate into unstable
2008-12-14 - Neil Williams <codehelp@debian.org>
tslib (1.0-5) experimental; urgency=low
* Add enviroment variables, including TSLIB_TSDEVICE, to manual page
for ts_calibrate and reference as 'see also' in other pages.
(Closes: #497516)
* Add patch for 32bit big endian support - being tested upstream -
to provide event interface on powerpc (Closes: #499446)
* Patch AC_INIT to use 0.1.0 in tslib-0.0.pc (Closes: #496759)
* Add 050-glibc2.8-ubuntu from 1.0-4ubuntu1, thanks to Michael
Casadevall <sonicmctails@gmail.com> - Failure to build resolved due
to glibc-2.8, resolved by modifying code to confirm to the new
open()/O_CREAT API by adding a mode setting
* Incorporate cross-building improvements from Emdebian
* Add a general manpage for /etc/ts.conf in libts-0.0-0
2008-02-03 - Neil Williams <codehelp@debian.org>
tslib (1.0-4) unstable; urgency=low
* Failure to install libts-dev because duplicated .so files (Closes:
#463822)
2008-01-27 - Neil Williams <codehelp@debian.org>
tslib (1.0-3) unstable; urgency=low
* rules: Add cross build support
* rules: Add -dbg package support
* control: Add Debian GPE team to uploaders.
* control: Add -dbg package.
* Migrate to libts-0.0-0.install
* Remove debian version number from symbols file
* Migrate symbols file to new package name
* Expand debian/copyright to machine-interpretable format
* Add very simple man pages - the binaries themselves have no options
* control: highlight use of libts-bin in developing touch screen apps,
rather than users
* control: Use embedded section and provide libts0
* fix the watch file so that the real tarball is downloaded, not a
webpage
* debian/README: add instructions on building from collab-maint SVN
(not a packaged file at this stage).
* Revert manual change to source files and implement as dpatches; add
dpatch support
* rules: Support a cache-file when cross compiling to find malloc
* changelog: Remove unnecessary ITP message.
* control: Rename -dbg package in line with new lib name. Rename -dev
package without SONAME.
* Remove Joey from Maintainer on his request. Remove Vcs-Svn as no
longer in collab-maint

See Also

Package Description
libtse3-0.3.1c2a_0.3.1-4.3_i386.deb portable MIDI sequencer engine in C++ - development files
libtse3-dev_0.3.1-4.3_i386.deb portable MIDI sequencer engine in C++ - development files
libtsk-dev_3.2.3-2_i386.deb library for forensics analysis (development files)
libtsk3-3_3.2.3-2_i386.deb library for forensics analysis on volume and file system data
libtspi-dev_0.3.9-3+wheezy1_i386.deb open-source TCG Software Stack (development)
libtspi1_0.3.9-3+wheezy1_i386.deb open-source TCG Software Stack (library)
libtulip-3.7_3.7.0dfsg-4_i386.deb Tulip graph library - core runtime
libtulip-dev_3.7.0dfsg-4_i386.deb Tulip graph library - core development files
libtulip-ogdf-3.7_3.7.0dfsg-4_i386.deb Tulip graph library - OGDF runtime
libtulip-ogl-3.7_3.7.0dfsg-4_i386.deb Tulip graph library - OpenGL runtime
libtulip-qt4-3.7_3.7.0dfsg-4_i386.deb Tulip graph library - Qt/OpenGL GUI runtime
libtumbler-1-0_0.1.25-1+b1_i386.deb library for tumbler, a D-Bus thumbnailing service
libtumbler-1-dev_0.1.25-1+b1_i386.deb library for tumbler, a D-Bus thumbnailing service (development)
libtut-dev_0.0.20070706-1_all.deb elegant C++ unit test framework
libtuxcap-dev_1.4.0.dfsg2-2.1_i386.deb framework for developing 2D games - development files
Advertisement
Advertisement