libtcnative-1_1.1.24-1_i386.deb


Advertisement

Description

libtcnative-1 - Tomcat native library using the apache portable runtime

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name libtcnative-1
Package version 1.1.24
Package release 1
Package architecture i386
Package type deb
Installed size 403 B
Download size 131.11 KB
Official Mirror ftp.br.debian.org
Tomcat can use the Apache Portable Runtime to provide superior scalability,
performance, and better integration with native server technologies.
The Apache Portable Runtime is a highly portable library that is at the
heart of Apache HTTP Server 2.x. APR has many uses, including access to
advanced IO functionality (such as sendfile, epoll and OpenSSL), OS level
functionality (random number generation, system status, etc), and native
process handling (shared memory, NT pipes and Unix sockets).
These features allows making Tomcat a general purpose webserver, will
enable much better integration with other native web technologies, and
overall make Java much more viable as a full fledged webserver platform
rather than simply a backend focused technology.

Alternatives

Package Version Architecture Repository
libtcnative-1_1.1.24-1+deb7u1_amd64.deb 1.1.24 amd64 Debian Security Updates Main
libtcnative-1_1.1.24-1+deb7u1_i386.deb 1.1.24 i386 Debian Security Updates Main
libtcnative-1_1.1.24-1_amd64.deb 1.1.24 amd64 Debian Main
libtcnative-1 - - -

Requires

Name Value
libapr1 >= 1.2.7
libc6 >= 2.4
libssl1.0.0 >= 1.0.0

Download

Type URL
Binary Package libtcnative-1_1.1.24-1_i386.deb
Source Package tomcat-native

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtcnative-1 deb package:
    # sudo apt-get install libtcnative-1

Files

Path
/usr/lib/libtcnative-1.a
/usr/lib/libtcnative-1.so
/usr/lib/libtcnative-1.so.0
/usr/lib/libtcnative-1.so.0.1.24
/usr/lib/pkgconfig/tcnative-1.pc
/usr/share/doc/libtcnative-1/README.Debian
/usr/share/doc/libtcnative-1/changelog.Debian.gz
/usr/share/doc/libtcnative-1/changelog.gz
/usr/share/doc/libtcnative-1/copyright
/usr/share/lintian/overrides/libtcnative-1

Changelog

2012-08-25 - tony mancill <tmancill@debian.org>
tomcat-native (1.1.24-1) unstable; urgency=low
* Team upload.
* New upstream release (closes: #685516)
* Update README.Debian to include reference to tomcat7.
2012-03-02 - Damien Raude-Morvan <drazzib@debian.org>
tomcat-native (1.1.23-1) unstable; urgency=low
[ tony mancill ]
* Team upload.
* Remove Michael Koch from Uploaders (Closes: #654135)
[ Damien Raude-Morvan ]
* New upstream release.
* d/control: Build-Depends on dpkg-dev (>= 1.16.1~) for hardening
flags
* d/rules: Enable hardening build.
* d/copyright: Use copyright-format 1.0.
* d/control: Bump Standards-Version to 3.9.3: no changes needed.
2011-08-12 - Damien Raude-Morvan <drazzib@debian.org>
tomcat-native (1.1.22-1) unstable; urgency=low
* New upstream release:
- Update d/patches/drop_sslv2_support.diff patch.
2011-07-10 - Damien Raude-Morvan <drazzib@debian.org>
tomcat-native (1.1.20-3) unstable; urgency=low
* Switch to 3.0 quilt source format.
* d/patches/drop_sslv2_support.diff: Drop support for SSLv2
(Closes: #622141).
* d/copyright: Update to DEP-5 format.
2011-04-09 - tony mancill <tmancill@debian.org>
tomcat-native (1.1.20-2) unstable; urgency=low
* Team upload.
* Remove *.la (Closes: #621279)
* Bump Standards-Version to 3.9.2 (no changes needed)
2010-02-20 - Damien Raude-Morvan <drazzib@debian.org>
tomcat-native (1.1.20-1) unstable; urgency=low
* New upstream release:
- Prevent crashing JVM on shutdown.
* Bump Standards-Version to 3.8.4 (no changes needed)
2010-01-17 - Damien Raude-Morvan <drazzib@debian.org>
tomcat-native (1.1.19-1) unstable; urgency=low
* New upstream release.
- minor versioning fix
- allows building against OpenSSL 1.0
* Add a README.Debian to help users to setup Tomcat 6.x
with Tomcat Native Library
2009-11-24 - Damien Raude-Morvan <drazzib@debian.org>
tomcat-native (1.1.18-1) unstable; urgency=high
* New upstream release.
- Fix CVE-2009-3555 SSL-Man-In-The-Middle attack
- set urgency=high to get security fix in testing
2009-11-07 - Damien Raude-Morvan <drazzib@debian.org>
tomcat-native (1.1.17-1) unstable; urgency=low
* New upstream release.
* debian/control:
- Update my email address
- Bump Standards-Version to 3.8.3 (no changes needed)
- Bump debhelper version to >= 7
- Update upstream Homepage field
- Use default-jdk instead of default-jdk-builddep as there is no
native (-gcj) package build.
* debian/copyright:
- Update upstream copyright years
- Add myself as debian/* copyright holder
* debian/libtcnative-1.lintian-overrides:
- Change to be version agnostic
2009-03-29 - Damien Raude-Morvan <drazzib@drazzib.com>
tomcat-native (1.1.16-1) unstable; urgency=low
* New upstream release (Closes: #514500)
- Fix IPv6 issues (Closes: #517163, #521306)
* debian/control:
- Move libtcnative-1 to "java" section
- Add myself to Uploaders
- Bump Standards-Version to 3.8.1 (no changes needed)
* debian/watch: Update to new upstream location
* debian/rules: Provide a "get-orig-source" target using uscan
* debian/control: Build-Depends on default-jdk-builddep
* debian/rules: use JAVA_HOME=/usr/lib/jvm/default-java
* Remove debian/libtcnative-1.install and use dh_lintian
to install debian/libtcnative-1.lintian-overrides

See Also

Package Description
libtdb-dev_1.2.10-2_i386.deb Trivial Database - development files
libtdb1_1.2.10-2_i386.deb Trivial Database - shared library
libtecla1-dev_1.6.1-5_i386.deb interactive command line editing facilities (development)
libtecla1_1.6.1-5_i386.deb interactive command line editing facilities
libteem-dev_1.11.0~svn5226-1_i386.deb Tools to process and visualize scientific data and images - development
libteem2_1.11.0~svn5226-1_i386.deb Tools to process and visualize scientific data and images - runtime
libtelepathy-farstream-dev_0.4.0-3_i386.deb Glue library between telepathy and farstream (development files)
libtelepathy-farstream-doc_0.4.0-3_all.deb Glue library between telepathy and farstream (documentation)
libtelepathy-farstream2_0.4.0-3_i386.deb Glue library between telepathy and farstream
libtelepathy-glib-dev_0.18.2-2_i386.deb GLib Telepathy connection manager library (headers)
libtelepathy-glib-doc_0.18.2-2_all.deb GLib Telepathy library (documentation)
libtelepathy-glib0_0.18.2-2_i386.deb Telepathy framework - GLib library
libtelepathy-logger-dev_0.4.0-1_i386.deb Telepathy logger service -- utility library (headers)
libtelepathy-logger-doc_0.4.0-1_all.deb Telepathy logger service -- documentation
libtelepathy-logger-qt4-1_0.4.0-1_i386.deb Qt bindings for the telepathy-logger library
Advertisement
Advertisement