libsword-utils_1.6.2+dfsg-5_i386.deb


Advertisement

Description

libsword-utils - conversion utilities for bible documents in SWORD supported formats

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name libsword-utils
Package version 1.6.2+dfsg
Package release 5
Package architecture i386
Package type deb
Installed size 488 B
Download size 193.48 KB
Official Mirror ftp.br.debian.org
The SWORD Project is an open source, cross-platform (Linux, Windows, Solaris,
MacOSX etc.) API/library for Bible software with a constantly growing list
of front-ends (GUI, textmode, web-based, etc.) and a library of over 200
text modules.
This package contains utilities to convert documents in various
formats into those suitable to be used with SWORD library.

Alternatives

Package Version Architecture Repository
libsword-utils_1.6.2+dfsg-5_amd64.deb 1.6.2+dfsg amd64 Debian Main
libsword-utils - - -

Requires

Name Value
libc6 >= 2.3.6-6~
libclucene0ldbl >= 0.9.21b
libcurl3-gnutls >= 7.16.2
libgcc1 >= 1:4.1.1
libicu48 >= 4.8-1
libstdc++6 >= 4.1.1
libsword9 >= 1.6.2+dfsg
zlib1g >= 1:1.1.4

Conflicts

Name Value
libsword6 -
libsword7 -
libsword8 -

Replaces

Name Value
libsword6 -
libsword7 -
libsword8 -

Download

Type URL
Binary Package libsword-utils_1.6.2+dfsg-5_i386.deb
Source Package sword

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsword-utils deb package:
    # sudo apt-get install libsword-utils

Files

Path
/usr/bin/addld
/usr/bin/imp2gbs
/usr/bin/imp2ld
/usr/bin/imp2vs
/usr/bin/installmgr
/usr/bin/mkfastmod
/usr/bin/mod2imp
/usr/bin/mod2osis
/usr/bin/mod2vpl
/usr/bin/mod2zmod
/usr/bin/osis2mod
/usr/bin/tei2mod
/usr/bin/vpl2mod
/usr/bin/vs2osisref
/usr/bin/vs2osisreftxt
/usr/bin/xml2gbs
/usr/share/doc/libsword-utils/changelog.Debian.gz
/usr/share/doc/libsword-utils/changelog.gz
/usr/share/doc/libsword-utils/copyright
/usr/share/man/man1/addld.1.gz
/usr/share/man/man1/imp2gbs.1.gz
/usr/share/man/man1/imp2ld.1.gz
/usr/share/man/man1/imp2vs.1.gz
/usr/share/man/man1/installmgr.1.gz
/usr/share/man/man1/mkfastmod.1.gz
/usr/share/man/man1/mod2imp.1.gz
/usr/share/man/man1/mod2osis.1.gz
/usr/share/man/man1/mod2vpl.1.gz
/usr/share/man/man1/mod2zmod.1.gz
/usr/share/man/man1/osis2mod.1.gz
/usr/share/man/man1/tei2mod.1.gz
/usr/share/man/man1/vpl2mod.1.gz
/usr/share/man/man1/vs2osisref.1.gz
/usr/share/man/man1/vs2osisreftxt.1.gz
/usr/share/man/man1/xml2gbs.1.gz

Changelog

2012-06-07 - Dmitrijs Ledkovs <xnox@debian.org>
sword (1.6.2+dfsg-5) unstable; urgency=low
* Fix FTBFS due to icu changes (Closes: #676097).
2012-04-17 - Dmitrijs Ledkovs <xnox@debian.org>
sword (1.6.2+dfsg-4) unstable; urgency=low
[ Matthias Klose ]
* Fix build failure in installed header file with GCC 4.7.
Addresses: #667387.
[ Dmitrijs Ledkovs ]
* Remove python-sword swig bindings. Loads of build-time warnings (4.6)
and errors (4.7) and the resulting module was reported not to
work. Should be readded if/when it can be build with gcc 4.7 without
errors. (Closes: #667387)
2012-04-09 - Dmitrijs Ledkovs <xnox@debian.org>
sword (1.6.2+dfsg-3) unstable; urgency=low
* Fix FTBFS if running binary-arch target only.
2012-04-07 - Dmitrijs Ledkovs <xnox@debian.org>
sword (1.6.2+dfsg-2) unstable; urgency=low
[ Dmitrijs Ledkovs <xnox@debian.org> ]
* Fix linking against CLucene
* Backport CMake changes
* Set sword config path to /etc
* ABI was broken in 1.6.2, bump soname to libsword9 (Closes: 663096)
* Split libswordX into libswordX, -utils & -common, to make libswordX
non-conflicting with libswordX+1
2010-11-30 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
sword (1.6.2+dfsg-1) unstable; urgency=low
[ Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com> ]
* Revamped debian/rules to use dh tiny rules style
* Raised compat to debhelper 7 and change associated packaging files
* Use CMake to build sword
* debian/patches/02_libver.diff: dropped, using CMake variable
* Add debian/source/local-options with VCS friendly options
* Add .bzr-builddeb/default.conf to facilitate building from bzr
* Use dpkg-buildflags
* Make CMake honour environmental variables
* Create python-sword package (LP: #49959) (Closes: 640357)
* document vs2osisreftxt.1
* 3.0 (quilt) format only (launchpad ppa supports it now)
* fix gcc-4.6 warnings
* Additional compiler error fix, thanks to
"brian m. carlson" <sandals@crustytoothpaste.net> (Closes: 624962)
* Updated debian/copyright to match the updated dep-5 spec
2010-03-22 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
sword (1.6.1+dfsg-2) unstable; urgency=low
[ Dmitrijs Ledkovs ]
* Fixed lintian warning about watch file.
* debian/patches/13_curl - Upstream fix for curl 7.20 compatibility.
* bumped standards version to 3.8.4 - no changes required.
* Update email address.
* Added upstream changelog.
* debian/copyright:
- Removed reference to unversioned GPL license
- Two files do not explictly specify GPL version
- Based on clause 9 GPL-2 & clause 14 GPL-3, GPL-2 is selected such
that to be compatible with the rest of sword
2010-01-21 - Dmitrijs Ledkovs <dmitrij.ledkov@gmail.com>
sword (1.6.1+dfsg-1) unstable; urgency=low
[ Jonathan Marsden ]
* debian/libsword8.examples: Add missing tcl eggdrop bot script.
[ Dmitrijs Ledkovs ]
* Drop shipping .la file in favour of pkg-config (Debian release goal)
- More info http://lists.debian.org/debian-devel/2009/08/msg00783.html
* Drop backported patches, refreshed libver & compiler warnings.
* Compiling with -Werror enabled. 
* Bumped standards version to 3.8.3, no changes needed.
* Added debian/README.source documentation quilt usage
* Added configure option --without-internalregex

See Also

Package Description
libsword9_1.6.2+dfsg-5_i386.deb API/library for bible software
libswscale-dev_0.8.17-2_i386.deb Development files for libswscale
libswscale-extra-2_0.8.17-2_all.deb Libav video software scaling library (transitional package)
libswscale2_0.8.17-2_i386.deb Libav video scaling library
libswt-cairo-gtk-3-jni_3.8.0~rc4-1_i386.deb Standard Widget Toolkit for GTK+ Cairo JNI library
libswt-glx-gtk-3-jni_3.8.0~rc4-1_i386.deb Standard Widget Toolkit for GTK+ GLX JNI library
libswt-gnome-gtk-3-jni_3.8.0~rc4-1_i386.deb Standard Widget Toolkit for GTK+ GNOME JNI library
libswt-gtk-3-java-gcj_3.8.0~rc4-1_i386.deb Standard Widget Toolkit for GTK+ native library
libswt-gtk-3-java_3.8.0~rc4-1_i386.deb Standard Widget Toolkit for GTK+ Java library
libswt-gtk-3-jni_3.8.0~rc4-1_i386.deb Standard Widget Toolkit for GTK+ JNI library
libswt-webkit-gtk-3-jni_3.8.0~rc4-1_i386.deb Standard Widget Toolkit for GTK+ WebKit JNI library
libswtcalendar-java_0.5-1_all.deb GUI date picker for Java using SWT
libswtchart-java-doc_0.8.0-1_all.deb Chart drawing SWT component (documentation)
libswtchart-java_0.8.0-1_all.deb Chart drawing SWT component
libsx-dev_2.05-3_i386.deb Development files (headers and static libraries) for libsx
Advertisement
Advertisement