libsearchclient-dev_0.7.7-3_i386.deb


Advertisement

Description

libsearchclient-dev - development files for libsearchclient

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name libsearchclient-dev
Package version 0.7.7
Package release 3
Package architecture i386
Package type deb
Installed size 65 B
Download size 15.87 KB
Official Mirror ftp.br.debian.org
This package is part of Strigi Desktop Search, it contains the Strigi
development files for libsearchclient.
See the 'strigi-daemon' package for more information.

Alternatives

Package Version Architecture Repository
libsearchclient-dev_0.7.7-3_amd64.deb 0.7.7 amd64 Debian Main
libsearchclient-dev - - -

Requires

Name Value
libsearchclient0 = 0.7.7-3
libstreamanalyzer-dev = 0.7.7-3

Download

Type URL
Binary Package libsearchclient-dev_0.7.7-3_i386.deb
Source Package strigi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libsearchclient-dev deb package:
    # sudo apt-get install libsearchclient-dev

Files

Path
/usr/include/strigi/asyncsocket.h
/usr/include/strigi/asyncsocketclient.h
/usr/include/strigi/clientinterface.h
/usr/include/strigi/socketclient.h
/usr/lib/libsearchclient.so
/usr/lib/libsearchclient/LibSearchClientConfig.cmake
/usr/share/doc/libsearchclient-dev/changelog.Debian.gz
/usr/share/doc/libsearchclient-dev/changelog.gz
/usr/share/doc/libsearchclient-dev/copyright

Changelog

2012-06-24 - Sune Vuorela <sune@debian.org>
strigi (0.7.7-3) unstable; urgency=low
* Team upload
* Backport a patch I wrote for upstream to fix a crash when parsing mp3
files. (Closes: #678698)
2012-05-08 - Pino Toscano <pino@debian.org>
strigi (0.7.7-2) unstable; urgency=low
* Team upload.
* Bump Standards-Version to 3.9.3, no changes required.
* rules: use make functions to filter the list of libraries.
* Bump to debhelper compat 9:
- bump debhelper build dependency to >= 9
- bump compat to 9
* Revert the changes done in 0.7.7-1.1, as now with dh compat 9 the build
flags are properly exported and used.
* rules: explicitly disable the XSD regeneration (which uses java).
* copyright: explicitly refer to /usr/share/common-licenses/GPL-2 instead of
/usr/share/common-licenses/GPL.
* Backport upstream commit a8e97f672325557b3fbc84b987299350ec5ac10b (from the
strigidaemon repository) to fix build with GCC 4.7; patch
upstream_gcc47-fix-unistd.h-header-required-unconditionally-f.patch.
(Closes: #667384)
* Encode also the SONAME in .install files of libraries.
* Remove the symbols files for libsearchclient0, libstrigihtmlgui0, and
libstrigiqtdbusclient0, since they are not really worth to maintain
(the libraries are not really used), and autogenerated shlibs should be
enough for them. (Closes: #671850)
2012-03-03 - Neil Williams <codehelp@debian.org>
strigi (0.7.7-1.1) unstable; urgency=low
* Non-maintainer upload.
* Apply patch from Thomas Weber <tweber@debian.org> to
enable builds with debug symbols. (Closes: #659893)
2011-12-31 - Fathi Boudra <fabo@debian.org>
strigi (0.7.7-1) unstable; urgency=low
* New upstream release.
* Drop Revert_patch_that_breaks_parsing_of_PDF_files.patch - stolen upstream.
* Switch to pkg-kde symbolshelper.
* Update debian/*.symbols files for amd64 and i386 architectures.
(Closes: #653804)
2011-09-23 - Fathi Boudra <fabo@debian.org>
strigi (0.7.6-2) unstable; urgency=low
* Add Revert_patch_that_breaks_parsing_of_PDF_files.patch from upstream.
(Closes: #642318)
* Improve strigi-daemon descritpion. (Closes: #571297)
2011-09-20 - Fathi Boudra <fabo@debian.org>
strigi (0.7.6-1) unstable; urgency=low
* New upstream release.
* Drop debian/patches/01_remove_FindQt4.cmake_local_copy.diff - merged
upstream.
* Update debian/compat: bump to 8.
* Update debian/control:
- bump debehlper to 8.1.3~.
- add dbus-x11, libavcodec-dev, libavformat-dev, libpostproc-dev and
libswscale-dev build dependencies.
- drop pkg-kde-tools build dependency - not used.
- drop python and python-support build dependencies.
- bump Standard-Version to 3.9.2, use Breaks instead of Conflicts.
- drop deskbar-plugins-strigi package.
* Drop debian/libstreams0.docs file - not used anymore.
* Update debian/*-dev.install files.
* Update debian/rules:
- drop useless override_dh_{pysupport, strip}.
- remove unused commented lines.
* Update symbols files.
2010-04-20 - Fathi Boudra <fabo@debian.org>
strigi (0.7.2-1) unstable; urgency=low
* New upstream release.
2010-01-07 - Fathi Boudra <fabo@debian.org>
strigi (0.7.1-1) unstable; urgency=low
* New upstream release.
* Switch to dpkg-source 3.0 (quilt) format:
- Remove quilt build dependency.
- Remove debian/README.source file.
- Remove quilt option to dh.
* Add DEP-3 header to 01_remove_FindQt4.cmake_local_copy.diff patch.
* Update debian/strigi-utils.install: add rdfindexer.

See Also

Package Description
libsearchclient0_0.7.7-3_i386.deb searchclient library for Strigi Desktop Search
libseaudit-dev_3.3.7-3_i386.deb Security Enhanced Linux audit message parser development
libseaudit4_3.3.7-3_i386.deb Security Enhanced Linux audit message parsing library
libseed-gtk3-0_3.2.0-2_i386.deb GObject JavaScript bindings for the webkit engine - Runtime
libseed-gtk3-dev_3.2.0-2_i386.deb GObject JavaScript bindings for the webkit engine - Development
libsefs-dev_3.3.7-3_i386.deb Security Enhanced Linux file context management development
libsefs4_3.3.7-3_i386.deb Security Enhanced Linux file context management
libsegment-java_1.3.5~svn57+dfsg-1.1_all.deb Rule based text splitting library
libselinux-ruby1.8_2.1.9-5_all.deb Transitional package for ruby-selinux
libselinux1-dev_2.1.9-5_i386.deb SELinux development headers
libselinux1_2.1.9-5_i386.deb SELinux runtime shared libraries
libsemanage-common_2.1.6-6_all.deb Common files for SELinux policy management libraries
libsemanage-ruby1.8_2.1.6-6_all.deb Transitional package for ruby-semanage
libsemanage1-dev_2.1.6-6_i386.deb Header files and libraries for SELinux policy manipulation
libsemanage1_2.1.6-6_i386.deb SELinux policy management library
Advertisement
Advertisement