libopengl-ruby1.9.1_0.60.1+dfsg2-1~wheezy1_all.deb


Advertisement

Description

libopengl-ruby1.9.1 - Transitional package for ruby-opengl

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package filename libopengl-ruby1.9.1_0.60.1+dfsg2-1~wheezy1_all.deb
Package name libopengl-ruby1.9.1
Package version 0.60.1+dfsg2
Package release 1~wheezy1
Package architecture all
Package type deb
Homepage -
License -
Maintainer -
Download size 6.85 KB
Installed size 33 B
This is a transitional package to ease upgrades to the ruby-opengl
package. It can safely be removed.

Alternatives

Package Version Architecture Repository
libopengl-ruby1.9.1_0.60.1+dfsg2-1~wheezy1_all.deb 0.60.1+dfsg2 all Debian Main
libopengl-ruby1.9.1 - - -

Requires

Name Value
ruby-opengl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libopengl-ruby1.9.1_0.60.1+dfsg2-1~wheezy1_all.deb
Source Package ruby-opengl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopengl-ruby1.9.1 deb package:
    # sudo apt-get install libopengl-ruby1.9.1

Files

Path
/usr/share/doc/libopengl-ruby1.9.1/changelog.Debian.gz
/usr/share/doc/libopengl-ruby1.9.1/changelog.gz
/usr/share/doc/libopengl-ruby1.9.1/copyright

Changelog

2014-01-26 - Cédric Boutillier <boutil@debian.org>
ruby-opengl (0.60.1+dfsg2-1~wheezy1) stable; urgency=medium
* Imported Upstream version 0.60.1+dfsg2
* Repack upstream tarball to remove examples/NeHe as it does not have a
clear license (Closes: #713820).
* Do not rely on Rake file to clean.
2012-06-26 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-opengl (0.60.1+dfsg1-2) unstable; urgency=low
* Bump build dependency on gem2deb to >= 0.3.0~
2012-04-23 - Cédric Boutillier <cedric.boutillier@gmail.com>
ruby-opengl (0.60.1+dfsg1-1) unstable; urgency=low
* Transition to gem2deb packaging (Closes: #651702)
+ renaming source and binary packages
* convert debian/copyright to DEP5
* debian/patches
+ 0100_remove_rubygems.patch: remove requirement on rubygems
+ 0300_fix_STR2CSTR.patch: replace deprecated STR2CSTR by
StringValuePtr (Closes: #650605)
+ 0500_fix_metadata_for_extensions.patch: fix metadata to build
correctly extensions
+ 0900_fix_orangebook_examples.patch: fix syntax in some examples
* Ignore test results during build for the moment.
* Override lintian warning about duplicate descriptions for transitional
packages
* Bump Standards-Version: to 3.9.3 (no changes needed)
* Repack upstream source tarball to remove non-free example
2010-06-08 - Deepak Tripathi <apenguinlinux@gmail.com>
libopengl-ruby (0.60.1-1) unstable; urgency=low
* New upstream release
* debian/control
+ added DMUA flag.
+ added myself to uploaders.
+ ported to ruby1.9.1.
+ remove quilt as BD.
* debian/copyright
+ added Debian's specific copyright information
and updated copyright information.
* debian/patches
+ added patch for adding ruby version's C flags.
+ added patch for backward compatibility.
* debian/rules
+ removed patchsys-quilt.mk, not required now.
+ removed ruby-extconf-rb.mk and added ruby-setup-rb.mk.
* debian/watch
+ updated source location.
2010-04-10 - Paul van Tilburg <paulvt@debian.org>
libopengl-ruby (0.32g-1) unstable; urgency=low
* New upstream release.
* Maintenance transfered to the Debian/Ruby Extras team. 
* debian/control:
- Set the maintainer to the team and myself as uploader.
- Changed the section to ruby.
- Added homepage and VCS fields. 
- Added libopengl-ruby{1.8,1.9.1} packages, transformed libopengl-ruby into
a dummy package.
- Bumped the standards version to 3.8.4.
- Dropped the Ruby 1.9.1 package; upstream is not ready yet.
- Added ${misc:Depends} to libopengl-ruby and libopengl-ruby1.8.
- Changed xlibmesa-gl-dev build depend into libgl1-mesa-dev.
- Added build depend on quilt.
* debian/rules:
- Rewritted to use CDBS and ruby-pkg-tools.
* debian/libopengl-ruby.docs, debian/libopengl.examples: Added!
* debian/source/format: Switched the source format to 3.0 (quilt).
2009-10-22 - Matt Kraai <kraai@debian.org>
libopengl-ruby (0.32f-2.1) unstable; urgency=low
* Non-maintainer upload.
* Build-depend on freeglut3-dev instead of libglut-dev. Closes: #545632.
2005-08-09 - Dafydd Harries <daf@debian.org>
libopengl-ruby (0.32f-2) unstable; urgency=low
* Apply patch from Daniel Brockman to fix typo in the API. Closes: #320741.
2004-08-02 - Dafydd Harries <daf@muse.19inch.net>
libopengl-ruby (0.32f-1) unstable; urgency=low
* New upstream release.
* debian/control:
- Update Standards-Version to 3.6.1. No changes necessary.
- Improve the package description.
- Specify ">= 1.8" for Ruby build-dependency.
- Specify xlibmesa-gl-dev as the default for the build-dependency on the
libgl-dev virtual package.
* Add a watch file.
* Make example files non-executable.
2004-03-03 - Dafydd Harries <daf@muse.19inch.net>
libopengl-ruby (0.32d-2) unstable; urgency=low
* Remove CVS directories from upstream tarball.

See Also

Package Description
libopengl-ruby_0.60.1+dfsg2-1~wheezy1_all.deb Transitional package for ruby-opengl
libopengl-xscreensaver-perl_0.04-1+b2_i386.deb Perl module for writing OpenGL-based XScreenSaver hacks
libopenhpi-dev_2.14.1-1.2_i386.deb OpenHPI libraries (development files)
libopenhpi2_2.14.1-1.2_i386.deb OpenHPI libraries (runtime and support files)
libopenid-ruby1.8_2.1.8debian-6_all.deb Transitional package for ruby-openid
libopenid-ruby_2.1.8debian-6_all.deb Transitional package for ruby-openid
libopenid4java-java-doc_0.9.6.662-1_all.deb documentation for libopenid4java
libopenid4java-java_0.9.6.662-1_all.deb This library allows you to OpenID-enable your Java webapp
libopenigtlink1-dev_1.9.2~svn7468-1_i386.deb Open IGT Link is a simple network protocol - development
libopenigtlink1.9_1.9.2~svn7468-1_i386.deb Open IGT Link is a simple network protocol - runtime
libopenimageio-dev_1.0.5+dfsg0-1_i386.deb Library for reading and writing images - development
libopenimageio1.0_1.0.5+dfsg0-1_i386.deb Library for reading and writing images - runtime
libopenipmi-dev_2.0.16-1.3_i386.deb Intelligent Platform Management Interface - development
libopenipmi0_2.0.16-1.3_i386.deb Intelligent Platform Management Interface - runtime
libopenjpa-java-doc_2.0.1-1_all.deb Documentation for libopenjpa-java
Advertisement
Advertisement