libmagic1_5.11-2+deb7u8_i386.deb


Advertisement

Description

libmagic1 - File type determination library using "magic" numbers

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package filename libmagic1_5.11-2+deb7u8_i386.deb
Package name libmagic1
Package version 5.11
Package release 2+deb7u8
Package architecture i386
Package type deb
Homepage -
License -
Maintainer -
Download size 201.23 KB
Installed size 2.39 KB
This library can be used to classify files according to magic number tests. It
implements the core functionality of the file command.

Alternatives

Package Version Architecture Repository
libmagic1_5.22+15-2~bpo7+1_amd64.deb 5.22+15 amd64 Debian Backports Main
libmagic1_5.22+15-2~bpo7+1_i386.deb 5.22+15 i386 Debian Backports Main
libmagic1_5.11-2+deb7u9_amd64.deb 5.11 amd64 Debian Security Updates Main
libmagic1_5.11-2+deb7u9_i386.deb 5.11 i386 Debian Security Updates Main
libmagic1_5.11-2+deb7u8_amd64.deb 5.11 amd64 Debian Main
libmagic1 - - -

Requires

Name Value
libc6 >= 2.8
multiarch-support -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libmagic1_5.11-2+deb7u8_i386.deb
Source Package file

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmagic1 deb package:
    # sudo apt-get install libmagic1

Files

Path
/etc/magic
/etc/magic.mime
/usr/lib/i386-linux-gnu/libmagic.so.1
/usr/lib/i386-linux-gnu/libmagic.so.1.0.0
/usr/share/bug/libmagic1/control
/usr/share/bug/libmagic1/presubj
/usr/share/doc/libmagic1/changelog.Debian.gz
/usr/share/doc/libmagic1/changelog.gz
/usr/share/doc/libmagic1/copyright
/usr/share/file/magic.mgc
/usr/share/man/man5/magic.5.gz
/usr/share/misc/magic
/usr/share/misc/magic.mgc

Changelog

2015-02-15 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
file (5.11-2+deb7u8) wheezy-security; urgency=high
* Fix partial reads in readelf.c [CVE-2014-9653]. Closes: #777585
2015-01-05 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
file (5.11-2+deb7u7) wheezy-security; urgency=high
* Fix several security issues, Closes: #773148
2014-11-09 - Pierre Schweitzer <pierre@reactos.org>
file (5.11-2+deb7u6) wheezy-security; urgency=high
* Fix CVE-2014-3710 for file 5.11/Debian wheezy. Closes: #768806
2014-09-10 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
file (5.11-2+deb7u5) wheezy-security; urgency=high
* Fix regression in detection of some CDF files, introduced in
5.11-2+deb7u4
2014-09-06 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
file (5.11-2+deb7u4) wheezy-security; urgency=high
* Fix vulnerabilites
- CVE-2014-0207
The cdf_read_short_sector function in cdf.c allows remote
attackers to cause a denial of service (assertion failure and
application exit).
- CVE-2014-0237
The cdf_unpack_summary_info function in cdf.c allows remote
attackers to cause a denial of service (performance
degradation) by triggering many file_printf calls.
- CVE-2014-0238
The cdf_read_property_info function in cdf.c allows remote
attackers to cause a denial of service (infinite loop or
out-of-bounds memory access).
- CVE-2014-3478
Buffer overflow in the mconvert function in softmagic.c i
allows remote attackers to cause a denial of service
(application crash).
- CVE-2014-3479
The cdf_check_stream_offset function in cdf.c in relies on
incorrect sector-size data, which allows remote attackers to
cause a denial of service (application crash) via a crafted
stream offset in a CDF file.
- CVE-2014-3480
The cdf_count_chain function in cdf.c in does not properly
validate sector-count data, which allows remote attackers to
cause a denial of service (application crash).
- CVE-2014-3487
The cdf_read_property_info function does not properly validate
a stream offset, which allows remote attackers to cause a
denial of service (application crash).
- CVE-2014-3538
file does not properly restrict the amount of data read during
a regex search, which allows remote attackers to cause a denial
of service (CPU consumption).
- CVE-2014-3587
Integer overflow in the cdf_read_property_info function in
cdf.c allows remote attackers to cause a denial of service
(application crash).
2014-03-21 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
file (5.11-2+deb7u3) wheezy-security; urgency=high
* Fix regression introduced in DSA-2873-1. Closes: #742262, #742265
2014-03-05 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
file (5.11-2+deb7u2) wheezy-security; urgency=high
* Backport upstream commit FILE5_14-2-gef2329c:
limit [awk detection] to 100 repetitions to avoid excessive
backtracking. Closes: #703993
* Backport upstream commit FILE5_16-24-g4475585 and
FILE5_17-20-g70c65d2:
Check properly for exceeding the offset. (CVE-2014-2270)
2014-02-13 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de>
file (5.11-2+deb7u1) wheezy-security; urgency=high
* Fix CVE-2014-1943 for file 5.11/Debian wheezy. Closes: #738832
2012-06-30 - Daniel Baumann <daniel.baumann@progress-technologies.net>
file (5.11-2) unstable; urgency=low
* Removing leading slash in debhelper install files.
* Minimizing rules file.
* Switching to xz compression.
2012-03-17 - Daniel Baumann <daniel.baumann@progress-technologies.net>
file (5.11-1) unstable; urgency=low
[ Judit Foglszinger ]
* Merging upstream version 5.11.
[ Daniel Baumann ]
* Updating to debhelper version 9.
* Removing uneeded versioned build-depends against dpkg-dev.
* Updating to standards version 3.9.3.
* Updating copyright file machine-readable format version 1.0.
* Adding todo file.

See Also

Package Description
libmagick++-dev_6.7.7.10-5+deb7u4_i386.deb object-oriented C++ interface to ImageMagick - development files
libmagick++5_6.7.7.10-5+deb7u4_i386.deb object-oriented C++ interface to ImageMagick
libmagickcore-dev_6.7.7.10-5+deb7u4_i386.deb low-level image manipulation library - development files
libmagickcore5-extra_6.7.7.10-5+deb7u4_i386.deb low-level image manipulation library - extra codecs
libmagickcore5_6.7.7.10-5+deb7u4_i386.deb low-level image manipulation library
libmagickwand-dev_6.7.7.10-5+deb7u4_i386.deb image manipulation library - development files
libmagickwand5_6.7.7.10-5+deb7u4_i386.deb image manipulation library
libmagics++-data_2.14.11-4_all.deb Data files needed for magics++ library
libmagics++-dev_2.14.11-4_i386.deb Development files for ECMWF plotting software MAGICS++
libmagplus3_2.14.11-4_i386.deb ECMWF meteorological plotting software library
libmail-box-perl_2.105-1_all.deb message-folder management module
libmail-bulkmail-perl_3.12-4_all.deb Platform independent mailing list module
libmail-cclient-perl_1.12-11+b1_i386.deb Interface to UW c-client library
libmail-checkuser-perl_1.21-2_all.deb Perl module for checking email addresses for validity
libmail-deliverystatus-bounceparser-perl_1.531-1_all.deb module for analyzing bounce messages
Advertisement
Advertisement