libedit2_2.11-20080614-5_i386.deb


Advertisement

Description

libedit2 - BSD editline and history libraries

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package filename libedit2_2.11-20080614-5_i386.deb
Package name libedit2
Package version 2.11
Package release 20080614-5
Package architecture i386
Package type deb
Homepage -
License -
Maintainer -
Download size 69.82 KB
Installed size 169 B
The editline library provides generic line editing and
history functions.
It slightly resembles GNU readline

Alternatives

Package Version Architecture Repository
libedit2_2.11-20080614-5_amd64.deb 2.11 amd64 Debian Main
libedit2 - - -

Requires

Name Value
libbsd0 >= 0.0
libc6 >= 2.11
libtinfo5 -
multiarch-support -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libedit2_2.11-20080614-5_i386.deb
Source Package libedit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libedit2 deb package:
    # sudo apt-get install libedit2

Files

Path
/usr/lib/i386-linux-gnu/libedit.so.2
/usr/lib/i386-linux-gnu/libedit.so.2.11
/usr/share/doc/libedit2/changelog.Debian.gz
/usr/share/doc/libedit2/copyright

Changelog

2012-06-01 - Anibal Monsalve Salazar <anibal@debian.org>
libedit (2.11-20080614-5) unstable; urgency=low
* Add LDFLAGS hardening flags to PMAKE_ARGS
Patch by Simon Ruderich
Closes: #675404 
2012-05-31 - Anibal Monsalve Salazar <anibal@debian.org>
libedit (2.11-20080614-4) unstable; urgency=low
* Merge 2.11-20080614-3ubuntu2 
- Fix libdir in libedit.pc to match multiarch installation paths.
- libedit/tty.c: grabs controlling terminal even when output is a non
tty, causing things like php | less to mis-function. Patch changes
this behavior to work more like readline. (LP: #322214)
* debian/control: Don't use the Vcs-Browser field
Closes: #534514
* Link against libtinfo rather than libncurses
Patch by Sven Joachim
Closes: #644421
* Remove <libedit/vis.h>
Closes: #675147
* Standards-Version is 3.9.3
* DH compatibility is 9
* Enable hardening
2012-04-02 - Colin Watson <cjwatson@ubuntu.com>
libedit (2.11-20080614-3ubuntu2) precise; urgency=low
* Fix libdir in libedit.pc to match multiarch installation paths.
2011-01-26 - Clint Byrum <clint@ubuntu.com>
libedit (2.11-20080614-3ubuntu1) precise; urgency=low
* libedit/tty.c: grabs controlling terminal even when output is a non
tty, causing things like php | less to mis-function. Patch changes
this behavior to work more like readline. (LP: #322214)
2011-08-28 - Anibal Monsalve Salazar <anibal@debian.org>
libedit (2.11-20080614-3) unstable; urgency=low
* Don't leak curses library through the pkg-config file
Patch by Guillem Jover
Closes: 534515
* Source format is 3.0 (quilt)
* Standards-Version is 3.9.2
* Fix debhelper-but-no-misc-depends
* Fix debian-rules-missing-recommended-target
* Update homepage
2011-08-17 - Steve Langasek <vorlon@debian.org>
libedit (2.11-20080614-2.2) unstable; urgency=low
* Non-maintainer upload.
* Fix a regression in the previous NMU: the pkgconfig file has gone
missing, add it back in.
2011-08-17 - Steve Langasek <vorlon@debian.org>
libedit (2.11-20080614-2.1) unstable; urgency=low
* Non-maintainer upload.
* debian/patches/fix_gcc_warnings.diff: fix warnings about deprecated
headers.  Closes: #634324.
* debian/rules: don't double-link .so files twice into the library.
Closes: #628679.
* debian/rules: cope with pmake switching us to multiarch automatically.
* debian/control: since the package is already multiarched for us by pmake,
mark it as such and bump build-dependencies on debhelper and pmake to
suit.
2010-09-21 - Anibal Monsalve Salazar <anibal@debian.org>
libedit (2.11-20080614-2) unstable; urgency=high
* libedit2.shlibs: Fix minimal dependency version 
Patch by Agustin Martin
Closes: 523260 
2009-06-22 - Anibal Monsalve Salazar <anibal@debian.org>
libedit (2.11-20080614-1) unstable; urgency=low
* Fix typo in 03-el.c-MAXPATHLEN.diff 
* Standards version is 3.8.2
* Use libbsd
Patch by Guillem Jover
Closes: 513027
2009-05-22 - Anibal Monsalve Salazar <anibal@debian.org>
libedit (2.11~20080614-2) unstable; urgency=low
* Merge with Ubuntu 
- debian/patches/20-fortify.patch: handle error conditions found
by -D_FORTIFY_SOURCE=2; closes: #488456
* Suggests libbsd0; closes: #513027
* Support crossbuilding; closes: #489846, #489847
* Homepage is
http://ftp.netbsd.org/pub/NetBSD/NetBSD-release-5-0/src/lib/libedit/
* Standards version is 3.8.1
* debhelper compatibility is 7

See Also

Package Description
libeditline-dev_1.12-6_i386.deb development files for libeditline
libeditline0_1.12-6_i386.deb line editing library similar to readline
libedje-bin_1.2.0-1_i386.deb Various binaries for use with libedje
libedje-dev_1.2.0-1_i386.deb libedje headers and static libraries
libedje-doc_1.2.0-1_all.deb libedje0 development documentation
libedje1_1.2.0-1_i386.deb Graphical layout and animation library
libee-dev_0.4.1-1_i386.deb Event expression library inspired by CEE
libee0_0.4.1-1_i386.deb Event expression library inspired by CEE
libeegdev-dev_0.2-3_i386.deb Biosignal acquisition device library (Developement files)
libeegdev0_0.2-3_i386.deb Biosignal acquisition device library
libeet-bin_1.6.0-1_i386.deb Enlightenment DR17 file chunk reading/writing utility
libeet-dev_1.6.0-1_i386.deb Enlightenment DR17 file chunk reading/writing library development files
libeet-doc_1.6.0-1_all.deb libeet1 API documentation
libeet1_1.6.0-1_i386.deb Enlightenment DR17 file chunk reading/writing library
libefreet-dev_1.2.0-1_i386.deb Development files for libefreet and libefreet-mime
Advertisement
Advertisement