gksu_2.0.2-6_i386.deb


Advertisement

Description

gksu - graphical frontend to su

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name gksu
Package version 2.0.2
Package release 6
Package architecture i386
Package type deb
Installed size 453 B
Download size 80.88 KB
Official Mirror ftp.br.debian.org
gksu is a Gtk+ frontend to /bin/su. It supports login shells
and preserving environment when acting as a su frontend. It
is useful to menu items or other graphical programs that need
to ask a user's password to run another program as another user.

Alternatives

Package Version Architecture Repository
gksu_2.0.2-6_amd64.deb 2.0.2 amd64 Debian Main
gksu - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.3.6-6~
libcairo2 >= 1.2.4
libfontconfig1 >= 2.8.0
libfreetype6 >= 2.2.1
libgconf2-4 >= 2.31.1
libgdk-pixbuf2.0-0 >= 2.22.0
libgksu2-0 >= 2.0.8
libglib2.0-0 >= 2.16.0
libgnome-keyring0 >= 2.20.3
libgtk2.0-0 >= 2.8.0
libpango1.0-0 >= 1.14.0
libstartup-notification0 >= 0.2
sudo -

Provides

Name Value
gnome-sudo -

Conflicts

Name Value
gnome-sudo <= 0.3-1.1

Replaces

Name Value
gnome-sudo -
libgksu0 -

Download

Type URL
Binary Package gksu_2.0.2-6_i386.deb
Source Package gksu

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gksu deb package:
    # sudo apt-get install gksu

Files

Path
/usr/bin/gksu
/usr/bin/gksudo
/usr/share/applications/gksu.desktop
/usr/share/doc/gksu/AUTHORS
/usr/share/doc/gksu/README
/usr/share/doc/gksu/changelog.Debian.gz
/usr/share/doc/gksu/changelog.gz
/usr/share/doc/gksu/copyright
/usr/share/gksu/gksu-migrate-conf.sh
/usr/share/locale/ar/LC_MESSAGES/gksu.mo
/usr/share/locale/ca/LC_MESSAGES/gksu.mo
/usr/share/locale/cs/LC_MESSAGES/gksu.mo
/usr/share/locale/da/LC_MESSAGES/gksu.mo
/usr/share/locale/de/LC_MESSAGES/gksu.mo
/usr/share/locale/es/LC_MESSAGES/gksu.mo
/usr/share/locale/fr/LC_MESSAGES/gksu.mo
/usr/share/locale/gl/LC_MESSAGES/gksu.mo
/usr/share/locale/hu/LC_MESSAGES/gksu.mo
/usr/share/locale/it/LC_MESSAGES/gksu.mo
/usr/share/locale/ja/LC_MESSAGES/gksu.mo
/usr/share/locale/ko/LC_MESSAGES/gksu.mo
/usr/share/locale/lt/LC_MESSAGES/gksu.mo
/usr/share/locale/nb/LC_MESSAGES/gksu.mo
/usr/share/locale/nl/LC_MESSAGES/gksu.mo
/usr/share/locale/pl/LC_MESSAGES/gksu.mo
/usr/share/locale/pt/LC_MESSAGES/gksu.mo
/usr/share/locale/pt_BR/LC_MESSAGES/gksu.mo
/usr/share/locale/ro/LC_MESSAGES/gksu.mo
/usr/share/locale/ru/LC_MESSAGES/gksu.mo
/usr/share/locale/sk/LC_MESSAGES/gksu.mo
/usr/share/locale/sv/LC_MESSAGES/gksu.mo
/usr/share/locale/th/LC_MESSAGES/gksu.mo
/usr/share/locale/xh/LC_MESSAGES/gksu.mo
/usr/share/locale/zh_CN/LC_MESSAGES/gksu.mo
/usr/share/man/man1/gksu.1.gz
/usr/share/man/man1/gksudo.1.gz
/usr/share/menu/gksu
/usr/share/pixmaps/gksu-debian.xpm
/usr/share/pixmaps/gksu-icon.png
/usr/share/pixmaps/gksu-root-terminal.png
/usr/share/pixmaps/gksuexec-debian.xpm

Changelog

2011-10-10 - Michael Biebl <biebl@debian.org>
gksu (2.0.2-6) unstable; urgency=low
* Drop the nautilus-gksu package. It won't be ported to GNOME 3 and is
blocking the nautilus 3 transition. Closes: #637325
* Switch to dpkg source format 3.0 (quilt)
- Add debian/source/format.
- Remove simple-patchsys.mk include from debian/rules.
- Drop Build-Depends on sng and replace debian/gksu-root-terminal.sng by
the final .png file. We no longer need to create it during build time.
- Add debian/source/include-binaries for debian/gksu-root-terminal.png.
* Bump debhelper compatibility level to 8.
* Remove pre-lenny upgrade code, drop debian/gksu.postinst.
* Bump Standards-Version to 3.9.2.
* debian/patches/02_format_security.patch
- Fix possible format string vulnerabilities. Closes: #643389
* debian/copyright
- Refer to GPL-2 not the versionless GPL license file.
* Updated Russian translation by Sergey Alyoshin. Closes: #547448
* Updated Portuguese translation by Américo Monteiro. Closes: #567587
2010-11-06 - Josselin Mouette <joss@debian.org>
gksu (2.0.2-5) unstable; urgency=low
* 01_desktop_in.patch: new patch. Ship gksu.desktop.in since it was 
forgot in the upstream tarball. Closes: #601257.
2010-10-19 - Josselin Mouette <joss@debian.org>
gksu (2.0.2-4) unstable; urgency=low
* New Brazilian Portuguese translation by Sérgio Cipolla. 
Closes: #585484.
* 99_intltool.patch: update po/Makefile.in.in with a working intltool
version. Closes: #599424.
2010-05-29 - Josselin Mouette <joss@debian.org>
gksu (2.0.2-3) unstable; urgency=low
* Only recommend gnome-keyring, gksu works fine without it (especially 
in sudo mode).
* Move the symlink to nautilus-gksu. Closes: #583647.
* Add a Replaces this time to avoid running into the same bug the 
other way round.
2009-04-01 - Gustavo Noronha Silva <kov@debian.org>
gksu (2.0.2-2) unstable; urgency=high
* debian/gksu.links:
- add link to the extension-1.0 ABI directory, to make nautilus-gksu
available to the previous version as well; we use a small enough part
of the ABI that it works for boths, from my testing (Closes: #520511)
2009-03-04 - Gustavo Noronha Silva <kov@debian.org>
gksu (2.0.2-1) unstable; urgency=low
* New upstream bug fix release
- reverts bogus change that breaks mode configuration through gconf
(Closes: #517474)
2009-02-22 - Gustavo Noronha Silva <kov@debian.org>
gksu (2.0.1-1) unstable; urgency=low
* Long awaited new upstream release
- nautilus-gksu supports newer versions of nautilus, and ported to GIO
* debian/control.in:
- added Homepage, Vcs-* headers, and upgraded Standards-Version to 3.8.1
* debian/patches/{00_all_linguas,02_fr.po}.diff, 01_nautilus_crash.diff:
- removed; applied upstream
* debian/patches/03_dbus_address.diff:
- removed; a slightly different approach has been adopted upstream
* debian/control.in:
- require libgksu2.0-dev >= 2.0.8, since we use new API from it
2009-02-04 - Josselin Mouette <joss@debian.org>
gksu (2.0.0-8) unstable; urgency=low
* Brown paper bag release.
* 03_dbus_address.diff: remove the ORBIT_SOCKETDIR environment 
variable instead of the D-Bus one. Really closes: #512803.
* debian/pos/th.po: Thai translation of gksu by Theppitak 
Karoonboonyanan. Closes: #513358.
2009-01-26 - Josselin Mouette <joss@debian.org>
gksu (2.0.0-7) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* debian/control.in: Wrap dependencies.
[ Loic Minier ]
* Clean up postinst and use lt-nl instead of checking $2.
* Add depends on {misc:Depends} to the nautilus package as well.
* Drop Debian revision from libgksu build-dep.
[ Josselin Mouette ]
* 03_dbus_address.diff: new patch. Remove the D-Bus session bus 
address from the environment to work around a bug in libbonobo when 
launching the root terminal. Closes: #512803.

See Also

Package Description
gl-117-data_1.3.2-2.1_all.deb Data files for gl-117
gl-117_1.3.2-2.1_i386.deb An action flight simulator
glabels-data_3.0.0-3_all.deb data files for gLabels
glabels-dev_3.0.0-3+b1_i386.deb development documentation and library files for gLabels
glabels_3.0.0-3+b1_i386.deb label, business card and media cover creation program for GNOME
glade-xfce_4.8.1-1_i386.deb glade modules for xfce
glade_3.12.1-1_i386.deb GTK+ User Interface Builder
gladish_1+dfsg0-3_i386.deb graphical interface for LADI Session Handler
glam2_1064-1_i386.deb gapped protein motifs from unaligned sequences
glance-api_2012.1.1-5_all.deb OpenStack Image Service - API server
glance-common_2012.1.1-5_all.deb OpenStack Image Service - common files
glance-registry_2012.1.1-5_all.deb OpenStack Image Service - registry server
glance_2012.1.1-5_all.deb OpenStack Image Service - metapackage
glark_1.8.0-1.1~deb7u1_all.deb pattern matching tool similar to grep
glassfish-activation_2.1.1-b31g-3_all.deb Open source Java EE 5 Application Server
Advertisement
Advertisement