gir1.2-vte-2.90_0.32.2-1_i386.deb


Advertisement

Description

gir1.2-vte-2.90 - GObject introspection data for the VTE library

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main i386
Package name gir1.2-vte-2.90
Package version 0.32.2
Package release 1
Package architecture i386
Package type deb
Installed size 423 B
Download size 379.17 KB
Official Mirror ftp.br.debian.org
This package contains introspection data for VTE, a terminal emulator
widget for GTK+.
It can be used by interpreters understanding the GIRepository format to
write programs using the VTE widget for GTK+ 3.0.

Alternatives

Package Version Architecture Repository
gir1.2-vte-2.90_0.32.2-1_amd64.deb 0.32.2 amd64 Debian Main
gir1.2-vte-2.90 - - -

Requires

Name Value
gir1.2-atk-1.0 -
gir1.2-freedesktop -
gir1.2-gdkpixbuf-2.0 -
gir1.2-glib-2.0 -
gir1.2-gtk-3.0 -
gir1.2-pango-1.0 -
libvte-2.90-9 >= 1:0.27.90

Download

Type URL
Binary Package gir1.2-vte-2.90_0.32.2-1_i386.deb
Source Package vte3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-vte-2.90 deb package:
    # sudo apt-get install gir1.2-vte-2.90

Files

Path
/usr/lib/girepository-1.0/Vte-2.90.typelib
/usr/share/doc/gir1.2-vte-2.90/AUTHORS
/usr/share/doc/gir1.2-vte-2.90/NEWS.gz
/usr/share/doc/gir1.2-vte-2.90/README
/usr/share/doc/gir1.2-vte-2.90/changelog.Debian.gz
/usr/share/doc/gir1.2-vte-2.90/changelog.gz
/usr/share/doc/gir1.2-vte-2.90/copyright

Changelog

2012-06-01 - Michael Biebl <biebl@debian.org>
vte3 (1:0.32.2-1) unstable; urgency=low
* New upstream release.
- Fixes broken Alt/Meta/Mod1 handling. Closes: #648975
* Refresh patches.
* Remove debian/patches/02_meta.patch, fixed upstream in a different way.
2012-04-25 - Michael Biebl <biebl@debian.org>
vte3 (1:0.32.1-1) unstable; urgency=low
* New upstream release.
2012-04-02 - Michael Biebl <biebl@debian.org>
vte3 (1:0.32.0-2) unstable; urgency=low
* Install a copy of the old termcap file so currently running terminal
instances which have the old version of the library loaded, aren't broken
by the upgrade. This workaround is only temporary. Closes: #665771
* debian/watch: Track stable releases.
* Bump Standards-Version to 3.9.3.
* Update debian/copyright using the machine-readable copyright format 1.0.
* Drop Build-Depends on gir1.2-gtk-3.0, pulled by libgtk-3-dev.
2012-03-21 - Martin Pitt <mpitt@debian.org>
vte3 (1:0.32.0-1) experimental; urgency=low
* New upstream release.
* debian/control.in: Bump glib build dependency as per configure.ac.
* Drop 03_glade-catalog-library-name.patch, fixed upstream.
* 25_optional-ncurses.patch: Unfuzz.
* Add 03_scroll_region_updates.patch: Fix glitches with interspersing writes
to the bottom line with scrolls of the upper region. Patch taken from
Ubuntu package. (GNOME #542087, LP: #246701)
* Add 04_workaround_resources_compiler_path.patch: Drop --sourcedir from
glib-compile-resources call. It is not necessary here, and breaks
out-of-tree builds with absolute configure paths, such as cdbs does.
Works around GNOME #672541.
* debian/libvte-2.90-{common,9-udeb}.install: Drop termcap file, it's built
in using GResource now.
* debian/rules: Explicitly configure with --enable-gtk-doc, it's disabled
now by default.
* debian/libvte-2.90-9.symbols: Add new symbol from this release.
2012-03-13 - Michael Biebl <biebl@debian.org>
vte3 (1:0.30.1-4) unstable; urgency=low
* debian/patches/03_glade-catalog-library-name.patch: Use the correct
vte library name in the glade catalog file.
* Move the glade catalog file from libvte-2.90-common into libvte-2.90-dev
alongside the .so it references.
* Add the necessary Breaks/Replaces.
2011-12-12 - Michael Biebl <biebl@debian.org>
vte3 (1:0.30.1-3) unstable; urgency=low
* debian/control.in:
- Remove obsolete Replaces.
- Change section of gir1.2-vte-2.90 to introspection.
- Remove X-Python-Version, since we no longer build a python module.
* debian/rules:
- Correctly pass libexecdir to configure so libvte has the correct path to
gnome-pty-helper.
* Update install and lintian override file for the updated gnome-pty-helper
location. We use the full library package name as subdirectory now, so we
don't get file conflicts on soname bumps.
2011-11-19 - Josselin Mouette <joss@debian.org>
vte3 (1:0.30.1-2) unstable; urgency=low
* libvte-2.90-9.symbols: add correct Build-Depends-Package.
* 02_meta.patch: workaround for Meta key being broken since the GTK+ 
3.2.2 upgrade. Closes: #648975.
2011-11-12 - Josselin Mouette <joss@debian.org>
vte3 (1:0.30.1-1) experimental; urgency=low
* New upstream release.
* Drop all GTK+ 2.x support since it has disappeared upstream.
* Rename source package accordingly.
* Bump gtk+ build-dependency.
* Call dpkg-gensymbols -c4.
* Add appropriate Breaks/Replaces for moved files.
* Create a udeb for the gtk3 version.
2011-10-19 - Michael Biebl <biebl@debian.org>
vte (1:0.28.2-1) unstable; urgency=low
* New upstream release.
* debian/watch:
- Track .xz tarballs.
* Refresh debian/patches/25_optional-ncurses.patch.
* debian/control.in:
- Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer.
- Add Vcs-* fields.
- Bump Standards-Version to 3.9.2. No further changes.
* Switch to dh_python2.

See Also

Package Description
gir1.2-webkit-1.0_1.8.1-3.4_i386.deb GObject introspection data for the WebKit library
gir1.2-webkit-3.0_1.8.1-3.4_i386.deb GObject introspection data for the WebKit library
gir1.2-wnck-3.0_3.4.2-1_i386.deb GObject introspection data for the WNCK library
gir1.2-xkl-1.0_5.2.1-1_i386.deb X Keyboard Extension high-level API - introspection data
gis-data_0.0.2_all.deb Debian GIS data
gis-gps_0.0.2_all.deb GPS related programs
gis-osm_0.0.2_all.deb OpenStreetMap related programs
gis-remotesensing_0.0.2_all.deb Remote sensing and earth observation
gis-statistics_0.0.2_all.deb Statistics with geographical data
gis-tasks_0.0.2_all.deb Debian GIS tasks for tasksel
gis-web_0.0.2_all.deb Present geographic information via web map server
gis-workstation_0.0.2_all.deb Geographic Information Systems (GIS) workstation
git-all_1.7.10.4-1+wheezy3_all.deb fast, scalable, distributed revision control system (all subpackages)
git-annex_3.20120629_i386.deb manage files with git, without checking their contents into git
git-arch_1.7.10.4-1+wheezy3_all.deb fast, scalable, distributed revision control system (arch interoperability)
Advertisement
Advertisement