xmltooling-schemas_1.4.2-5+deb7u1_all.deb


Advertisement

Description

xmltooling-schemas - XML schemas for XMLTooling

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name xmltooling-schemas
Package version 1.4.2
Package release 5+deb7u1
Package architecture all
Package type deb
Installed size 78 B
Download size 15.53 KB
Official Mirror ftp.br.debian.org
The XMLTooling library contains generic XML parsing and processing
classes based on the Xerces-C DOM.  It adds more powerful facilities for
declaring element- and type-specific API and implementation classes, as
well as signing and encryption support.
This package contains the XML schema files used by the XMLTooling
library.

Alternatives

Package Version Architecture Repository
xmltooling-schemas_1.5.3-2~bpo70+1_all.deb 1.5.3 all Debian Backports Main
xmltooling-schemas_1.5.3-2~bpo70+1_all.deb 1.5.3 all Debian Backports Main
xmltooling-schemas_1.4.2-5+deb7u3_all.deb 1.4.2 all Debian Security Updates Main
xmltooling-schemas_1.4.2-5+deb7u3_all.deb 1.4.2 all Debian Security Updates Main
xmltooling-schemas_1.4.2-5+deb7u1_all.deb 1.4.2 all Debian Main
xmltooling-schemas - - -

Download

Type URL
Binary Package xmltooling-schemas_1.4.2-5+deb7u1_all.deb
Source Package xmltooling

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install xmltooling-schemas deb package:
    # sudo apt-get install xmltooling-schemas

Files

Path
/usr/share/doc/xmltooling-schemas/NOTICE.txt
/usr/share/doc/xmltooling-schemas/changelog.Debian.gz
/usr/share/doc/xmltooling-schemas/copyright
/usr/share/xml/xmltooling/catalog.xml
/usr/share/xml/xmltooling/soap-envelope.xsd
/usr/share/xml/xmltooling/xenc-schema.xsd
/usr/share/xml/xmltooling/xml.xsd
/usr/share/xml/xmltooling/xmldsig-core-schema.xsd
/usr/share/xml/xmltooling/xmldsig11-schema.xsd
/usr/share/xml/xmltooling/xmltooling.xsd

Changelog

2015-07-27 - Ferenc Wagner <wferi@niif.hu>
xmltooling (1.4.2-5+deb7u1) wheezy-security; urgency=high
* Apply security fix from 1.5.5 for CVE-2015-0851 DoS (Closes: #793855):
Shibboleth SP software crashes on well-formed but invalid XML
2012-01-31 - Russ Allbery <rra@debian.org>
xmltooling (1.4.2-5) unstable; urgency=low
* Revert changes to add symbols file.  Due to churn in weak symbols for
inlined functions, it doesn't appear maintainanable with existing
tools, and for this library the shlibs behavior seems sufficient.
* Update Autotools build files via dh_autoreconf.
* Force linking with -lpthread, working around a bug in libtool that
drops the linkage because it uses -nostdlib.  See #468555.
2012-01-27 - Russ Allbery <rra@debian.org>
xmltooling (1.4.2-4) unstable; urgency=low
* Update symbols files for all non-i386 architectures currently built by
the buildds except mipsel (which will hopefully be the same as mips),
armel (modeled after armhf), nad kfreebsd-i386 (hopefully the same as
i386).
* Build-Depend on pkg-kde-tools and use its symbolhelper plugin so that
the package can use the output of pkgkde-symbolshelper.
2012-01-27 - Russ Allbery <rra@debian.org>
xmltooling (1.4.2-3) unstable; urgency=low
* Also enable bindnow hardening build flags and use the correct syntax
to add additional hardening flags.
* Add symbols file constructed with pkgkde-symbolshelper.  Add a
README.source file with a pointer to the documentation.
2012-01-26 - Russ Allbery <rra@debian.org>
xmltooling (1.4.2-2) unstable; urgency=low
* Update to debhelper compatibility level V9.
- Enable hardening build flags.  (Closes: #656656)
- Enable multiarch support.
* Use the latest directory in debian/watch instead of the versioned
directories.
* Update the upstream homepage.
* Update the upstream download location in debian/copyright.
* Minor format updates to debian/copyright for the new DEP-5.
2011-07-25 - Russ Allbery <rra@debian.org>
xmltooling (1.4.2-1) unstable; urgency=low
* New upstream release.
- Fix use attribute in shorthand file CredentialResolver
- Fix handling of SOAP 1.1 fault package
- Make library init routines idempotent
* Make removal of the Doxygen-installed jquery.js file conditional on
its existence, since some versions of Doxygen don't install it.
* Update debian/watch for the new upstream distribution location.
2011-04-07 - Russ Allbery <rra@debian.org>
xmltooling (1.4.1-3) unstable; urgency=low
* Add explicit build dependency on libssl-dev, which is used directly by
this package, and force build dependency on libssl-dev 1.0 or later
for consistent build results.  If some Shibboleth-related libraries
are built against earlier versions of libssl, it produces linking
failures when building the Shibboleth SP package.
* Update standards version to 3.9.2 (no changes required).
2011-03-16 - Russ Allbery <rra@debian.org>
xmltooling (1.4.1-2) unstable; urgency=low
* Fix FTBFS with arch-only builds, such as those on the buildds.
Thanks, Aaron M. Ucko.  (Closes: #618615)

See Also

Package Description
xmltv-gui_0.5.63-2_all.deb Graphical user interface related to the XMLTV file format
xmltv-util_0.5.63-2_all.deb Utilities related to the XMLTV file format for TV listings
xmltv_0.5.63-2_all.deb Functionality related to the XMLTV file format for TV listings
xmms2-client-avahi_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - avahi client
xmms2-client-cli_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - cli client
xmms2-client-medialib-updater_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - medialib-updater client
xmms2-client-nycli_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - new cli client
xmms2-core_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - core package
xmms2-dev_0.8+dfsg-4+deb7u1_all.deb XMMS2 - plug-in development files
xmms2-icon_0.8+dfsg-4+deb7u1_all.deb XMMS2 - icon package
xmms2-plugin-airplay_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - airplay output plug-in
xmms2-plugin-all_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - all plug-ins
xmms2-plugin-alsa_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - ALSA output
xmms2-plugin-ao_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - libao output plug-in
xmms2-plugin-apefile_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - Monkey's Audio decoder plug-in
Advertisement
Advertisement