xiphos_3.1.5+dfsg-1+b2_amd64.deb


Advertisement

Description

xiphos - environment for Bible reading, study, and research

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name xiphos
Package version 3.1.5+dfsg
Package release 1+b2
Package architecture amd64
Package type deb
Installed size 1.16 KB
Download size 407.01 KB
Official Mirror ftp.br.debian.org
Xiphos is a Bible study program for the GNOME desktop environment, based on The
SWORD Project by the CrossWire Bible Society, a framework for developing Bible
study tools and of associated texts such as commentaries and dictionaries.
This package provides the main Xiphos program, a digital text reader with
bookmarks and full-text search. It allows viewing multiple versions of the same
text, for parallel reading of alternatives or translations. It also supports
personal verse-specific notes and a rich-text study pad, both of which have
spell checking and full-text search.
Xiphos has a built-in facility to browse and install freely-distributed content
from CrossWire repositories.

Alternatives

Package Version Architecture Repository
xiphos_3.1.5+dfsg-1+b2_i386.deb 3.1.5+dfsg i386 Debian Main
xiphos - - -

Requires

Name Value
gconf-service -
libatk1.0-0 >= 1.12.4
libc6 >= 2.3
libcairo-gobject2 >= 1.10.0
libcairo2 >= 1.2.4
libdbus-1-3 >= 1.0.2
libdbus-glib-1-2 >= 0.88
libenchant1c2a >= 1.6
libgcc1 >= 1:4.1.1
libgconf-2-4 >= 2.31.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.24.0
libgsf-1-114 >= 1.14.8
libgtk-3-0 >= 3.0.0
libgtkhtml-4.0-0 << 4.5
libgtkhtml-4.0-0 >= 4.4
libgtkhtml-editor-4.0-0 << 4.5
libgtkhtml-editor-4.0-0 >= 4.4
libjavascriptcoregtk-3.0-0 >= 1.5.1
libpango1.0-0 >= 1.18.0
libsoup2.4-1 >= 2.4.0
libstdc++6 >= 4.1.1
libsword9 >= 1.6.2+dfsg
libwebkitgtk-3.0-0 >= 1.3.10
libxml2 >= 2.7.4
xiphos-data = 3.1.5+dfsg-1

Provides

Name Value
sword-frontend -

Conflicts

Name Value
xiphos-svn -

Replaces

Name Value
xiphos-data -

Download

Type URL
Binary Package xiphos_3.1.5+dfsg-1+b2_amd64.deb
Source Package xiphos

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install xiphos deb package:
    # sudo apt-get install xiphos

Files

Path
/usr/bin/xiphos
/usr/share/applications/xiphos.desktop
/usr/share/doc/xiphos/AUTHORS
/usr/share/doc/xiphos/NEWS.gz
/usr/share/doc/xiphos/README
/usr/share/doc/xiphos/RELEASE-NOTES.gz
/usr/share/doc/xiphos/TODO
/usr/share/doc/xiphos/changelog.Debian.gz
/usr/share/doc/xiphos/changelog.gz
/usr/share/doc/xiphos/copyright
/usr/share/icons/hicolor/scalable/apps/xiphos.svg
/usr/share/man/man1/xiphos.1.gz

Changelog

2012-03-11 - Dmitrijs Ledkovs <xnox@debian.org>
xiphos (3.1.5+dfsg-1) unstable; urgency=low
[ Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com> ]  
* New upstream release.
* Build using webkit backend
* Contains unpacked source for waf binary (Closes: #654511)
* Update debian/copyright to latest specification
2011-06-25 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
xiphos (3.1.4-3) unstable; urgency=low
[ Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com> ]
* Drop xulrunner, use gtkhtml instead. (Closes: #631049) (LP: #756201)
* Drop quilt dependency (daily ppa converts 3.0 quilt format to 3.0 native)
* Bump policy to 3.9.2, no changes required.
2010-11-29 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
xiphos (3.1.4-2) unstable; urgency=low
[ Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com ]
* Release to unstable
* Simplify and reduce logic in debian/rules.
* Drop gnomesword package now that squeeze is released
* Add dependency (renamed) libgtkhtml-editor-3.14-dev (Closes: #613971)
2010-11-25 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
xiphos (3.1.4-1) experimental; urgency=low
[ Jonathan Marsden ]
* New upstream release 3.1.4
* Removed debian/patch/* since the one patch was included upstream.
* Bumped Standards-Version to 3.9.1 (no changes required).
* debian/README.Debian: Corrected spelling and reworded for clarity.
* debian/control: Add Jonathan Marsden back into Uploaders.
[ Dmitrijs Ledkovs ]
* Added local options dpkg-source to unapply patches and fail on
upstream source changes (ignoring false positives).
* Added bzr-builddeb hook to generate source-format before build. If you
are not using bzr-builddeb, you must run "./debian/rules clean" before
building.
* patches/xul-2.0.patch: bump UPPER_RANGE to allow running against xul20.
2010-05-24 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
xiphos (3.1.3-3) unstable; urgency=low
* Fix FTBFS on hppa (Closes: #582904)
2010-04-03 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
xiphos (3.1.3-2) unstable; urgency=low
* Fixing Intrepid->Karmic builds. It was a perl bug.
* Added debug package
* Manually adding xulrunner dependency when dh_xulrunner is not available.
* Lzma compressed debs when version has ~ (e.g. ppa)
* Source format 3.0 (quilt) official, 1.0 ppas
* Keeping XDG desktop file & icon in arch package to appear in appinstall-data
* Cleaned up build-dependencies
* Rebuild to pick up new gtkhtml dependency (Closes: #582169)
2010-03-22 - Dmitrijs Ledkovs <dmitrij.ledkov@ubuntu.com>
xiphos (3.1.3-1) unstable; urgency=low
* New upstream release:
+ Bugfix only
+ Compatible with xulrunner 1.9.2
+ Update translations
* Revert changes introduced in 3.1.2-1ubuntu1. Thank you Chris Coulson
for temporary fix.
* debian/xiphos.1 - spelling mistake
* waf is now default buildsystem
* help is now licensed under GPL
* Bumped standards version no changes required
* Changed email to @ubuntu.com
2010-03-12 - Chris Coulson <chris.coulson@canonical.com>
xiphos (3.1.2-1ubuntu1) lucid; urgency=low
* debian/patches/xul192-workaround.patch:
- Ensure that we don't load the 1.9.2 GRE if it is installed, as
1.9.2 makes xiphos unusable at the moment. This is a temporary 
measure until the new xulrunner behaviour is understood
* debian/control:
- Explicitly depend xulrunner-1.9.1
* debian/rules:
- Don't call dh_xulrunner to automatically populate the binary depends.
This is known to be broken in xulrunner-1.9.1 (it adds an incorrectly
versioned dependency). We add it manually instead
2010-02-28 - Micah Gersten <micahg@ubuntu.com>
xiphos (3.1.2-1build1) lucid; urgency=low
* No source change rebuild against xulrunner-1.9.2 (LP: #536877)

See Also

Package Description
xipmsg_0.8088-2.1_amd64.deb A pop up style message communication software
xiterm+thai_1.10-2_amd64.deb X terminal program with Thai languague support
xjadeo_0.6.4-1_amd64.deb Video player with JACK sync
xjdic_24-8_amd64.deb Japanese-English dictionary search program
xjed_0.99.19-2.1_amd64.deb editor for programmers (x11 version)
xjig_2.4-13+b2_amd64.deb An X11 jigsaw puzzle
xjobs_20110730-1_amd64.deb reads job description line by line and executes them in parallel
xjokes_1.0-13_amd64.deb X11 jokes
xjump_2.7.5-6.1_amd64.deb jumping game for X
xkb-data_2.5.1-3_all.deb X Keyboard Extension (XKB) configuration data
xkbind_2010.05.20-1_amd64.deb X Keyboard Extension Indicator
xkbset_0.5-5.1_amd64.deb Small utility to change the AccessX settings of XKEYBOARD
xkeycaps_2.47-4_amd64.deb manipulate X11 keymaps (for xmodmap) graphically
xl2tpd_1.3.1+dfsg-1_amd64.deb layer 2 tunneling protocol implementation
xlassie_1.8-21_amd64.deb Dockable mail notifier w/ message count & POP3/APOP/IMAP support
Advertisement
Advertisement