wordpress-shibboleth_1.4-2_all.deb


Advertisement

Description

wordpress-shibboleth - Shibboleth plugin for WordPress

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name wordpress-shibboleth
Package version 1.4
Package release 2
Package architecture all
Package type deb
Installed size 116 B
Download size 22.31 KB
Official Mirror ftp.br.debian.org
This plugin is designed to support integrating your WordPress blog into
your existing identity management infrastructure using a Shibboleth
Service Provider.
WordPress can be configured so that all standard login requests will be
sent to your configured Shibboleth Identity Provider or Discovery Service.
Upon successful authentication, a new WordPress account will be
automatically provisioned for the user if one does not already exist.
User attributes (username, first name, last name, display name, nickname,
and email address) can be synchronized with your enterprise's system of
record each time the user logs into WordPress.
Finally, the user's role within WordPress can be automatically set (and
continually updated) based on any attribute Shibboleth provides. For
example, you may decide to give users with an eduPersonAffiliation value
of faculty the WordPress role of editor, while the eduPersonAffiliation
value of student maps to the WordPress role contributor. Or you may choose
to limit access to WordPress altogether using a special
eduPersonEntitlement value.

Alternatives

Package Version Architecture Repository
wordpress-shibboleth_1.4-2+deb7u1_all.deb 1.4 all Debian Security Updates Main
wordpress-shibboleth_1.4-2+deb7u1_all.deb 1.4 all Debian Security Updates Main
wordpress-shibboleth_1.4-2_all.deb 1.4 all Debian Main
wordpress-shibboleth - - -

Requires

Name Value
libapache2-mod-shib2 -
wordpress >= 2.8

Download

Type URL
Binary Package wordpress-shibboleth_1.4-2_all.deb
Source Package wordpress-shibboleth

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install wordpress-shibboleth deb package:
    # sudo apt-get install wordpress-shibboleth

Files

Path
/usr/share/doc/wordpress-shibboleth/buildinfo.gz
/usr/share/doc/wordpress-shibboleth/changelog.Debian.gz
/usr/share/doc/wordpress-shibboleth/copyright
/usr/share/doc/wordpress-shibboleth/readme.txt.gz
/usr/share/wordpress/wp-content/plugins/shibboleth/icon.png
/usr/share/wordpress/wp-content/plugins/shibboleth/options-admin.php
/usr/share/wordpress/wp-content/plugins/shibboleth/options-user.php
/usr/share/wordpress/wp-content/plugins/shibboleth/shibboleth-mu.php
/usr/share/wordpress/wp-content/plugins/shibboleth/shibboleth.php
/usr/share/wordpress/wp-content/plugins/shibboleth/localization/shibboleth.pot

Changelog

2011-01-30 - Dominic Hargreaves <dom@earth.li>
wordpress-shibboleth (1.4-2) unstable; urgency=low
* Add debian/watch file
2010-09-15 - Dominic Hargreaves <dom@earth.li>
wordpress-shibboleth (1.4-1) unstable; urgency=low
* New upstream release
* Relax dependency on wordpress version to 2.8, as stated in upstream
readme.txt
2010-08-09 - Dominic Hargreaves <dom@earth.li>
wordpress-shibboleth (1.3-1) unstable; urgency=low
* Initial release based on wordpress-openid package (Closes: #590852)
* Include bugfix for <http://wordpress.org/support/topic/shibboleth-plugin-does-not-hold-managed-settings>

See Also

Package Description
wordpress-xrds-simple_1.0-1_all.deb XRDS-Simple plugin for WordPress
wordpress_3.6.1+dfsg-1~deb7u10_all.deb weblog manager
worker-data_2.19.2-2_all.deb data files for worker
worker_2.19.2-2_amd64.deb highly configurable two-paned file manager for X
worklog_1.8-6_amd64.deb Keep Track of Time worked on Projects
workrave-data_1.9.909+abc941eb70-1_all.deb Repetitive Strain Injury prevention tool (data files)
workrave_1.9.909+abc941eb70-1_amd64.deb Repetitive Strain Injury prevention tool
wormux-data_11.04.1+repack-4_all.deb transitional package for warmux-data
wormux-servers_11.04.1+repack-4_all.deb transitional package for warmux-servers
wormux_11.04.1+repack-4_all.deb transitional package for warmux
wotsap_0.7-2_all.deb OpenPGP Web of Trust analyzer and pathfinder
wp2x_2.5-mhi-10.1_amd64.deb WordPerfect 5.x documents to whatever converter
wpagui_1.0-3+deb7u3_amd64.deb graphical user interface for wpa_supplicant
wpasupplicant_1.0-3+deb7u3_amd64.deb client support for WPA and WPA2 (IEEE 802.11i)
wpd2odt_0.8.1-4_amd64.deb WordPerfect to OpenDocument converter
Advertisement
Advertisement