widelands_17-3_amd64.deb


Advertisement

Description

widelands - fantasy real-time strategy game

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name widelands
Package version 17
Package release 3
Package architecture amd64
Package type deb
Installed size 5.38 KB
Download size 2.11 MB
Official Mirror ftp.br.debian.org
Widelands is a strategy game aiming for gameplay similar to Settlers II by
BlueByte.
In this game, you start out on a small piece of land with nothing more than
a few of useful resources. Using those, you can build yourself an empire
with many thousands of inhabitants. On your way towards this goal, you will
have to build up an economic infrastructure, explore the lands around you
and face enemies who are trying to rule the world just like you do.

Alternatives

Package Version Architecture Repository
widelands_17-3_i386.deb 17 i386 Debian Main
widelands - - -

Requires

Name Value
libboost-signals1.49.0 >= 1.49.0-1
libc6 >= 2.2.5
libgcc1 >= 1:4.1.1
libgl1 -
libgl1-mesa-glx -
libglew1.7 >= 1.7.0
liblua5.1-0 -
libpng12-0 >= 1.2.13-4
libsdl-gfx1.2-4 >= 2.0.22
libsdl-image1.2 >= 1.2.10
libsdl-mixer1.2 -
libsdl-net1.2 -
libsdl-ttf2.0-0 -
libsdl1.2debian >= 1.2.11
libstdc++6 >= 4.6
ttf-freefont -
widelands-data = 1:17-3
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package widelands_17-3_amd64.deb
Source Package widelands

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install widelands deb package:
    # sudo apt-get install widelands

Files

Path
/usr/games/widelands
/usr/share/applications/widelands.desktop
/usr/share/doc/widelands/changelog.Debian.gz
/usr/share/doc/widelands/changelog.gz
/usr/share/doc/widelands/copyright
/usr/share/man/man6/widelands.6.gz
/usr/share/menu/widelands

Changelog

2012-05-02 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:17-3) unstable; urgency=low
* add debian/compat (7)
* add patch boost-linking-4.7 to fix linking error with boost
and gcc 4.7. This also links widelands dinamically with
boost, as per policy (Closes: #672034)
* add patch Werror to fix compilation with gcc 4.7 and the
-Werror=format-security flag
2012-05-02 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:17-2) unstable; urgency=low
* define PATH_MAX if not defined (i.e. on hurd)
* re-enable patch for s390 but not on s390x
2012-04-24 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:17-1) experimental; urgency=low
* new upstream release
* disable patches/s390
* debian/rules: use && istead of ; so that failures are reported correctly 
* we go to experimental to see if s390 is happy and not to disturb
transitions for libpng15 and boost
2012-04-13 - Martin Quinson <mquinson@debian.org>
widelands (1:17~rc2-3) unstable; urgency=low
* on kfreebsd, the execinfo library cannot be found for an unkown reason.
Try to survive this fact to fix the resulting FTBFS.
2012-04-12 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:17~rc2-2) unstable; urgency=low
* call make and not make all
2012-04-11 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:17~rc2-1) unstable; urgency=low
* New upstream release candidate
* Add patches/dbg_symbols to compile -g to generate the -dbg package
* Update build dependencies, including the removal of GGZ (Closes: #655402)
* Fixed flags passed to cmake for locales (Closes: #645127, LP: #872777)
2011-04-19 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:16-1) unstable; urgency=low
* New upstream release
2011-04-06 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:16~rc1-1) unstable; urgency=low
* New upsteram release candidate 
* Updated Standards-Version to 3.9.1, no changes required 
* Removed patches/secfix-617960 since part of the new release 
* Do not override widelands version number in debian/rules
2011-03-23 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:15-3) unstable; urgency=high
* Closes a potential security issue in internet games.
Added: patches/secfix-617960 (Closes: #617960)
2010-05-10 - Enrico Tassi <gareuselesinge@debian.org>
widelands (1:15-2) unstable; urgency=low
* add patch s390 to fix FTBFS on s390. The patch defines
explicit _Index(uintptr_t  const I), so that it's call
is not ambiguous.

See Also

Package Description
widemargin_1.0.11-4_all.deb bible reading and study application
wifi-radar_2.0.s08+dfsg-1.1_all.deb graphical utility for managing Wi-Fi profiles
wiggle_0.8+dfsg1-1_amd64.deb apply patches with conflicting changes
wiipdf_1.4-2_amd64.deb present a PDF file using your wiimote
wiki2beamer_0.9.4-1_all.deb Tool to create LaTeX beamer presentations in wiki syntax
wikipedia2text_0.11-2_all.deb displays Wikipedia articles on the command line
wikipediafs_0.4-4_all.deb View and edit Wikipedia articles as if they were real files
wildmidi_0.2.3.4-2.1_amd64.deb software MIDI player
wiliki_0.6.2-1_all.deb Yet another Wiki clone written in Scheme
wily_0.13.41-7.2_amd64.deb A work-alike of the Acme programming environment for Plan 9
wims-help_4.01-2_all.deb help files for wims
win32-loader_0.7.4.7+deb7u2_all.deb Debian-Installer loader for win32
winbind_3.6.6-6+deb7u7_amd64.deb Samba nameservice integration server
windowlab_1.40-1_amd64.deb small and simple Amiga-like window manager
windows-el_2.41-3_all.deb window manager for GNU Emacs
Advertisement
Advertisement