vpnc_0.5.3r512-2_amd64.deb


Advertisement

Description

vpnc - Cisco-compatible VPN client

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name vpnc
Package version 0.5.3r512
Package release 2
Package architecture amd64
Package type deb
Installed size 252 B
Download size 93.25 KB
Official Mirror ftp.br.debian.org
vpnc is a VPN client compatible with cisco3000 VPN Concentrator (also
known as Cisco's EasyVPN equipment). vpnc runs entirely in userspace
and does not require kernel modules except for the tun driver to
communicate with the network layer.
It supports most of the features needed to establish connection to the
VPN concentrator: MD5 and SHA1 hashes, 3DES and AES ciphers, PFS and
various IKE DH group settings.

Alternatives

Package Version Architecture Repository
vpnc_0.5.3r512-2_i386.deb 0.5.3r512 i386 Debian Main
vpnc - - -

Requires

Name Value
dpkg >= 1.15.7.2
libc6 >= 2.8
libgcrypt11 >= 1.4.5
libgnutls26 >= 2.12.17-0
perl -

Download

Type URL
Binary Package vpnc_0.5.3r512-2_amd64.deb
Source Package vpnc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install vpnc deb package:
    # sudo apt-get install vpnc

Files

Path
/etc/vpnc/default.conf
/etc/vpnc/vpnc-script
/usr/bin/cisco-decrypt
/usr/bin/pcf2vpnc
/usr/sbin/vpnc
/usr/sbin/vpnc-connect
/usr/sbin/vpnc-disconnect
/usr/share/doc/vpnc/README.Debian.gz
/usr/share/doc/vpnc/README.gz
/usr/share/doc/vpnc/TODO.gz
/usr/share/doc/vpnc/changelog.Debian.gz
/usr/share/doc/vpnc/changelog.gz
/usr/share/doc/vpnc/copyright
/usr/share/lintian/overrides/vpnc
/usr/share/man/man1/cisco-decrypt.1.gz
/usr/share/man/man1/pcf2vpnc.1.gz
/usr/share/man/man8/vpnc-connect.8.gz
/usr/share/man/man8/vpnc-disconnect.8.gz
/usr/share/man/man8/vpnc.8.gz

Changelog

2012-03-13 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
vpnc (0.5.3r512-2) unstable; urgency=low
* Turned maintainer scripts into proper shell scripts (thanks, Johannes
Schauer!). Closes: #663206
* Added a pre-dependency on dpkg (>= 1.15.7.2) for dpkg-maintscript-helper.
* Bumped Standards-Version to 3.9.3.
2012-02-15 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
vpnc (0.5.3r512-1) unstable; urgency=low
* Imported new upstream SVN snapshot with support for Fritz!Box routers
(closes: #629646), fixed MTU when no default route (closes: #525389).
* Refreshed patches, dropped 07_bug496718.patch, 08_bug640978.patch 
(applied upstream).
* Added missing ${perl:Depends}.
* Updated debian/copyright to reflect recent work in SVN.
* Updated README.Debian, clarified security warning (closes: #442629) and
added a note on NetworkManager integration.
* Properly remove obsolete conffile example.conf on upgrade.
* Simplify debian/rules (PREFIX ony needed for install - thanks gregoa).
* Added a get-orig-source target to debian/rules.
* Bumped debhelper compatibility to level 9 for extra hardening build flags.
* Added fix_makefile_VERSION.patch so that vpnc will report the correct
version including SVN revision.
2012-01-09 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
vpnc (0.5.3r449-3) unstable; urgency=low
* New maintainer.
* Use source "3.0 (quilt)", dh 8 and minimal debian/rules.
+ Converted patch system from dpatch to quilt.
+ Added DEP-3 headers and refreshed 07_bug496718.patch.
* Don't ship duplicate sample config in examples, and go with upstream's
default.conf.
* Install cisco-decrypt and pcf2vpnc into /usr/bin like upstream does,
increasing visibility.
* debian/control: Added Homepage field.
* Added fix_make_test.patch: cert0.pem has expired, remove it from test.
* Rewrote debian/copyright according to DEP-5.
* Added debian/watch.
* Bumped Standards-Version to 3.9.2 (no changes necessary).
2011-11-24 - Florian Schlichting <fschlich@zedat.fu-berlin.de>
vpnc (0.5.3r449-2.2) unstable; urgency=low
* Non-maintainer upload.
* Bug fix: "more verbose iproute makes vpnc fail connecting", taken from
http://git.infradead.org/users/dwmw2/vpnc-scripts.git/commitdiff/4deaaf9a32
Closes: #624203, #640978, LP: #805435.
2010-11-09 - Reinhard Tartler <siretart@tauware.de>
vpnc (0.5.3r449-2.1) unstable; urgency=low
* Non-maintainer upload.
* Bug fix: "Disconnects after an hour and loops trying to reconnect",
thanks to Daniel Schepler (Closes: #496718, LP: #479632). Patch taken
from upstream: http://www.gossamer-threads.com/lists/vpnc/devel/3442
2010-03-20 - Eric Warmenhoven <warmenhoven@debian.org>
vpnc (0.5.3r449-2) unstable; urgency=low
* Add pkg-config build-dependency. (closes: #574715)
2010-03-17 - Eric Warmenhoven <warmenhoven@debian.org>
vpnc (0.5.3r449-1) unstable; urgency=low
* New upstream SVN snapshot with GnuTLS support (closes: #513645, #440318)
* Change resolvconf from "Recommends" to "Suggests (closes: #519947)
* Since /var/run/vpnc is automatically created, no need to have it as
part of vpnc.dirs (fixes lintian error)
2008-12-15 - Eric Warmenhoven <warmenhoven@debian.org>
vpnc (0.5.3-1) unstable; urgency=low
* New maintainer (closes: #508590)
* New upstream release (closes: #506265)
+ fixes bug in pcf2vpnc which causes too many spaces (closes: #456550)
+ fixes prompting for password even though it's in the configuration
file (closes: #492981) 
2008-07-19 - Eduard Bloch <blade@debian.org>
vpnc (0.5.1r334-1) unstable; urgency=low
* New upstream SVN snapshot with various bugfixes
* removed the warning section from our manpage patch, was adopted upstream
(closes: 469865)
2007-12-23 - Eduard Bloch <blade@debian.org>
vpnc (0.5.1r275-1) unstable; urgency=low
* New upstream SVN snapshot with various bugfixes
* A very very very very urgent "fix" from Nicolas Duboc to put cisco-decrypt
into /usr/lib/vpnc (closes: #454236)

See Also

Package Description
vprerex_6.4.0-3_amd64.deb Qt interface to prerex, a course prerequisite chart editor
vpx-tools_1.1.0-1_amd64.deb VP8 video codec encoding/decoding tools
vrfy_990522-8_amd64.deb verify electronic mail addresses
vrms_1.16_all.deb virtual Richard M. Stallman
vrrpd_1.0-2_amd64.deb Virtual Router Redundancy Protocol user-space implementation
vsd2odg_0.8.1-4_amd64.deb Visio to OpenDocument converter
vsdump_0.0.45-1_amd64.deb Convert Microsoft Visio diagrams .vsd, .vss
vsftpd_2.3.5-3_amd64.deb lightweight, efficient FTP server written for security
vstream-client-dev_1.2-6.1_amd64.deb Development headers for vstream-client
vstream-client_1.2-6.1_amd64.deb library and utility to fetch media streams from a TIVO
vtgrab_0.1.8-3_amd64.deb A VNC like console monitoring
vtk-doc_5.8.0-13_all.deb VTK class reference documentation
vtk-examples_5.8.0-13_all.deb C++, Tcl and Python example programs/scripts for VTK
vtkdata_5.8.0-1_all.deb Example data for VTK
vtprint_2.0.2-12_amd64.deb Prints to term emulator via ANSI codes
Advertisement
Advertisement