system-config-printer-udev_1.3.7-4_amd64.deb


Advertisement

Description

system-config-printer-udev - Utilities to detect and configure printers automatically

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name system-config-printer-udev
Package version 1.3.7
Package release 4
Package architecture amd64
Package type deb
Installed size 137 B
Download size 78.24 KB
Official Mirror ftp.br.debian.org
These utilities allow to detect automatically printers using UDEV when they
are plugged on the system. They are then configured automatically in the CUPS
printing daemon and made available to users.

Alternatives

Package Version Architecture Repository
system-config-printer-udev_1.4.3-4~bpo70+1_i386.deb 1.4.3 i386 Debian Backports Main
system-config-printer-udev_1.4.3-4~bpo70+1_amd64.deb 1.4.3 amd64 Debian Backports Main
system-config-printer-udev_1.3.7-4_i386.deb 1.3.7 i386 Debian Main
system-config-printer-udev - - -

Requires

Name Value
libc6 >= 2.4
libcups2 >= 1.4.0
libglib2.0-0 >= 2.12.0
libudev0 >= 154
libusb-0.1-4 >= 2:0.1.12
python >= 2.6
python-cups >= 1.9.42
python-cupshelpers = 1.3.7-4
python-dbus -

Conflicts

Name Value
hal-cups-utils << 0.6.17

Download

Type URL
Binary Package system-config-printer-udev_1.3.7-4_amd64.deb
Source Package system-config-printer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install system-config-printer-udev deb package:
    # sudo apt-get install system-config-printer-udev

Files

Path
/lib/udev/udev-add-printer
/lib/udev/udev-configure-printer
/lib/udev/rules.d/70-printers.rules
/usr/share/doc/system-config-printer-udev/AUTHORS
/usr/share/doc/system-config-printer-udev/README
/usr/share/doc/system-config-printer-udev/changelog.Debian.gz
/usr/share/doc/system-config-printer-udev/changelog.gz
/usr/share/doc/system-config-printer-udev/copyright

Changelog

2013-01-25 - Laurent Bigonville <bigon@debian.org>
system-config-printer (1.3.7-4) unstable; urgency=low
* debian/control.in: Add missing Depends against python-dbus
(Closes: #627810)
* debian/python-cupshelpers.install: Install missing
/etc/cupshelpers/preferreddrivers.xml file (Closes: #695582)
* debian/patches/0005-Fix-French-translation.patch: Fix confusing French
translation (Closes: #615113)
2011-12-22 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.3.7-3) unstable; urgency=low
* Upload to unstable
* Bump standards version to 3.9.2. No source changes.
* Remove now superfulous '/usr/bin/env' removal.  Upstream removed this
already.
* Adjust download URL
2011-12-17 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.3.7-2) experimental; urgency=low
* Add pycurl dependency to control.in too.
Thanks; Michael Biebl (Closes: #652387)
2011-12-13 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.3.7-1) experimental; urgency=low
* New upstream version 1.3.7 (Closes: #642211)
* Update watch file.
Upstream uses xz now (Closes: #646320)
* Drop superfluous patches.
0003-Adjust-package-names.patch
0004-Fix-blacklist-name.patch
0005-Revert-to-the-correct-menu-category.patch
0006-Don-t-blindly-listen-to-any-signal.patch
* configure: Enable installation of udev rule
* Fix MITM via unencrypted metadata download (CVE-2011-4405).
Patch taken from Ubuntu. Thanks to Till Kamppeter
2010-09-28 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.2.3-3) unstable; urgency=high
* Depend on libxml2 (Closes: #597723)
* Make system-config-printer conflict on hal-cups-utils to help
lenny->>squeeze updates. Otherwise hal-cups-utils won't get removed. See
http://lists.debian.org/debian-release/2010/09/msg00923.html for a
discussion.
2010-09-12 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.2.3-2) unstable; urgency=low
* python-cupshelpers: Don't Break and Replace python-cupsutils since we
don't share any files and this eases upgrades via apt-get.
2010-08-31 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.2.3-1) unstable; urgency=medium
[ Guido Günther ]
* Add Vcs-{Svn,Browser} and Homepage URLs
* Add myself to uploaders
* pyversions, control.in: require python 2.6 (Closes: #594901)
[ Josselin Mouette ]
* pyversions, control.in: require python 2.5. Closes: #594402.
2010-08-20 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.2.3-0.3) unstable; urgency=low
* Non-maintainer upload.
* Upload to unstable.
2010-08-13 - Guido Günther <agx@sigxcpu.org>
system-config-printer (1.2.3-0.2) experimental; urgency=low
* Non-maintainer upload.
* Install debug.py and smburi.py in the cupshelpers package
(Closes: #525714)

See Also

Package Description
system-config-printer_1.3.7-4_all.deb graphical interface to configure the printing system
system-tools-backends-dev_2.10.2-1_all.deb System Tools to manage computer configuration -- development files
system-tools-backends_2.10.2-1_amd64.deb System Tools to manage computer configuration -- scripts
systemd-gui_44-11+deb7u4_amd64.deb system and service manager - GUI
systemd-sysv_44-11+deb7u4_amd64.deb system and service manager - SysV links
systemd_44-11+deb7u4_amd64.deb system and service manager
systempreferences.app_1.1.0-2+b3_amd64.deb GNUstep preferences application
systemsettings_4.8.4-6_amd64.deb System Settings
systemtap-client_1.7-1+deb7u1_amd64.deb instrumentation system for Linux (client for compile server)
systemtap-common_1.7-1+deb7u1_all.deb instrumentation system for Linux (common component)
systemtap-doc_1.7-1+deb7u1_all.deb documentation and examples for SystemTap
systemtap-grapher_1.7-1+deb7u1_amd64.deb instrumentation system for Linux (grapher)
systemtap-runtime_1.7-1+deb7u1_amd64.deb instrumentation system for Linux (runtime component)
systemtap-sdt-dev_1.7-1+deb7u1_amd64.deb statically defined probes development files
systemtap-server_1.7-1+deb7u1_amd64.deb instrumentation system for Linux (compile server)
Advertisement
Advertisement