spidermonkey-bin_24.8.1esr-2~deb7u1_amd64.deb


Advertisement

Description

spidermonkey-bin - standalone JavaScript/ECMAScript (ECMA-262) interpreter

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name spidermonkey-bin
Package version 24.8.1esr
Package release 2~deb7u1
Package architecture amd64
Package type deb
Installed size 5.61 KB
Download size 1.67 MB
Official Mirror ftp.br.debian.org
SpiderMonkey is a standalone JavaScript/ECMAScript interpreter. It can either
take input from files or from a command line driven interface.
It is not recommended for production use, as it contains dangerous
(security-wise) debugging features.
ECMAScript (ECMA-262) is a dynamic scripting language supporting prototype
based object construction. The basic syntax is intentionally similar to
both Java and C++ to reduce the number of new concepts required to learn
the language. Language constructs, such as if statements, for and while
loops, and switch and try ... catch blocks function the same as these
languages (or nearly so).
JavaScript is a superset of the ECMA-262 Edition 3 (ECMAScript) standard
first introduced by Netscape and now led by the Mozilla project.

Alternatives

Package Version Architecture Repository
spidermonkey-bin_24.8.1esr-2~deb7u1_amd64.deb 24.8.1esr amd64 Debian Security Updates Main
spidermonkey-bin_24.8.1esr-2~deb7u1_i386.deb 24.8.1esr i386 Debian Security Updates Main
spidermonkey-bin_24.8.1esr-2~deb7u1_i386.deb 24.8.1esr i386 Debian Main
spidermonkey-bin - - -

Requires

Name Value
libc6 >= 2.4
libffi5 >= 3.0.4
libgcc1 >= 1:4.1.1
libreadline6 >= 6.0
libstdc++6 >= 4.1.1
zlib1g >= 1:1.1.4

Download

Type URL
Binary Package spidermonkey-bin_24.8.1esr-2~deb7u1_amd64.deb
Source Package xulrunner

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install spidermonkey-bin deb package:
    # sudo apt-get install spidermonkey-bin

Files

Path
/usr/bin/smjs
/usr/share/doc/spidermonkey-bin/MPL-1.1.gz
/usr/share/doc/spidermonkey-bin/MPL-2.0.gz
/usr/share/doc/spidermonkey-bin/changelog.Debian.gz
/usr/share/doc/spidermonkey-bin/copyright
/usr/share/man/man1/smjs.1.gz
/usr/share/menu/spidermonkey-bin

Changelog

2014-10-25 - Mike Hommey <glandium@debian.org>
xulrunner (24.8.1esr-2~deb7u1) stable-security; urgency=medium
* debian/control*, debian/extra-stuff/Makefile.in,
debian/installer/Makefile.in, debian/rules, debian/upstream.mk,
debian/noinstall.in: Only build xulrunner.
* debian/branding/*, debian/browser.*, debian/debsearch.xml,
debian/duckduckgo.xml, debian/firefox.in,
debian/installer/package-manifest.browser, debian/l10n.filter,
debian/l10n/*, debian/source/include-binaries, debian/vendor.js.in:
Removed.
* debian/patches: Unapplied and removed iceweasel-specific patches.
2014-09-25 - Mike Hommey <glandium@debian.org>
iceweasel (24.8.1esr-1~deb7u1) stable-security; urgency=medium
* New upstream release.
* Fixes for mfsa2014-73, also known as CVE-2014-1568.
2014-09-03 - Mike Hommey <glandium@debian.org>
iceweasel (24.8.0esr-1~deb7u1) stable-security; urgency=medium
* New upstream release.
* Fixes for mfsa2014-{67,72}, also known as
CVE-2014-1562, CVE-2014-1567.
2014-07-23 - Mike Hommey <glandium@debian.org>
iceweasel (24.7.0esr-1~deb7u1) stable-security; urgency=medium
* New upstream release.
* Fixes for mfsa2014-{56,61-64}, also known as
CVE-2014-1547, CVE-2014-1555, CVE-2014-1556, CVE-2014-1544,
CVE-2014-1557.
2014-06-11 - Mike Hommey <glandium@debian.org>
iceweasel (24.6.0esr-1~deb7u1) stable-security; urgency=medium
* New upstream release.
* Fixes for mfsa2014-{48-49,52,55}, also known as
CVE-2014-1533, CVE-2014-1538, CVE-2014-1541, CVE-2014-1545.
2014-04-29 - Mike Hommey <glandium@debian.org>
iceweasel (24.5.0esr-1~deb7u1) stable-security; urgency=medium
* New upstream release.
* Fixes for mfsa2014-{34,37-38,42-44,46}, also known as
CVE-2014-1518, CVE-2014-1523, CVE-2014-1524, CVE-2014-1529,
CVE-2014-1530, CVE-2014-1531, CVE-2014-1532.
* debian/control.in: Don't depend on nss and nspr dev and dbg packages when
building with LESS_SYSTEM_LIBS. Closes: #744187.
* debian/control*, debian/browser.mozconfig, debian/xulrunner.mozconfig.in:
Disable gstreamer support. Because the ffmpeg gstreamer 0.10 plugin is not
available in testing/unstable anymore, and gstreamer support is not
enabled by default anyways.
* debiab/control*: Build depend on iso-codes.
2014-03-19 - Mike Hommey <glandium@debian.org>
iceweasel (24.4.0esr-1~deb7u2) stable-security; urgency=low
* debian/rules: Disable the test suite.
2014-03-19 - Mike Hommey <glandium@debian.org>
iceweasel (24.4.0esr-1~deb7u1) stable-security; urgency=low
* New upstream release.
* Fixes for mfsa2014-{15,17,26-32}, also known as
CVE-2014-1493, CVE-2014-1497, CVE-2014-1508, CVE-2014-1509,
CVE-2014-1505, CVE-2014-1510, CVE-2014-1511, CVE-2014-1512,
CVE-2014-1513, CVE-2014-1514.
* debian/noinstall.in, debian/xulrunner-dev.install.in: Install
mozilla-nspr.pc and mozilla-nss.pc when building backports. Closes: #739490.
* xulrunner/installer/mozilla-ns*.pc.in: Fix includedir in mozilla-nspr.pc
and mozilla-nss.pc. bz#985200.

See Also

Package Description
spikeproxy_1.4.8-4.1_all.deb Web application security testing proxy
spim_8.0+dfsg-5.1_amd64.deb MIPS R2000/R3000 emulator
spinner_1.2.4-3_amd64.deb Sends small packets over a idle link
spip_2.1.17-1+deb7u5_all.deb website engine for publishing
spl-core_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language
spl-curl_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language -- curl adapter
spl-dev_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language -- development files
spl-mysql_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language -- MySQL adapter
spl-postgres_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language -- postgres adapter
spl-sdl_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language -- SDL adapter
spl-sqlite_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language -- sqlite adapter
spl-webspl_1.0~pre6-3.1+b1_amd64.deb SPL based web application framework
spl-xml_1.0~pre6-3.1+b1_amd64.deb SPL Programming Language -- XML adapter
splat_1.4.0-2_amd64.deb analyze point-to-point terrestrial RF communication links
splay_0.9.5.2-13_amd64.deb Sound player for MPEG-1,2 layer 1,2,3
Advertisement
Advertisement