ruby_1.9.3_all.deb


Advertisement

Description

ruby - Interpreter of object-oriented scripting language Ruby (default version)

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name ruby
Package version 1.9.3
Package architecture all
Package type deb
Installed size 31 B
Download size 6.33 KB
Official Mirror ftp.br.debian.org
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in perl).  It is simple,
straight-forward, and extensible.
This package is a dependency package, which depends on Debian's default Ruby
version (currently v1.9.3).

Alternatives

Package Version Architecture Repository
ruby_1.9.3_all.deb 1.9.3 all Debian Main
ruby - - -

Requires

Name Value
ruby1.9.1 >= 1.9.3.194-1

Provides

Name Value
irb -
rdoc -

Conflicts

Name Value
irb -
rdoc -

Replaces

Name Value
irb -
rdoc -

Download

Type URL
Binary Package ruby_1.9.3_all.deb
Source Package ruby-defaults

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby deb package:
    # sudo apt-get install ruby

Files

Path
/usr/share/doc/ruby/README.Debian
/usr/share/doc/ruby/changelog.gz
/usr/share/doc/ruby/copyright

Changelog

2013-02-23 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (1:1.9.3) unstable; urgency=low
* declare Breaks: apt-listbugs (<< 0.1.6) in ruby package to avoid breaking
squeeze/wheezy upgrades when apt-listbugs is installed (Closes: 700671).
2012-06-03 - Antonio Terceiro <terceiro@debian.org>
ruby-defaults (4.9) unstable; urgency=low
[ Shawn Landden ]
* Switch default ruby version to 1.9.
* Drop "transitional package" desciptions to something more similar to
Python default version packages.
* Convert copyright file to machine readable specification.
[ Antonio Terceiro ]
* debian/control:
+ add myself to Uploaders:
+ bump standards version to 3.9.3. No changes needed.
* added debian/source/format
2011-04-26 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.8) unstable; urgency=high
* Drop ruby-elisp, since the corresponding ruby1.8 package was dropped.
2011-03-25 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.7) unstable; urgency=low
* Switch to git. Update Vcs-* fields.
* Upload to unstable.
* Sync Maintainers and Uploaders with those from ruby1.8 and ruby1.9.1
* Bump Standards-Version to 3.9.1. No changes needed.
2011-03-05 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.6) experimental; urgency=low
* Remove the Ruby policy from the package. It is no longer applied to ruby
packages anyway.
* Make all binary packages transitional packages for their ruby1.8
counterparts. This source package can be dropped after the wheezy release.
* Upload to experimental. Changes are very intrusive and need
extensive testing.
2010-05-03 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.5) unstable; urgency=low
* Merge irb and rdoc into ruby.
* Merge lib{dbm,gdbm,readline,openssl}-ruby into libruby.
2010-03-18 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.4) unstable; urgency=low
* Change section to ruby. Agree with ftpmaster.
* Drop transitional dummy packages,  not needed in squeeze:
libtk-ruby libcurses-ruby libzlib-ruby libyaml-ruby libwebrick-ruby
libxmlrpc-ruby librexml-ruby libtest-unit-ruby liberb-ruby libdrb-ruby
libracc-runtime-ruby libiconv-ruby libstrscan-ruby libsyslog-ruby
libbigdecimal-ruby libpty-ruby libdl-ruby libsdbm-ruby
* Standards-Version -> 3.8.4. No changes needed.
* Add ${misc:Depends} everywhere to make lintian happy.
2010-03-18 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.3) unstable; urgency=low
* In the 'ruby' meta-package, suggest to install the main other packages
that are of interest to ruby users.
2008-03-20 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.2) unstable; urgency=low
* debian/control: Added Homepage and Vcs-* fields.
* Added ruby-dev package, depending on ruby1.8-dev. (Closes: #301534)
2008-01-17 - Lucas Nussbaum <lucas@lucas-nussbaum.net>
ruby-defaults (4.1) unstable; urgency=low
* Switched to cdbs.
* Added ruby-full package, which depends on everything part of the "normal"
ruby tarball-based installation. Supersedes the ruby-full source package.
Closes: #460465.
* Corrected Conflicts/Replaces. I was using < 1:1.8.2-3, because, before
using 3, 4, 4.1 as verisoning scheme, I considered using an epoch, but
changed my mind. Fixes unreported build failure of rails.

See Also

Package Description
rubyfilter-doc_0.12-2_all.deb A mail filtering library for Ruby (documentation)
rubygems-doc_1.8.24-1_all.deb Transitional package for rubygems
rubygems-integration_1.1_all.deb integrates Debian Ruby packages with Rubygems
rubygems1.8_1.8.24-1_all.deb Transitional package for rubygems
rubygems_1.8.24-1_all.deb package management framework for Ruby libraries/applications
rumor_1.0.5-1_amd64.deb Realtime MIDI keyboard to Lilypond converter
rungetty_1.2-15_amd64.deb minimal console getty that can run any process
runit_2.1.1-6.2_amd64.deb system-wide service supervision
runlim_1.7-1_amd64.deb tool for sampling time and memory usage
runsnakerun_2.0.2a1-2_all.deb GUI utility for (Python) cProfile or Profile profiler dumps
rusers_0.17-8_amd64.deb Displays who is logged in to machines on local network
rusersd_0.17-8_amd64.deb Logged in users server
rush_1.7+dfsg-1+deb7u1_amd64.deb restricted user shell
rwall_0.17-7_amd64.deb Send a message to users logged on a host
rwalld_0.17-7_amd64.deb Write messages to users currently logged in server
Advertisement
Advertisement