python-zope.testing_3.10.2-1_all.deb


Advertisement

Description

python-zope.testing - Zope testing framework, including the testrunner script

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name python-zope.testing
Package version 3.10.2
Package release 1
Package architecture all
Package type deb
Installed size 480 B
Download size 60.43 KB
Official Mirror ftp.br.debian.org
This package provides a number of testing frameworks. It includes a flexible
test runner, and supports both doctest and unittest.

Alternatives

Package Version Architecture Repository
python-zope.testing_3.10.2-1_all.deb 3.10.2 all Debian Main
python-zope.testing - - -

Requires

Name Value
python << 2.8
python >= 2.6.6-7~
python-pkg-resources -
python-zope -
python-zope.exceptions -
python-zope.interface -
python-zope.testrunner -
python2.6 -
python2.7 -

Provides

Name Value
python2.6-zope.testing -
python2.7-zope.testing -

Conflicts

Name Value
python-zodb << 2.9
zope3 -

Download

Type URL
Binary Package python-zope.testing_3.10.2-1_all.deb
Source Package zope.testing

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-zope.testing deb package:
    # sudo apt-get install python-zope.testing

Files

Path
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2-nspkg.pth
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2.egg-info/PKG-INFO
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2.egg-info/SOURCES.txt
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2.egg-info/dependency_links.txt
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2.egg-info/namespace_packages.txt
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2.egg-info/not-zip-safe
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2.egg-info/requires.txt
/usr/lib/python2.6/dist-packages/zope.testing-3.10.2.egg-info/top_level.txt
/usr/lib/python2.6/dist-packages/zope/testing/__init__.py
/usr/lib/python2.6/dist-packages/zope/testing/cleanup.py
/usr/lib/python2.6/dist-packages/zope/testing/doctest.txt
/usr/lib/python2.6/dist-packages/zope/testing/doctestunit.py
/usr/lib/python2.6/dist-packages/zope/testing/exceptions.py
/usr/lib/python2.6/dist-packages/zope/testing/formparser.py
/usr/lib/python2.6/dist-packages/zope/testing/formparser.txt
/usr/lib/python2.6/dist-packages/zope/testing/loggingsupport.py
/usr/lib/python2.6/dist-packages/zope/testing/loghandler.py
/usr/lib/python2.6/dist-packages/zope/testing/module.py
/usr/lib/python2.6/dist-packages/zope/testing/module.txt
/usr/lib/python2.6/dist-packages/zope/testing/server.py
/usr/lib/python2.6/dist-packages/zope/testing/setupstack.py
/usr/lib/python2.6/dist-packages/zope/testing/setupstack.txt
/usr/lib/python2.6/dist-packages/zope/testing/tests.py
/usr/lib/python2.6/dist-packages/zope/testing/doctest/__init__.py
/usr/lib/python2.6/dist-packages/zope/testing/renormalizing/__init__.py
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2-nspkg.pth
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2.egg-info/SOURCES.txt
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2.egg-info/namespace_packages.txt
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/zope.testing-3.10.2.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/zope/testing/__init__.py
/usr/lib/python2.7/dist-packages/zope/testing/cleanup.py
/usr/lib/python2.7/dist-packages/zope/testing/doctest.txt
/usr/lib/python2.7/dist-packages/zope/testing/doctestunit.py
/usr/lib/python2.7/dist-packages/zope/testing/exceptions.py
/usr/lib/python2.7/dist-packages/zope/testing/formparser.py
/usr/lib/python2.7/dist-packages/zope/testing/formparser.txt
/usr/lib/python2.7/dist-packages/zope/testing/loggingsupport.py
/usr/lib/python2.7/dist-packages/zope/testing/loghandler.py
/usr/lib/python2.7/dist-packages/zope/testing/module.py
/usr/lib/python2.7/dist-packages/zope/testing/module.txt
/usr/lib/python2.7/dist-packages/zope/testing/server.py
/usr/lib/python2.7/dist-packages/zope/testing/setupstack.py
/usr/lib/python2.7/dist-packages/zope/testing/setupstack.txt
/usr/lib/python2.7/dist-packages/zope/testing/tests.py
/usr/lib/python2.7/dist-packages/zope/testing/doctest/__init__.py
/usr/lib/python2.7/dist-packages/zope/testing/renormalizing/__init__.py
/usr/share/doc/python-zope.testing/README.txt
/usr/share/doc/python-zope.testing/changelog.Debian.gz
/usr/share/doc/python-zope.testing/changelog.gz
/usr/share/doc/python-zope.testing/copyright
/usr/share/pyshared/zope.testing-3.10.2-nspkg.pth
/usr/share/pyshared/zope.testing-3.10.2.egg-info/PKG-INFO
/usr/share/pyshared/zope.testing-3.10.2.egg-info/SOURCES.txt
/usr/share/pyshared/zope.testing-3.10.2.egg-info/dependency_links.txt
/usr/share/pyshared/zope.testing-3.10.2.egg-info/namespace_packages.txt
/usr/share/pyshared/zope.testing-3.10.2.egg-info/not-zip-safe
/usr/share/pyshared/zope.testing-3.10.2.egg-info/requires.txt
/usr/share/pyshared/zope.testing-3.10.2.egg-info/top_level.txt
/usr/share/pyshared/zope/testing/__init__.py
/usr/share/pyshared/zope/testing/cleanup.py
/usr/share/pyshared/zope/testing/doctest.txt
/usr/share/pyshared/zope/testing/doctestunit.py
/usr/share/pyshared/zope/testing/exceptions.py
/usr/share/pyshared/zope/testing/formparser.py
/usr/share/pyshared/zope/testing/formparser.txt
/usr/share/pyshared/zope/testing/loggingsupport.py
/usr/share/pyshared/zope/testing/loghandler.py
/usr/share/pyshared/zope/testing/module.py
/usr/share/pyshared/zope/testing/module.txt
/usr/share/pyshared/zope/testing/server.py
/usr/share/pyshared/zope/testing/setupstack.py
/usr/share/pyshared/zope/testing/setupstack.txt
/usr/share/pyshared/zope/testing/tests.py
/usr/share/pyshared/zope/testing/doctest/__init__.py
/usr/share/pyshared/zope/testing/renormalizing/__init__.py
/usr/share/python-zope.testing/test_helper
/usr/share/python/ns/python-zope.testing

Changelog

2011-05-18 - Arnaud Fontaine <arnau@debian.org>
zope.testing (3.10.2-1) unstable; urgency=low
* Team upload.
[ Arnaud Fontaine ]
* Switch to 3.0 (quilt) source format.
* debian/docs:
+ Add README.txt.
* debian/control:
+ Rename deprecated XS-Python-Version to X-Python-Version.
+ Add Vcs-Browser and Homepage fields.
+ Rename XS-Vcs-Svn to Vcs-Svn (dpkg supports it).
+ Bump Standards-Version to 3.9.2. No changes needed.
* debian/copyright:
+ Update to the last revision of DEP5 format.
[ Brian Sutherland ]
* New upstream version.
* Upload fixes dependency on python2.5 (Closes: #623922).
* Use dh_python2 instead of python-central (Closes: #617180).
* Add python-all to debian/tests/control as we test against all python
versions.
* Specifically depend on python-zope.testrunner, even though upstream
doesn't, to provide backwards compatibility.
2011-04-15 - Gediminas Paulauskas <menesis@pov.lt>
zope.testing (3.9.4-0ubuntu2) natty; urgency=low
* debian/rules: do not mess with scripts, install only
/usr/bin/zope-testrunner using default python.
* debian/test_helper: adapt to changed name of zope-testrunner, execute it
with different python interpreters instead.
* debian/tests/all: use our own test_helper.
2010-09-14 - Gediminas Paulauskas <menesis@pov.lt>
zope.testing (3.9.4-0ubuntu1) maverick; urgency=low
* New upstream release.
* debian/rules: Build-Depends on python-all, not its -dev variant.
* debian/copyright: update, convert to dep5 format.
2010-01-27 - Fabio Tranchitella <kobold@debian.org>
zope.testing (3.8.3-4) unstable; urgency=low
* Fix test path on python2.6.
2009-12-25 - Fabio Tranchitella <kobold@debian.org>
zope.testing (3.8.3-3) unstable; urgency=low
* Convert to debhelper 7 and the pydeb dh7 extension.
2009-11-08 - Fabio Tranchitella <kobold@debian.org>
zope.testing (3.8.3-2) unstable; urgency=low
* debian/control: build-depend on pyton-vab.pydeb >= 1.3.0-2.
(Closes: #552923)
2009-09-27 - Fabio Tranchitella <kobold@debian.org>
zope.testing (3.8.3-1) unstable; urgency=low
* New upstream release.
2009-09-21 - Matthias Klose <doko@ubuntu.com>
zope.testing (3.8.2-1) unstable; urgency=low
[ Matthias Klose ]
* New upstream version.
[ Brian Sutherland ]
* Set priority to optional as we are depended on by python-zodb which is
priority optional.
2009-09-12 - Matthias Klose <doko@ubuntu.com>
zope.testing (3.8.1-3) unstable; urgency=low
* Add a conflict with python-zodb (<< 2.9). LP: #422428.
2009-09-12 - Matthias Klose <doko@ubuntu.com>
zope.testing (3.8.1-2) unstable; urgency=low
* Set section to zope.
* Rebuild against van.pydeb 1.3.

See Also

Package Description
python-zope.testrunner_4.0.3-3_all.deb Flexible test runner with layer support for Python
python-zope.traversing_3.13.2-2_all.deb Resolving paths in the object hierarchy
python-zsi_2.1~a1-3_all.deb Zolera Soap Infrastructure
python2.6-dev_2.6.8-1.1_amd64.deb Header files and a static library for Python (v2.6)
python2.6-doc_2.6.8-1.1_all.deb Documentation for the high-level object-oriented language Python (v2.6)
python2.6-examples_2.6.8-1.1_all.deb Examples for the Python language (v2.6)
python2.6-minimal_2.6.8-1.1_amd64.deb Minimal subset of the Python language (version 2.6)
python2.6_2.6.8-1.1_amd64.deb Interactive high-level object-oriented language (version 2.6)
python2.7-dev_2.7.3-6+deb7u2_amd64.deb Header files and a static library for Python (v2.7)
python2.7-doc_2.7.3-6+deb7u2_all.deb Documentation for the high-level object-oriented language Python (v2.7)
python2.7-examples_2.7.3-6+deb7u2_all.deb Examples for the Python language (v2.7)
python2.7-minimal_2.7.3-6+deb7u2_amd64.deb Minimal subset of the Python language (version 2.7)
python2.7_2.7.3-6+deb7u2_amd64.deb Interactive high-level object-oriented language (version 2.7)
python3-all-dev_3.2.3-6_all.deb package depending on all supported Python 3 development packages
python3-all_3.2.3-6_all.deb package depending on all supported Python 3 runtime versions
Advertisement
Advertisement