python-xlwt_0.7.4+debian1-1_all.deb


Advertisement

Description

python-xlwt - module for writing Microsoft Excel spreadsheet files

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name python-xlwt
Package version 0.7.4+debian1
Package release 1
Package architecture all
Package type deb
Installed size 443 B
Download size 100.69 KB
Official Mirror ftp.br.debian.org
This package provides a pure Python module for writing spreadsheet files
readable by Excel 97/2000/XP/2003, OpenOffice.org Calc, and Gnumeric. Excel
spreadsheets can be generated on any platform without needing Excel or a COM
server.
Xlwt is a fork of the unmaintained pyExcelerator module with several
bugfixes and enhancements. For the functionality previously provided by the
parse_xls function, see the python-xlrd package.

Alternatives

Package Version Architecture Repository
python-xlwt_0.7.4+debian1-1_all.deb 0.7.4+debian1 all Debian Main
python-xlwt - - -

Requires

Name Value
python >= 2.6.6-7~
python << 2.8
python-antlr -
python2.6 -
python2.7 -

Download

Type URL
Binary Package python-xlwt_0.7.4+debian1-1_all.deb
Source Package xlwt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-xlwt deb package:
    # sudo apt-get install python-xlwt

Files

Path
/usr/lib/python2.6/dist-packages/xlwt-0.7.4.egg-info
/usr/lib/python2.6/dist-packages/xlwt/BIFFRecords.py
/usr/lib/python2.6/dist-packages/xlwt/Bitmap.py
/usr/lib/python2.6/dist-packages/xlwt/Cell.py
/usr/lib/python2.6/dist-packages/xlwt/Column.py
/usr/lib/python2.6/dist-packages/xlwt/CompoundDoc.py
/usr/lib/python2.6/dist-packages/xlwt/ExcelFormula.py
/usr/lib/python2.6/dist-packages/xlwt/ExcelFormulaLexer.py
/usr/lib/python2.6/dist-packages/xlwt/ExcelFormulaParser.py
/usr/lib/python2.6/dist-packages/xlwt/ExcelMagic.py
/usr/lib/python2.6/dist-packages/xlwt/Formatting.py
/usr/lib/python2.6/dist-packages/xlwt/Row.py
/usr/lib/python2.6/dist-packages/xlwt/Style.py
/usr/lib/python2.6/dist-packages/xlwt/UnicodeUtils.py
/usr/lib/python2.6/dist-packages/xlwt/Utils.py
/usr/lib/python2.6/dist-packages/xlwt/Workbook.py
/usr/lib/python2.6/dist-packages/xlwt/Worksheet.py
/usr/lib/python2.6/dist-packages/xlwt/__init__.py
/usr/lib/python2.6/dist-packages/xlwt/doc/xlwt.html
/usr/lib/python2.7/dist-packages/xlwt-0.7.4.egg-info
/usr/lib/python2.7/dist-packages/xlwt/BIFFRecords.py
/usr/lib/python2.7/dist-packages/xlwt/Bitmap.py
/usr/lib/python2.7/dist-packages/xlwt/Cell.py
/usr/lib/python2.7/dist-packages/xlwt/Column.py
/usr/lib/python2.7/dist-packages/xlwt/CompoundDoc.py
/usr/lib/python2.7/dist-packages/xlwt/ExcelFormula.py
/usr/lib/python2.7/dist-packages/xlwt/ExcelFormulaLexer.py
/usr/lib/python2.7/dist-packages/xlwt/ExcelFormulaParser.py
/usr/lib/python2.7/dist-packages/xlwt/ExcelMagic.py
/usr/lib/python2.7/dist-packages/xlwt/Formatting.py
/usr/lib/python2.7/dist-packages/xlwt/Row.py
/usr/lib/python2.7/dist-packages/xlwt/Style.py
/usr/lib/python2.7/dist-packages/xlwt/UnicodeUtils.py
/usr/lib/python2.7/dist-packages/xlwt/Utils.py
/usr/lib/python2.7/dist-packages/xlwt/Workbook.py
/usr/lib/python2.7/dist-packages/xlwt/Worksheet.py
/usr/lib/python2.7/dist-packages/xlwt/__init__.py
/usr/lib/python2.7/dist-packages/xlwt/doc/xlwt.html
/usr/share/doc-base/python-xlwt-api
/usr/share/doc-base/python-xlwt-intro
/usr/share/doc/python-xlwt/README.html
/usr/share/doc/python-xlwt/changelog.Debian.gz
/usr/share/doc/python-xlwt/changelog.gz
/usr/share/doc/python-xlwt/changelog.html.gz
/usr/share/doc/python-xlwt/copyright
/usr/share/doc/python-xlwt/xlwt.html
/usr/share/doc/python-xlwt/examples/big-16Mb.py
/usr/share/doc/python-xlwt/examples/big-35Mb.py
/usr/share/doc/python-xlwt/examples/blanks.py
/usr/share/doc/python-xlwt/examples/col_width.py
/usr/share/doc/python-xlwt/examples/country.py
/usr/share/doc/python-xlwt/examples/dates.py
/usr/share/doc/python-xlwt/examples/format.py
/usr/share/doc/python-xlwt/examples/formula_names.py
/usr/share/doc/python-xlwt/examples/formulas.py
/usr/share/doc/python-xlwt/examples/hyperlinks.py
/usr/share/doc/python-xlwt/examples/image.py
/usr/share/doc/python-xlwt/examples/merged.py
/usr/share/doc/python-xlwt/examples/merged0.py
/usr/share/doc/python-xlwt/examples/merged1.py
/usr/share/doc/python-xlwt/examples/mini.py
/usr/share/doc/python-xlwt/examples/num_formats.py
/usr/share/doc/python-xlwt/examples/outline.py
/usr/share/doc/python-xlwt/examples/panes.py
/usr/share/doc/python-xlwt/examples/parse-fmla.py
/usr/share/doc/python-xlwt/examples/protection.py
/usr/share/doc/python-xlwt/examples/python.bmp.gz
/usr/share/doc/python-xlwt/examples/row_styles.py
/usr/share/doc/python-xlwt/examples/row_styles_empty.py
/usr/share/doc/python-xlwt/examples/simple.py
/usr/share/doc/python-xlwt/examples/sst.py
/usr/share/doc/python-xlwt/examples/unicode0.py
/usr/share/doc/python-xlwt/examples/unicode1.py
/usr/share/doc/python-xlwt/examples/unicode2.py
/usr/share/doc/python-xlwt/examples/wsprops.py
/usr/share/doc/python-xlwt/examples/xlwt_easyxf_simple_demo.py
/usr/share/pyshared/xlwt-0.7.4.egg-info
/usr/share/pyshared/xlwt/BIFFRecords.py
/usr/share/pyshared/xlwt/Bitmap.py
/usr/share/pyshared/xlwt/Cell.py
/usr/share/pyshared/xlwt/Column.py
/usr/share/pyshared/xlwt/CompoundDoc.py
/usr/share/pyshared/xlwt/ExcelFormula.py
/usr/share/pyshared/xlwt/ExcelFormulaLexer.py
/usr/share/pyshared/xlwt/ExcelFormulaParser.py
/usr/share/pyshared/xlwt/ExcelMagic.py
/usr/share/pyshared/xlwt/Formatting.py
/usr/share/pyshared/xlwt/Row.py
/usr/share/pyshared/xlwt/Style.py
/usr/share/pyshared/xlwt/UnicodeUtils.py
/usr/share/pyshared/xlwt/Utils.py
/usr/share/pyshared/xlwt/Workbook.py
/usr/share/pyshared/xlwt/Worksheet.py
/usr/share/pyshared/xlwt/__init__.py
/usr/share/pyshared/xlwt/doc/xlwt.html

Changelog

2012-05-17 - Jan Dittberner <jandd@debian.org>
xlwt (0.7.4+debian1-1) unstable; urgency=low
* New upstream version.
* debian/control:
- bump Standards-Version to 3.9.3
- remove X-Python-Version
- add python-antlr to Build-Depends
* Fix "cannot read Excel spreadsheet files" (Closes: #644347)
- apply patch for long description clarifying the relationship to
python-excelerator and python-xlrd (thanks to Jonathan Nieder)
- add Suggests: python-xlrd
2011-03-03 - Jan Dittberner <jandd@debian.org>
xlwt (0.7.2+debian1-1) unstable; urgency=low
* Fix "unnecessary Depends", repacked source without antlr.py
(Closes: #614501)
* add debian/new-upstream script for repacking upstream source
* change debian/watch to execute debian/new-upstream when using uscan
* debian/rules:
- add --with python2 to dh invocation
- don't do repacking directly in get-orig-source rule
* debian/control:
- bump Standards-Version to 3.9.1 (no changes needed)
- change XS-Python-Version to X-Python-Version
- drop python-support dependency
- bump python dependency to 2.6.5-1~
- add Breaks: ${python:Breaks}
* change debian/source/format to "3.0 (quilt)"
* add debian/patches/fix_import_in_workbook.patch and
debian/patches/series to fix an import issue in xlwt/Worksheet.py
2010-02-03 - Jan Dittberner <jandd@debian.org>
xlwt (0.7.2-2) unstable; urgency=low
* switch to dh7
* debian/control:
- Build-Depends: require debhelper (>= 7.0.50)
- python-xlwt Depends: add ${misc:Depends}
- update Standards-Version to 3.8.4 (no changes needed)
* debian/rules:
- simplify rules using dh7 features
* debian/compat:
- 5 -> 7
* debian/copyright: explicitly link to GPL-2
* add debian/python-xlwt.doc-base.python-xlwt-api and
debian/python-xlwt.doc-base.python-xlwt-intro to register
/usr/share/doc/python- xlwt/*.html with doc-base
2009-07-24 - Jan Dittberner <jandd@debian.org>
xlwt (0.7.2-1) unstable; urgency=low
* new upstream version
* build for default Python version only
* debian/control:
- depend on python instead of python-all
- change email address
- update Standards-Version to 3.8.2 (no changes needed)
* debian/rules:
- use default python instead of building for all available versions
* debian/copyright:
- change email address
2009-03-27 - Jan Dittberner <jan@dittberner.info>
xlwt (0.7.1-1) unstable; urgency=low
* new upstream version
* debian/control:
- improved description thanks to upstream author John Machin
- update python-all-dev dependency to 2.4.5-1~
- update Standards-Version to 3.8.1 (no changes needed)
* debian/rules:
- add --no-compile --install-layout=deb to setup.py call
- use py_libdir from python.mk instead of hardcoded paths
2009-01-16 - Jan Dittberner <jan@dittberner.info>
xlwt (0.7.0-3) unstable; urgency=low
* debian/control: depend on separate python-antlr package instead of
antlr (available in antlr-2.7.7-10)
2009-01-07 - Jan Dittberner <jan@dittberner.info>
xlwt (0.7.0-2) unstable; urgency=low
* remove examples from module installation directory
2009-01-06 - Jan Dittberner <jan@dittberner.info>
xlwt (0.7.0-1) unstable; urgency=low
* Initial release. (Closes: #510763)
* debian/copyright:
- add permission by John McNamara (author of Perl::WriteExcel)
* remove antlr.py from upstream tarball and add dependency to antlr
package

See Also

Package Description
python-xmlmarshaller_0.9.7+svn39722-2_all.deb Converting Python objects to XML and back again
python-xmlrunner_1.2-1_all.deb Python test runner that produces machine-readable results
python-xmltv_1.3-1_all.deb allows Python applications to access XMLTV data
python-xmmsclient_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - Python bindings
python-xmpp_0.4.1-cvs20080505.2_all.deb Python library for communication with XMPP (Jabber) servers
python-xpyb_1.3.1-1_amd64.deb Python bindings to XCB
python-yahoo_3.1-1.1_all.deb Python module for the Yahoo Search Web Service
python-yaml_3.10-4+deb7u1_amd64.deb YAML parser and emitter for Python
python-yappy-doc_1.9.4-1_all.deb Documentation for yappy
python-yappy_1.9.4-1_all.deb Yet Another Parser Generator for Python
python-yenc_0.3+debian-2+b2_amd64.deb yEnc encoding/decoding extension for Python
python-yubico-tools_1.1.0-2_all.deb Tools for Yubico YubiKeys
python-yubico_1.1.0-2_all.deb Python code for talking to Yubico YubiKeys
python-zbar_0.10+doc-8_amd64.deb bar code scanner and decoder (Python bindings)
python-zbarpygtk_0.10+doc-8_amd64.deb bar code scanner and decoder (PyGTK bindings)
Advertisement
Advertisement