python-xappy_0.5-5_all.deb


Advertisement

Description

python-xappy - easy-to-use interface to the Xapian search engine

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name python-xappy
Package version 0.5
Package release 5
Package architecture all
Package type deb
Installed size 257 B
Download size 61.15 KB
Official Mirror ftp.br.debian.org
Xapian provides a low level interface, dealing with terms and
documents, but not really worrying about where terms come from, or how
to build searches to match the way in which data has been indexed.  In
contrast, Xappy allows you to design a field structure, specifying what
kind of information is held in particular fields, and then uses this
field structure to index data appropriately, and to build and perform
searches.

Alternatives

Package Version Architecture Repository
python-xappy_0.5-5_all.deb 0.5 all Debian Main
python-xappy - - -

Requires

Name Value
python >= 2.6.6-7~
python << 2.8
python-xapian -
python2.6 -
python2.7 -

Provides

Name Value
python2.6-xappy -
python2.7-xappy -

Download

Type URL
Binary Package python-xappy_0.5-5_all.deb
Source Package xappy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-xappy deb package:
    # sudo apt-get install python-xappy

Files

Path
/usr/lib/python2.6/dist-packages/xappy-0.5.egg-info
/usr/lib/python2.6/dist-packages/xappy/__init__.py
/usr/lib/python2.6/dist-packages/xappy/_checkxapian.py
/usr/lib/python2.6/dist-packages/xappy/datastructures.py
/usr/lib/python2.6/dist-packages/xappy/errors.py
/usr/lib/python2.6/dist-packages/xappy/fieldactions.py
/usr/lib/python2.6/dist-packages/xappy/fieldmappings.py
/usr/lib/python2.6/dist-packages/xappy/highlight.py
/usr/lib/python2.6/dist-packages/xappy/indexerconnection.py
/usr/lib/python2.6/dist-packages/xappy/marshall.py
/usr/lib/python2.6/dist-packages/xappy/memutils.py
/usr/lib/python2.6/dist-packages/xappy/parsedate.py
/usr/lib/python2.6/dist-packages/xappy/replaylog.py
/usr/lib/python2.6/dist-packages/xappy/schema.py
/usr/lib/python2.6/dist-packages/xappy/searchconnection.py
/usr/lib/python2.7/dist-packages/xappy-0.5.egg-info
/usr/lib/python2.7/dist-packages/xappy/__init__.py
/usr/lib/python2.7/dist-packages/xappy/_checkxapian.py
/usr/lib/python2.7/dist-packages/xappy/datastructures.py
/usr/lib/python2.7/dist-packages/xappy/errors.py
/usr/lib/python2.7/dist-packages/xappy/fieldactions.py
/usr/lib/python2.7/dist-packages/xappy/fieldmappings.py
/usr/lib/python2.7/dist-packages/xappy/highlight.py
/usr/lib/python2.7/dist-packages/xappy/indexerconnection.py
/usr/lib/python2.7/dist-packages/xappy/marshall.py
/usr/lib/python2.7/dist-packages/xappy/memutils.py
/usr/lib/python2.7/dist-packages/xappy/parsedate.py
/usr/lib/python2.7/dist-packages/xappy/replaylog.py
/usr/lib/python2.7/dist-packages/xappy/schema.py
/usr/lib/python2.7/dist-packages/xappy/searchconnection.py
/usr/share/doc/python-xappy/AUTHORS
/usr/share/doc/python-xappy/README
/usr/share/doc/python-xappy/buildinfo.gz
/usr/share/doc/python-xappy/changelog.Debian.gz
/usr/share/doc/python-xappy/changelog.gz
/usr/share/doc/python-xappy/copyright
/usr/share/pyshared/xappy-0.5.egg-info
/usr/share/pyshared/xappy/__init__.py
/usr/share/pyshared/xappy/_checkxapian.py
/usr/share/pyshared/xappy/datastructures.py
/usr/share/pyshared/xappy/errors.py
/usr/share/pyshared/xappy/fieldactions.py
/usr/share/pyshared/xappy/fieldmappings.py
/usr/share/pyshared/xappy/highlight.py
/usr/share/pyshared/xappy/indexerconnection.py
/usr/share/pyshared/xappy/marshall.py
/usr/share/pyshared/xappy/memutils.py
/usr/share/pyshared/xappy/parsedate.py
/usr/share/pyshared/xappy/replaylog.py
/usr/share/pyshared/xappy/schema.py
/usr/share/pyshared/xappy/searchconnection.py

Changelog

2012-03-12 - Jonas Smedegaard <dr@jones.dk>
xappy (0.5-5) unstable; urgency=low
* Use install helper python2 (not python-central).
* Bump debhelper compat level to 7.
* Bump standards-version to 3.9.3.
* Use anonscm.debian.org URL in Vcs-Browser field.
* Update copyright file: Rewrite using format 1.0.
* Update package relations:
+ Stop build-depending on python-central.
+ Tighten build-dependencies on cdbs and python: Needed for python2
install helper.
+ Relax build-depend unversioned on debhelper and devscripts (needed
versions satisfied even in oldstable).
2010-06-29 - Jonas Smedegaard <dr@jones.dk>
xappy (0.5-4) unstable; urgency=low
* Fix watch file, thanks to googlecode.debian.net redirector.
* Bump Policy compliance to Standards-Version 3.9.0.
* Avoid unneeded build-dependency on python-dev.
2010-05-07 - Jonas Smedegaard <dr@jones.dk>
xappy (0.5-3) unstable; urgency=low
* Use only official CDBS (drop local snippets) and drop locally
implemented DEB_MAINTAINER_MODE: All included upstream now.
* Refer to FSF website (not postal address) in licensing header of
rules file.
* Bump copyright years in header of in rules file.
* Rewrite copyright file using draft DEP5 rev. 135.
* Bump standards compliance to standards-version 3.8.4.
* Depend (not only build-depend) on python-xappy.
Closes: bug#580569, thanks to Frank Lin PIAT.
2010-01-23 - Jonas Smedegaard <dr@jones.dk>
xappy (0.5-2) unstable; urgency=low
* Improve watch file: Use list URL (not main page).
* Update local CDBS snippets:
+ Fix and improve package-relations.mk dependency cleanup.
+ Relax upstream-tarball.mk to depend unversioned on cdbs (the
needed 0.4.39 is in oldstable).
+ Let copyright-check.mk investigate top 99999 lines (not just 60 as
default for licensecheck).
+ Update upstream-tarball.mk to preserve bzip2 tarballs with source
format 3.0 (quilt).
+ Silence (GENERATED FILE) licensing notices in copyright-check.mk.
+ Group by owners (ignoring years) and sort owner list by years in
copyright-check.mk.
* Fix make the package architecture-independent, thanks to ftpmasters.
Build-depend on recent python-dev (and not on python-all-dev).
* Build-depend unversioned on cdbs.
* Fix include copyrights for testsuite/coverage.py (BSD-2),
docs/introduction.html (PD) and testdata/query_sourcewords.txt (GPL-
2+), thanks to ftpmasters.
2009-11-30 - Jonas Smedegaard <dr@jones.dk>
xappy (0.5-1) unstable; urgency=low
* Initial release. Closes: bug#558715.

See Also

Package Description
python-xattr_0.6.4-2_amd64.deb module for manipulating filesystem extended attributes
python-xcbgen_1.7.1-1_all.deb X C Binding - protocol binding generator
python-xdelta3_3.0.0.dfsg-1+deb7u1_amd64.deb Xdelta3 python module
python-xdg_0.19-5_all.deb Python library to access freedesktop.org standards
python-xenapi_1.3.2-15_all.deb Xen Cloud Platform - XenAPI Python libraries
python-xklavier_0.4-4_amd64.deb Python binding for libxklavier, an X Keyboard Extension API
python-xlib_0.14+20091101-1_all.deb Interface for Python to the X11 Protocol
python-xlrd_0.6.1-2_all.deb extract data from MS Excel spreadsheet files
python-xlwt_0.7.4+debian1-1_all.deb module for writing Microsoft Excel spreadsheet files
python-xmlmarshaller_0.9.7+svn39722-2_all.deb Converting Python objects to XML and back again
python-xmlrunner_1.2-1_all.deb Python test runner that produces machine-readable results
python-xmltv_1.3-1_all.deb allows Python applications to access XMLTV data
python-xmmsclient_0.8+dfsg-4+deb7u1_amd64.deb XMMS2 - Python bindings
python-xmpp_0.4.1-cvs20080505.2_all.deb Python library for communication with XMPP (Jabber) servers
python-xpyb_1.3.1-1_amd64.deb Python bindings to XCB
Advertisement
Advertisement