python-pkg-resources_0.6.24-1_all.deb


Advertisement

Description

python-pkg-resources - Package Discovery and Resource Access using pkg_resources

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name python-pkg-resources
Package version 0.6.24
Package release 1
Package architecture all
Package type deb
Installed size 183 B
Download size 62.12 KB
Official Mirror ftp.br.debian.org
The pkg_resources module provides an API for Python libraries to
access their resource files, and for extensible applications and
frameworks to automatically discover plugins.  It also provides
runtime support for using C extensions that are inside zipfile-format
eggs, support for merging packages that have separately-distributed
modules or subpackages, and APIs for managing Python's current
"working set" of active packages.

Alternatives

Package Version Architecture Repository
python-pkg-resources_0.6.24-1_all.deb 0.6.24 all Debian Main
python-pkg-resources - - -

Requires

Name Value
python >= 2.6
python << 2.8

Provides

Name Value
python2.6-setuptools -
python2.7-setuptools -

Conflicts

Name Value
python-setuptools << 0.6c8-3
python2.3-setuptools << 0.6b2
python2.4-setuptools << 0.6b2

Replaces

Name Value
python2.3-setuptools -
python2.4-setuptools -

Download

Type URL
Binary Package python-pkg-resources_0.6.24-1_all.deb
Source Package distribute

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pkg-resources deb package:
    # sudo apt-get install python-pkg-resources

Files

Path
/usr/lib/python2.6/dist-packages/pkg_resources.py
/usr/lib/python2.7/dist-packages/pkg_resources.py
/usr/share/doc/python-pkg-resources/README.Debian
/usr/share/doc/python-pkg-resources/changelog.Debian.gz
/usr/share/doc/python-pkg-resources/copyright
/usr/share/doc/python-pkg-resources/pkg_resources.txt.gz
/usr/share/pyshared/pkg_resources.py

Changelog

2011-10-22 - Matthias Klose <doko@debian.org>
distribute (0.6.24-1) unstable; urgency=low
* New upstream version. Closes: #632516.
2011-05-20 - Matthias Klose <doko@debian.org>
distribute (0.6.16-1) unstable; urgency=medium
* New upstream version.
* Support Python >=3.1.4 and >=3.2.1.
2011-04-18 - Matthias Klose <doko@debian.org>
distribute (0.6.15-2) unstable; urgency=low
* Stop building for python2.5 and python3.1.
2011-03-21 - Matthias Klose <doko@debian.org>
distribute (0.6.15-1) unstable; urgency=low
* New upstream version.
2010-10-14 - Matthias Klose <doko@debian.org>
distribute (0.6.14-5) experimental; urgency=low
* Build for python 2.7 and 3.2.
2010-10-06 - Matthias Klose <doko@debian.org>
distribute (0.6.14-4) unstable; urgency=low
* Upload to unstable.
2010-09-12 - Matthias Klose <doko@debian.org>
distribute (0.6.14-3) experimental; urgency=low
* Tighten build dependency on python3, remove b-d on python-central.
2010-07-17 - Matthias Klose <doko@debian.org>
distribute (0.6.14-1) unstable; urgency=low
* New upstream version.
2010-03-18 - Matthias Klose <doko@debian.org>
distribute (0.6.10-4) unstable; urgency=low
* Don't include 3.1 related files in the filelists of python-* packages.
Closes: #574153.

See Also

Package Description
python-plastex-doc_0.9.2-1_all.deb LaTeX document processing framework in Python - documentation files
python-plastex_0.9.2-1_all.deb LaTeX document processing framework in Python
python-playerc_3.0.2+dfsg-4+b1_amd64.deb Networked server for robots and sensors - Python wrapper
python-plist_1.8-1_amd64.deb Library for handling Apple binary and XML property lists
python-plplot-qt_5.9.9-5_amd64.deb Scientific plotting library (python qt GUI)
python-plplot_5.9.9-5_amd64.deb Python support for PLplot, a plotting library
python-plwm_2.6a+20080530-1.1_all.deb Pointless Window Manager - Python libraries for creating Window Managers
python-ply-doc_3.4-3_all.deb Lex and Yacc implementation for Python (documentation)
python-ply_3.4-3_all.deb Lex and Yacc implementation for Python2
python-pmw-doc_1.3.2-6_all.deb Pmw -- Python MegaWidgets
python-pmw_1.3.2-6_all.deb Pmw -- Python MegaWidgets
python-polib-doc_1.0.0-2_all.deb Python library to parse and manage gettext catalogs (documentation)
python-polib_1.0.0-2_all.deb Python library to parse and manage gettext catalogs
python-polybori_0.5~rc1-2.2_amd64.deb Polynomials over Boolean Rings, Python module
python-popcon_1.1_all.deb Python interface to Debian's Popularity Contest (popcon)
Advertisement
Advertisement