python-pgm_0.3.12-2+b4_amd64.deb


Advertisement

Description

python-pgm - User interfaces with embedded multimedia - Python bindings

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name python-pgm
Package version 0.3.12
Package release 2+b4
Package architecture amd64
Package type deb
Installed size 563 B
Download size 196.76 KB
Official Mirror ftp.br.debian.org
Pigment allows building of user interfaces with embedded multimedia
components.  It is designed with portability in mind and its plugin
system will select a particular underlying graphical API on each
platform.
This package contains the Python bindings.

Alternatives

Package Version Architecture Repository
python-pgm_0.3.12-2+b4_i386.deb 0.3.12 i386 Debian Main
python-pgm - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.2.5
libcairo2 >= 1.2.4
libfontconfig1 >= 2.8.0
libfreetype6 >= 2.2.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.24.0
libgstreamer-plugins-base0.10-0 >= 0.10.0
libgstreamer0.10-0 >= 0.10.0
libgtk2.0-0 >= 2.8.0
libpango1.0-0 >= 1.14.0
libpigment0.3-11 -
libxml2 >= 2.6.27
python << 2.8
python >= 2.7
python-cairo -
python-central >= 0.6.11
python-gobject -
python-gst0.10 -
python-gtk2 -
python-imaging -
python-twisted-core -

Provides

Name Value
python2.7-pgm -

Conflicts

Name Value
python-pigment -

Replaces

Name Value
python-pigment -

Download

Type URL
Binary Package python-pgm_0.3.12-2+b4_amd64.deb
Source Package pigment-python

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-pgm deb package:
    # sudo apt-get install python-pgm

Files

Path
/usr/lib/python2.7/dist-packages/_pgmgtkmodule.so
/usr/lib/python2.7/dist-packages/_pgmimagingmodule.so
/usr/lib/python2.7/dist-packages/_pgmmodule.so
/usr/share/doc/python-pgm/AUTHORS
/usr/share/doc/python-pgm/NEWS.gz
/usr/share/doc/python-pgm/README
/usr/share/doc/python-pgm/TODO
/usr/share/doc/python-pgm/changelog.Debian.gz
/usr/share/doc/python-pgm/changelog.gz
/usr/share/doc/python-pgm/copyright
/usr/share/doc/python-pgm/examples/cloning.py
/usr/share/doc/python-pgm/examples/groups.py
/usr/share/doc/python-pgm/examples/image.py
/usr/share/doc/python-pgm/examples/implicit.py
/usr/share/doc/python-pgm/examples/layout.py
/usr/share/doc/python-pgm/examples/mappingmatrix.py
/usr/share/doc/python-pgm/examples/pgmgtk.py
/usr/share/doc/python-pgm/examples/sphere.py
/usr/share/doc/python-pgm/examples/text.py
/usr/share/doc/python-pgm/examples/timing.py
/usr/share/doc/python-pgm/examples/video.py
/usr/share/doc/python-pgm/examples/webcam.py
/usr/share/doc/python-pgm/examples/wrapping.py
/usr/share/doc/python-pgm/examples/pictures/fluendo.png
/usr/share/doc/python-pgm/examples/pictures/line-pattern.png
/usr/share/doc/python-pgm/examples/pictures/meiko.jpg
/usr/share/pyshared-data/python-pgm
/usr/share/pyshared/pgm/__init__.py
/usr/share/pyshared/pgm/keysyms.py
/usr/share/pyshared/pgm/graph/__init__.py
/usr/share/pyshared/pgm/graph/drawable.py
/usr/share/pyshared/pgm/graph/group.py
/usr/share/pyshared/pgm/graph/image.py
/usr/share/pyshared/pgm/graph/text.py
/usr/share/pyshared/pgm/timing/__init__.py
/usr/share/pyshared/pgm/timing/controller.py
/usr/share/pyshared/pgm/timing/implicit.py
/usr/share/pyshared/pgm/timing/keyframe.py
/usr/share/pyshared/pgm/timing/modifier.py
/usr/share/pyshared/pgm/timing/ticker.py
/usr/share/pyshared/pgm/utils/__init__.py
/usr/share/pyshared/pgm/utils/benchmark.py
/usr/share/pyshared/pgm/utils/classinit.py
/usr/share/pyshared/pgm/utils/image.py
/usr/share/pyshared/pgm/utils/maths.py
/usr/share/pyshared/pgm/widgets/__init__.py
/usr/share/pyshared/pgm/widgets/button.py
/usr/share/pyshared/pgm/widgets/circular_list_ng.py
/usr/share/pyshared/pgm/widgets/console.py
/usr/share/pyshared/pgm/widgets/const.py
/usr/share/pyshared/pgm/widgets/grid_ng.py
/usr/share/pyshared/pgm/widgets/list_ng.py
/usr/share/pyshared/pgm/widgets/scrollbar.py
/usr/share/pyshared/pgm/widgets/sliced_image.py

Changelog

2009-11-03 - Paul van Tilburg <paulvt@debian.org>
pigment-python (0.3.12-2) unstable; urgency=low
[ Loïc Minier ]
* Drop Philippe Normand from Uploaders at his request.
[ Paul van Tilburg ]
* debian/python-pgm.install:
- Prepare for site- to dist-packages transition.  Patch courtesy of
Julien Laverne <julien.laverne@gmail.com> (Closes: #530948).
* debian/control: bumped the standards version to 3.8.3;
no changes required. 
2009-05-20 - Paul van Tilburg <paulvt@debian.org>
pigment-python (0.3.12-1) unstable; urgency=low
* New upstream release.
* Bumped the build-depend on libpigment0.3-dev to >= 0.3.17.
2009-04-06 - Paul van Tilburg <paulvt@debian.org>
pigment-python (0.3.11-2) unstable; urgency=low
* Bumped the build-depend on libgpiment0.3-dev to >= 0.3.16-2 
due to the SONAME mistake(/mismatch) in 0.3.16-1.
2009-04-06 - Paul van Tilburg <paulvt@debian.org>
pigment-python (0.3.11-1) unstable; urgency=low
* New upstream release. 
* Bumped the build-depend on libpigment0.3-dev to >= 0.3.16. 
2009-03-19 - Paul van Tilburg <paulvt@debian.org>
pigment-python (0.3.10-2) unstable; urgency=low
* Upload to unstable.
* Build against pigment 0.3.15.
* Bumped standards-version to 3.8.1; no changes required. 
2009-02-14 - Paul van Tilburg <paulvt@debian.org>
pigment-python (0.3.10-1) experimental; urgency=low
* New upstream release:
- Bump libpigment0.3-dev build-depend to >= 0.3.14.
* debian/rules: 
- Make sure examples are not compressed (closes: #497615).
2009-02-01 - Paul van Tilburg <paulvt@debian.org>
pigment-python (0.3.9-1) experimental; urgency=low
[ Loic Minier ]
* Stop install *.la files.
[ Paul van Tilburg ]
* New upstream release:
- Bump libpigment0.3-dev build-depend to >= 0.3.13.
* debian/control:
- Added myself to the uploaders.
2008-09-15 - Loic Minier <lool@dooz.org>
pigment-python (0.3.6-1) experimental; urgency=low
* New upstream release.
- Bump libpigment0.3-dev bdep to >= 0.3.8.
2008-07-22 - Loic Minier <lool@dooz.org>
pigment-python (0.3.5-1) experimental; urgency=low
[ Loic Minier ]
* Bump libpigment0.3-dev bdep to >= 0.3.6.
[ Philippe Normand ]
* New upstream release
- Bump libpigment0.3-dev bdep to >= 0.3.7.
[ Loic Minier ]
* Target experimental for now as the changes are too large for lenny.
2008-07-18 - Arnaud Quette <aquette@debian.org>
pigment-python (0.3.4-1) unstable; urgency=low
* New upstream release
* debian/control:
- bump Standards-Version to 3.8.0
- add the Homepage field

See Also

Package Description
python-pgmagick_0.5.1-1+b1_amd64.deb Yet Another Python wrapper for GraphicsMagick
python-phoneutils_0.1+git20100219-1+b1_amd64.deb python bindings for libphone-utils
python-pika_0.9.5-1_all.deb AMQP client library
python-pip_1.1-3_all.deb alternative Python package installer
python-pipeline_0.1.3-3_all.deb iterator pipelines for Python
python-pisa_3.0.32-1_all.deb PDF generator using HTML and CSS (Python module)
python-pisock_0.12.5-5_amd64.deb Python module to communicate with PalmOS PDA
python-pivy_0.5.0~v609hg-1_amd64.deb Coin binding for Python
python-pkg-resources_0.6.24-1_all.deb Package Discovery and Resource Access using pkg_resources
python-plastex-doc_0.9.2-1_all.deb LaTeX document processing framework in Python - documentation files
python-plastex_0.9.2-1_all.deb LaTeX document processing framework in Python
python-playerc_3.0.2+dfsg-4+b1_amd64.deb Networked server for robots and sensors - Python wrapper
python-plist_1.8-1_amd64.deb Library for handling Apple binary and XML property lists
python-plplot-qt_5.9.9-5_amd64.deb Scientific plotting library (python qt GUI)
python-plplot_5.9.9-5_amd64.deb Python support for PLplot, a plotting library
Advertisement
Advertisement