python-pexpect_2.4-1_all.deb


Advertisement

Description

python-pexpect - Python module for automating interactive applications

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: python-pexpect
Package version: 2.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 303 B
Download size: 120.26 KB
Official Mirror: ftp.br.debian.org
Pexpect is a pure Python module for spawning child applications; controlling them; and responding to expected patterns in their output. Pexpect works like Don Libes' Expect. Pexpect allows your script to spawn a child application and control it as if a human were typing commands.

Alternatives

    Download

    Source package: pexpect

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pexpect deb package:
      # sudo apt-get install python-pexpect

    Files

    • /usr/lib/python2.6/dist-packages/ANSI.py
    • /usr/lib/python2.6/dist-packages/FSM.py
    • /usr/lib/python2.6/dist-packages/fdpexpect.py
    • /usr/lib/python2.6/dist-packages/pexpect-2.4.egg-info
    • /usr/lib/python2.6/dist-packages/pexpect.py
    • /usr/lib/python2.6/dist-packages/pxssh.py
    • /usr/lib/python2.6/dist-packages/screen.py
    • /usr/lib/python2.7/dist-packages/ANSI.py
    • /usr/lib/python2.7/dist-packages/FSM.py
    • /usr/lib/python2.7/dist-packages/fdpexpect.py
    • /usr/lib/python2.7/dist-packages/pexpect-2.4.egg-info
    • /usr/lib/python2.7/dist-packages/pexpect.py
    • /usr/lib/python2.7/dist-packages/pxssh.py
    • /usr/lib/python2.7/dist-packages/screen.py
    • /usr/share/doc-base/pexpect
    • /usr/share/doc/python-pexpect/README
    • /usr/share/doc/python-pexpect/changelog.Debian.gz
    • /usr/share/doc/python-pexpect/copyright
    • /usr/share/doc/python-pexpect/doc/clean.css
    • /usr/share/doc/python-pexpect/doc/email.png
    • /usr/share/doc/python-pexpect/doc/examples.html
    • /usr/share/doc/python-pexpect/doc/index.html
    • /usr/share/doc/python-pexpect/doc/index.template.html
    • /usr/share/doc/python-pexpect/examples/README
    • /usr/share/doc/python-pexpect/examples/astat.py
    • /usr/share/doc/python-pexpect/examples/bd_client.py
    • /usr/share/doc/python-pexpect/examples/bd_serv.py.gz
    • /usr/share/doc/python-pexpect/examples/cgishell.cgi.gz
    • /usr/share/doc/python-pexpect/examples/chess.py
    • /usr/share/doc/python-pexpect/examples/chess2.py
    • /usr/share/doc/python-pexpect/examples/chess3.py
    • /usr/share/doc/python-pexpect/examples/df.py
    • /usr/share/doc/python-pexpect/examples/fix_cvs_files.py
    • /usr/share/doc/python-pexpect/examples/ftp.py
    • /usr/share/doc/python-pexpect/examples/hive.py.gz
    • /usr/share/doc/python-pexpect/examples/monitor.py.gz
    • /usr/share/doc/python-pexpect/examples/passmass.py
    • /usr/share/doc/python-pexpect/examples/python.py
    • /usr/share/doc/python-pexpect/examples/rippy.py.gz
    • /usr/share/doc/python-pexpect/examples/script.py
    • /usr/share/doc/python-pexpect/examples/ssh_session.py
    • /usr/share/doc/python-pexpect/examples/ssh_tunnel.py
    • /usr/share/doc/python-pexpect/examples/sshls.py
    • /usr/share/doc/python-pexpect/examples/table_test.html
    • /usr/share/doc/python-pexpect/examples/topip.py.gz
    • /usr/share/doc/python-pexpect/examples/uptime.py
    • /usr/share/pyshared/ANSI.py
    • /usr/share/pyshared/FSM.py
    • /usr/share/pyshared/fdpexpect.py
    • /usr/share/pyshared/pexpect-2.4.egg-info
    • /usr/share/pyshared/pexpect.py
    • /usr/share/pyshared/pxssh.py
    • /usr/share/pyshared/screen.py

    Changelog

    2012-03-09 - Arthur de Jong <adejong@debian.org> pexpect (2.4-1) unstable; urgency=low * Team upload. [ Arthur de Jong ] * New upstream release (Closes: #609195). * Switch to 3.0 (quilt) source format. * Switch to dh-style debian/rules. * Moved packaging from python-central to dh_python2 (Closes: #616935, LP: #788514). * Drop Conflicts/Replaces on ancient versions which shipped in sarge. * Bump standards-version to 3.9.3. * Register documentation with doc-base. * Update debian/copyright (license is actually MIT instead of Python 2.3). * Fix syntax errors in one of the examples (closes: #580271) [ Piotr O┼╝arowski ] * Added Vcs-Svn and Vcs-Browser fields [ Sandro Tosi ] * debian/control - uniforming Vcs-Browser field * debian/control - switch Vcs-Browser field to viewsvn [ Carlos Galisteo ] * debian/control - Added Homepage field.

    2008-07-27 - Ganesan Rajagopal <rganesan@debian.org> pexpect (2.3-1) unstable; urgency=low * New upstream release. * Fix lintian warnings: - Move debhelper to Build-Depends from Build-Depends-Indep. - Remove DH_COMPAT in debian/rules. - Added debian/pycompat. - Added #! line for examples/ssh_session.py. * Updated standards version.

    2008-07-18 - Matthias Klose <doko@debian.org> pexpect (2.1-1.1) unstable; urgency=low * NMU. Rebuild to move files to /usr/share/pyshared. Closes: #490482.

    2006-06-20 - Ganesan Rajagopal <rganesan@debian.org> pexpect (2.1-1) unstable; urgency=low * New upstream version. * Included pxssh.py and fdpxpect.py (Closes: #356128). * Included docs and examples (Closes: #230850). * Updated for new python policy using python-central (Closes: #373476). * Added watch file.

    2006-04-15 - Ganesan Rajagopal <rganesan@debian.org> pexpect (2.0-2) unstable; urgency=low * Included pexpect package into Python Modules repository. * Add python-modules-team@lists.alioth.debian.org to Uploaders. * Remove python2.2-pexpect package.

    2005-12-28 - Ganesan Rajagopal <rganesan@debian.org> pexpect (2.0-1) unstable; urgency=low * New upstream release. * Fixed *.docs to take README instead of README.txt. * Updated standards version.

    2005-02-19 - Ganesan Rajagopal <rganesan@debian.org> pexpect (0.999-5) unstable; urgency=low * Aargh. Install python2.4 binaries in the right place. * Added python2.4 to Build-depends.

    2005-01-09 - Ganesan Rajagopal <rganesan@debian.org> pexpect (0.999-4) unstable; urgency=low * Really build pexpect for python 2.4.

    2005-01-09 - Ganesan Rajagopal <rganesan@debian.org> pexpect (0.999-3) unstable; urgency=low * Build python 2.4 package. * python-pexpect now depends on ${python:Depends}.

    2004-07-09 - Ganesan Rajagopal <rganesan@debian.org> pexpect (0.999-2) unstable; urgency=low * Build-depend on python (Closes: #258299).

    Advertisement
    Advertisement