python-gi_3.2.2-2_amd64.deb


Advertisement

Description

python-gi - Python 2.x bindings for gobject-introspection libraries

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name python-gi
Package version 3.2.2
Package release 2
Package architecture amd64
Package type deb
Installed size 1.24 KB
Download size 505.60 KB
Official Mirror ftp.br.debian.org
GObject is an abstraction layer that allows programming with an object
paradigm that is compatible with many languages. It is a part of Glib,
the core library used to build GTK+ and GNOME.
This package contains the Python 2.x binding generator for libraries that
support gobject-introspection, i. e. which ship a gir1.2-<name>-<version>
package. With these packages, the libraries can be used from Python.

Alternatives

Package Version Architecture Repository
python-gi_3.2.2-2_i386.deb 3.2.2 i386 Debian Main
python-gi - - -

Requires

Name Value
gir1.2-glib-2.0 >= 1.31.0
libc6 >= 2.2.5
libffi5 >= 3.0.4
libgirepository-1.0-1 >= 1.29.0
libglib2.0-0 >= 2.31.8
python >= 2.6.6-7~
python << 2.8

Provides

Name Value
python2.6-gi -
python2.7-gi -

Replaces

Name Value
python-gobject << 3.0.2-4

Download

Type URL
Binary Package python-gi_3.2.2-2_amd64.deb
Source Package pygobject

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gi deb package:
    # sudo apt-get install python-gi

Files

Path
/usr/lib/libpyglib-gi-2.0-python2.6.so
/usr/lib/libpyglib-gi-2.0-python2.6.so.0
/usr/lib/libpyglib-gi-2.0-python2.6.so.0.0.0
/usr/lib/libpyglib-gi-2.0-python2.7.so
/usr/lib/libpyglib-gi-2.0-python2.7.so.0
/usr/lib/libpyglib-gi-2.0-python2.7.so.0.0.0
/usr/lib/pyshared/python2.6/gi/_gi.so
/usr/lib/pyshared/python2.6/gi/_glib/_glib.so
/usr/lib/pyshared/python2.6/gi/_gobject/_gobject.so
/usr/lib/pyshared/python2.7/gi/_gi.so
/usr/lib/pyshared/python2.7/gi/_glib/_glib.so
/usr/lib/pyshared/python2.7/gi/_gobject/_gobject.so
/usr/lib/python2.6/dist-packages/gi/__init__.py
/usr/lib/python2.6/dist-packages/gi/_gi.so
/usr/lib/python2.6/dist-packages/gi/importer.py
/usr/lib/python2.6/dist-packages/gi/module.py
/usr/lib/python2.6/dist-packages/gi/pygtkcompat.py
/usr/lib/python2.6/dist-packages/gi/types.py
/usr/lib/python2.6/dist-packages/gi/_glib/__init__.py
/usr/lib/python2.6/dist-packages/gi/_glib/_glib.so
/usr/lib/python2.6/dist-packages/gi/_glib/option.py
/usr/lib/python2.6/dist-packages/gi/_gobject/__init__.py
/usr/lib/python2.6/dist-packages/gi/_gobject/_gobject.so
/usr/lib/python2.6/dist-packages/gi/_gobject/constants.py
/usr/lib/python2.6/dist-packages/gi/_gobject/propertyhelper.py
/usr/lib/python2.6/dist-packages/gi/overrides/GIMarshallingTests.py
/usr/lib/python2.6/dist-packages/gi/overrides/GLib.py
/usr/lib/python2.6/dist-packages/gi/overrides/Gdk.py
/usr/lib/python2.6/dist-packages/gi/overrides/Gio.py
/usr/lib/python2.6/dist-packages/gi/overrides/Gtk.py
/usr/lib/python2.6/dist-packages/gi/overrides/Pango.py
/usr/lib/python2.6/dist-packages/gi/overrides/__init__.py
/usr/lib/python2.6/dist-packages/gi/overrides/keysyms.py
/usr/lib/python2.6/dist-packages/gi/repository/__init__.py
/usr/lib/python2.7/dist-packages/gi/__init__.py
/usr/lib/python2.7/dist-packages/gi/_gi.so
/usr/lib/python2.7/dist-packages/gi/importer.py
/usr/lib/python2.7/dist-packages/gi/module.py
/usr/lib/python2.7/dist-packages/gi/pygtkcompat.py
/usr/lib/python2.7/dist-packages/gi/types.py
/usr/lib/python2.7/dist-packages/gi/_glib/__init__.py
/usr/lib/python2.7/dist-packages/gi/_glib/_glib.so
/usr/lib/python2.7/dist-packages/gi/_glib/option.py
/usr/lib/python2.7/dist-packages/gi/_gobject/__init__.py
/usr/lib/python2.7/dist-packages/gi/_gobject/_gobject.so
/usr/lib/python2.7/dist-packages/gi/_gobject/constants.py
/usr/lib/python2.7/dist-packages/gi/_gobject/propertyhelper.py
/usr/lib/python2.7/dist-packages/gi/overrides/GIMarshallingTests.py
/usr/lib/python2.7/dist-packages/gi/overrides/GLib.py
/usr/lib/python2.7/dist-packages/gi/overrides/Gdk.py
/usr/lib/python2.7/dist-packages/gi/overrides/Gio.py
/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py
/usr/lib/python2.7/dist-packages/gi/overrides/Pango.py
/usr/lib/python2.7/dist-packages/gi/overrides/__init__.py
/usr/lib/python2.7/dist-packages/gi/overrides/keysyms.py
/usr/lib/python2.7/dist-packages/gi/repository/__init__.py
/usr/share/doc/python-gi/AUTHORS
/usr/share/doc/python-gi/NEWS.gz
/usr/share/doc/python-gi/README
/usr/share/doc/python-gi/changelog.Debian.gz
/usr/share/doc/python-gi/changelog.gz
/usr/share/doc/python-gi/copyright
/usr/share/pyshared/gi/__init__.py
/usr/share/pyshared/gi/importer.py
/usr/share/pyshared/gi/module.py
/usr/share/pyshared/gi/pygtkcompat.py
/usr/share/pyshared/gi/types.py
/usr/share/pyshared/gi/_glib/__init__.py
/usr/share/pyshared/gi/_glib/option.py
/usr/share/pyshared/gi/_gobject/__init__.py
/usr/share/pyshared/gi/_gobject/constants.py
/usr/share/pyshared/gi/_gobject/propertyhelper.py
/usr/share/pyshared/gi/overrides/GIMarshallingTests.py
/usr/share/pyshared/gi/overrides/GLib.py
/usr/share/pyshared/gi/overrides/Gdk.py
/usr/share/pyshared/gi/overrides/Gio.py
/usr/share/pyshared/gi/overrides/Gtk.py
/usr/share/pyshared/gi/overrides/Pango.py
/usr/share/pyshared/gi/overrides/__init__.py
/usr/share/pyshared/gi/overrides/keysyms.py
/usr/share/pyshared/gi/repository/__init__.py

Changelog

2013-02-21 - Michael Biebl <biebl@debian.org>
pygobject (3.2.2-2) unstable; urgency=low
[ Josselin Mouette ]
* Enable again gtk3 on m68k.
* Add missing dependency python3-gi-cairo → python3-gi.
Closes: #673213.
[ Michael Biebl ]
* Stop using a doc symlink for the dbg package. The space savings are
negligible and they are prone to cause problems. In case of
python-gobject-dbg, which was converted to a transitional package, the
symlink was mistakenly converted to a real directory which isn't handled
nicely by dpkg. Closes: #700779
* Move transitional packages into section oldlibs with priority extra.
2012-05-15 - Martin Pitt <mpitt@debian.org>
pygobject (3.2.2-1) unstable; urgency=low
* New upstream bug fix release.
2012-05-10 - Martin Pitt <mpitt@debian.org>
pygobject (3.2.1-1) unstable; urgency=low
* New upstream bug fix release.
- GTK overrides: Add missing keyword arguments (Closes: #667057)
2012-04-10 - Martin Pitt <mpitt@debian.org>
pygobject (3.2.0-3) unstable; urgency=low
* debian/control.in, debian/rules: Build a python3-gi-cairo package, now
that py3cairo is packaged in Debian. (LP: #879405)
2012-04-02 - Martin Pitt <mpitt@debian.org>
pygobject (3.2.0-2) unstable; urgency=low
* Upload to unstable.
* debian/watch: Switch back to only watching for stable versions.
* debian/control.in: Set Vcs-* back to unstable branch.
* debian/copyright: Move to copyright 1.0 format.
* debian/control.in: Bump Standards-Version to 3.9.3.
2012-03-26 - Martin Pitt <mpitt@debian.org>
pygobject (3.2.0-1) experimental; urgency=low
* New upstream bug fix release, to fix two regressions in 3.1.92.
2012-03-19 - Martin Pitt <mpitt@debian.org>
pygobject (3.1.92-1) experimental; urgency=low
* New upstream release.
- Fix Gtk override API for tree models to send out only one signal after
the data is set. (LP: #939450)
2012-03-13 - Martin Pitt <mpitt@debian.org>
pygobject (3.1.1-1) experimental; urgency=low
* New upstream bug fix release.
* debian/control.in: Bump libglib2.0-dev build dependency as per
configure.ac.
* Drop 00git_gtkbuilder-signals.patch, 00git_pygspawn_error_check.patch:
Included upstream.
* Drop glib_2.30.patch: Not necessary any more, we have a recent enough
glib in experimental now.
* debian/control.in: Have python-gi-dev depend on python-gi, not
the transitional python-gobject.
* debian/watch: Watch for odd-numbered minor versions as well, as we are
using these for GNOME 3.2.
* debian/control.in: Update Vcs-* for experimental branch.
2012-02-09 - Martin Pitt <mpitt@debian.org>
pygobject (3.1.0-2) unstable; urgency=low
* Add glib_2.30.patch: Partially revert commit ee62df4 to drop the usage of
g_value_*_schar. This was introduced in glib 2.31 only. (Closes: #659184)
* Add 00git_pygspawn_error_check.patch: Fix crash in pygspawn() when the
argv or envp arguments are not proper sequences. Backported from upstream
git head.
* Add 00git_gtkbuilder-signals.patch: Fix GtkBuilder signal connection
'after' logic. Backported from upstream git head. (LP: #925676)
2012-02-08 - Martin Pitt <mpitt@debian.org>
pygobject (3.1.0-1) unstable; urgency=low
* New upstream release. No new features or code reorg, just a lot of crash
and introspectability fixes, and well covered by test cases. This works
fine with GNOME 3.2.
* Drop all patches, all upstream now.

See Also

Package Description
python-git_0.3.2~RC1-1_all.deb Python library to interact with Git repositories
python-gitdb_0.5.4-1_amd64.deb pure-Python git object database
python-glade2_2.24.0-3+b1_amd64.deb GTK+ bindings: Glade support
python-glance-doc_2012.1.1-5_all.deb OpenStack Image Service - Python library documentation
python-glance_2012.1.1-5_all.deb OpenStack Image Service - Python client library
python-glitch_0.6-2.1_all.deb Python library for OpenGL graphics programming
python-glpk_0.4.45-1+b1_amd64.deb Python bindings to the GNU Linear Programming Kit
python-gluon_1.99.7-1_all.deb High-level Python web development framework
python-gmenu_3.0.1-4_amd64.deb GNOME implementation of the freedesktop menu specification
python-gmpy_1.15-1_amd64.deb interfaces GMP to Python for fast, unbound-precision computations
python-gnatpython-doc_54-3_all.deb Python framework to ease development of test suites (examples)
python-gnatpython_54-3_amd64.deb Python framework to ease development of test suites
python-gnome2-desktop-dev_2.32.0+dfsg-2_all.deb Python bindings for the GNOME desktop environment
python-gnome2-dev_2.28.1+dfsg-1_all.deb Python bindings for the GNOME desktop environment - development files
python-gnome2-doc_2.28.1+dfsg-1_all.deb Python bindings for the GNOME desktop environment
Advertisement
Advertisement