planner_0.14.6-1_amd64.deb


Advertisement

Description

planner - project management application

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name planner
Package version 0.14.6
Package release 1
Package architecture amd64
Package type deb
Installed size 1.12 KB
Download size 478.98 KB
Official Mirror ftp.br.debian.org
Planner is a Project Management application that supports Gantt charts,
resource allocation and integration with other GNOME applications.
Planner was formerly known as Mr.Project.

Alternatives

Package Version Architecture Repository
planner_0.14.6-1_i386.deb 0.14.6 i386 Debian Main
planner - - -

Requires

Name Value
gconf-service -
gconf2 >= 2.28.1-2
libart-2.0-2 >= 2.3.18
libatk1.0-0 >= 1.12.4
libc6 >= 2.7
libcairo2 >= 1.2.4
libgconf-2-4 >= 2.31.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglade2-0 >= 1:2.6.1
libglib2.0-0 >= 2.24.0
libgnomecanvas2-0 >= 2.11.1
libgtk2.0-0 >= 2.14.0
libpango1.0-0 >= 1.14.0
libpython2.7 >= 2.7
libxml2 >= 2.7.4
libxslt1.1 >= 1.1.25
planner-data = 0.14.6-1
python >= 2.7
python << 2.8
python2.7 -
scrollkeeper -
shared-mime-info -

Download

Type URL
Binary Package planner_0.14.6-1_amd64.deb
Source Package planner

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install planner deb package:
    # sudo apt-get install planner

Files

Path
/usr/bin/planner
/usr/lib/planner/libplanner-1.so.0
/usr/lib/planner/libplanner-1.so.0.0.0
/usr/lib/planner/file-modules/libmrp-xml.so
/usr/lib/planner/file-modules/libmrp-xsl.so
/usr/lib/planner/plugins/libhtml-plugin.so
/usr/lib/planner/plugins/libmsp-plugin.so
/usr/lib/planner/plugins/libpython-plugin.so
/usr/lib/planner/plugins/libxmlplanner-plugin.so
/usr/lib/planner/storage-modules/libstorage-mrproject-1.so
/usr/lib/pyshared/python2.7/planner.so
/usr/lib/pyshared/python2.7/plannerui.so
/usr/lib/python2.7/dist-packages/planner.so
/usr/lib/python2.7/dist-packages/plannerui.so
/usr/share/doc/planner/NEWS.gz
/usr/share/doc/planner/changelog.Debian.gz
/usr/share/doc/planner/changelog.gz
/usr/share/doc/planner/copyright
/usr/share/gconf/schemas/planner.schemas
/usr/share/man/man1/planner.1.gz
/usr/share/menu/planner
/usr/share/pixmaps/gnome-planner.xpm

Changelog

2012-03-08 - Dmitry Smirnov <onlyjob@member.fsf.org>
planner (0.14.6-1) unstable; urgency=medium
* New upstream release
* added patch for --as-needed issue, thanks to Julian Taylor
(Closes: #656795 "FTBFS with ld --as-needed")
* debian/control:
+ corrected planner version in Breaks/Replaces
(Closes: #657419 "fails to upgrade from squeeze...")
+ recalculated planner-dev Depends
- removed ${shlibs:Depends} and ${python:Depends} from -dev Depends
+ standards to 3.9.3
* debian/rules:
+ parallel build by default on linux
+ added --as-needed to LDFLAGS
* debian/copyright:
+ updated DEP-5 format URL
+ added myself as conbtributor
* dependant_typo patch is updated
2011-07-23 - Wences Arana <aranax@debian.org.gt>
planner (0.14.5-1) unstable; urgency=low
* New upstream release (Closes: #635483)
+ Fixes FTBFS -format not a string literal and no format arguments-
(Closes: #643458)
* New maintainers, thanks to Xavier Oswald for his previous work.
(Closes: #632993)
* debian/rules
+ The package is using debhelper 8 now
+ Use gtk-doc to build documentation
+ "--with autoreconf" added (Closes: #558617)
* debian/control
- cdbs removed from Build-Depends
- libgnomevfs2-dev removed from Build-Depends because it is not needed
anymore (Thanks to Didier Roche for the tip).
- dpkg-dev removed from Build-Depends, because it is not needed
anymore, since Etch (to have a binNMU safe package).
+ debhelper added to Build-Depends
+ Standards-Version updated to 3.9.2 (no changes needed)
+ Private library/plugins excluded in the call to dh_makeshlibs
+ Minor improvements to the description of planner and planner-dev
+ Package split into planner, planner-data and planner-doc (plus the
previous binary package planner-dev)
+ VCS fields added
+ Added X-Python-Version field (and rebuild with python 2.7 as the
python default) (Closes: #644679)
+ libgtk2.0-dev's version updated to >= 2.14.0 in Build-Depends (see the
upstream's README)
* Use dh_python2 instead of python-support
- debian/pyversions and debian/pycompat dropped
- debian/rules python-support removed from Build-Depends and from
Depends of the -dev package
- debian/control python-dev version bumped to 2.6.6-3~
* debian-changes-0.14.4-3 dropped because it was created due to the
presence of the auto-generated file config.status.lineno
* dependant_typo.diff patch added in order to fix a typo
* debian/copyright
+ The file was rewritten in order to use DEP-5.
+ The copyright multiple files was added.
+ The FSF address was updated (bug known upstream as #664112)
* libplanner-1.so* files moved to /usr/lib/planner/ in order to comply
with the Debian Debian Policy 10.2 which states that not public
libraries should be installed in subdirectories of /usr/lib
+ debian/rules --libdir parameter added to the call to dh_auto_configure.
+ plugins_directory.diff patch added in order to keep the *-modules and
plugins directories in the right place (due to the use of "--libdir").
+ debian/control dh-autoreconf added to the Build-Depends field.
* Lintian override for package-name-doesnt-match-sonames dropped
- debian/planner.dirs dropped because this was here in order to install
the override
* AUTHORS and README files dropped because the information is already
available in the package.
* command_line_args.diff patch added in order to make planner able to
read files from command line again.
[Dmitry Smirnov] <onlyjob@member.fsf.org>
* including examples (*.planner files)
* debian/control
- removed unused build-dep: autotools-dev
+ tighter build-deps on python-gtk2-dev (>= 2.24)
+ tighter build-deps on intltool (>= 0.41.1-3) due to bug #560704
* debian/rules to use dpkg-provided build flags

See Also

Package Description
plasma-containments-addons_4.8.4-1+b2_amd64.deb additional containment plugins for Plasma
plasma-dataengines-addons_4.8.4-1+b2_amd64.deb additional data engines for Plasma
plasma-dataengines-workspace_4.8.4-6_amd64.deb KDE Plasma data engines
plasma-dataengines-yawp_0.4.2-1_amd64.deb yaWP's data engines (Ions) for different weather services
plasma-desktop_4.8.4-6_amd64.deb KDE Plasma workspace for desktop and laptop computers
plasma-desktopthemes-artwork_4.8.4-5_all.deb desktop themes for KDE Plasma Workspaces
plasma-netbook_4.8.4-6_amd64.deb KDE Plasma workspace for netbook computers
plasma-runner-installer_1.3.0-2_amd64.deb KRunner plugin for installing packages
plasma-runners-addons_4.8.4-1+b2_amd64.deb additional runners for Plasma and Krunner
plasma-scriptengine-javascript_4.8.4-2_amd64.deb JavaScript script engine for Plasma
plasma-scriptengine-python_4.8.4-6_all.deb Python script engine for Plasma
plasma-scriptengine-ruby_4.8.4-6_all.deb Ruby script engine for Plasma
plasma-scriptengine-superkaramba_4.8.4-3_amd64.deb SuperKaramba theme support for the Plasma Workspaces
plasma-scriptengine-webkit_4.8.4-6_amd64.deb Web and Mac OS X dashboard widget support for Plasma
plasma-scriptengines_4.8.4-6_all.deb metapackage to install all Plasma script engines
Advertisement
Advertisement