pinentry-qt4_0.8.1-1_amd64.deb


Advertisement

Description

pinentry-qt4 - Qt-4-based PIN or pass-phrase entry dialog for GnuPG

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: pinentry-qt4
Package version: 0.8.1
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 208 B
Download size: 97.49 KB
Official Mirror: ftp.br.debian.org
This package contains a program that allows for entry of PINs or pass phrases. It is useful for entering pass phrases when using encryption software such as GnuPG or e-mail clients using the same. It uses an open protocol and is therefore not tied to particular software. The program contained in this package implements a PIN entry dialog using the Qt tool kit version 4, so it is especially suitable for users of KDE 4. If the X Window System is not active then an alternative text-mode dialog will be used. There are sibling packages that implement PIN entry dialogs using other tool kits.

Alternatives

Provides

  • pinentry
  • pinentry-qt
  • pinentry-x11

    Download

    Source package: pinentry

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pinentry-qt4 deb package:
      # sudo apt-get install pinentry-qt4

    Files

    • /usr/bin/pinentry-qt4
    • /usr/share/doc/pinentry-qt4/AUTHORS
    • /usr/share/doc/pinentry-qt4/NEWS.gz
    • /usr/share/doc/pinentry-qt4/README.Debian
    • /usr/share/doc/pinentry-qt4/changelog.Debian.gz
    • /usr/share/doc/pinentry-qt4/changelog.gz
    • /usr/share/doc/pinentry-qt4/copyright
    • /usr/share/man/man1/pinentry-qt4.1.gz

    Changelog

    2011-02-16 - Peter Eisentraut <petere@debian.org> pinentry (0.8.1-1) unstable; urgency=low * New upstream release - keyboard-race.patch incorporated upstream - Fixed segmentation fault in pinentry-gtk2 (closes: #584947) * Removed Qt 3 variant (closes: #604369) * Updated standards version * Changed to debhelper level 8

    2010-03-18 - Peter Eisentraut <petere@debian.org> pinentry (0.8.0-1) unstable; urgency=low * New upstream release * Changed source format to 3.0 (quilt) * Updated standards version

    2009-07-13 - Peter Eisentraut <petere@debian.org> pinentry (0.7.6-1) unstable; urgency=low * New upstream release - Includes Qt 4 variant, formerly in separate source package pinentry-qt4 - Obsoletes gmalloc-prototypes.patch - Made Gtk+-2 pinentry transient to the root window (closes: #445607) * Changed copyright file to refer to GPL-2 file, per lintian * Updated standards version * Changed to debhelper level 7 and minimal version 7.2.17, to avoid obsolete calls to install-info

    2009-02-10 - Peter Eisentraut <petere@debian.org> pinentry (0.7.5-3) unstable; urgency=low * Converted patches to quilt * Updated standards version * Dropped pinentry-gtk package (closes: #510740)

    2008-10-20 - Pierre Habouzit <madcoder@debian.org> pinentry (0.7.5-2.1) unstable; urgency=low * Non-maintainer upload. * gtk+-2/pinentry-gtk-2.c: apply patch to avoid keyboard grab race on SMP systems (closes: #401957).

    2008-04-29 - Peter Eisentraut <petere@debian.org> pinentry (0.7.5-2) unstable; urgency=high * gtk+-2/gtksecentry.c: Adjusted the g_*malloc*() overrides to have the same prototype as glib, to fix FTBFS (closes: #471613) * debian/control: Added Build-Depends on libglib2.0-dev (>= 2.15.5) to make sure we don't run into the old prototypes of g_*malloc*()

    2008-02-17 - Peter Eisentraut <petere@debian.org> pinentry (0.7.5-1) unstable; urgency=low * New upstream release

    2007-12-21 - Peter Eisentraut <petere@debian.org> pinentry (0.7.4-2) unstable; urgency=low * debian/copyright: converted to UTF-8 (closes: #455738) * Changed section of pinentry-doc to doc * debian/watch: force passive FTP, since ftp.gnupg.org seems unhappy with active (closes: #456468)

    2007-12-10 - Peter Eisentraut <petere@debian.org> pinentry (0.7.4-1) unstable; urgency=low * New upstream release * Added Homepage control field * Updated standards version * Added configure option --without-libcap to get consistent builds

    2007-07-17 - Peter Eisentraut <petere@debian.org> pinentry (0.7.3-1) unstable; urgency=low * New upstream release - Fixes segfault after confirm in pinentry-curses (closes: #311410) * Updated standards version * Changed to Debhelper level 5 * Cleaned up build rules

    Advertisement
    Advertisement