php5-adodb_5.04-7+b1_amd64.deb


Advertisement

Description

php5-adodb - Extension optimising the ADOdb database abstraction library

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name php5-adodb
Package version 5.04
Package release 7+b1
Package architecture amd64
Package type deb
Installed size 22 B
Download size 10.72 KB
Official Mirror ftp.br.debian.org
It provides up to 100% speedup on some drivers by replacing parts of ADOdb
with C code.  Some of the drivers taking advantage of the extension are:
* mysql
* oci8
* postgres7
ADOdb will auto-detect if this extension is installed and use it automatically.

Alternatives

Package Version Architecture Repository
php5-adodb_5.04-7+b1_i386.deb 5.04 i386 Debian Main
php5-adodb - - -

Requires

Name Value
libc6 >= 2.4
phpapi-20100525 -

Download

Type URL
Binary Package php5-adodb_5.04-7+b1_amd64.deb
Source Package php-adodb

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php5-adodb deb package:
    # sudo apt-get install php5-adodb

Files

Path
/etc/php5/conf.d/adodb.ini
/usr/lib/php5/20100525/adodb.so
/usr/share/doc/php5-adodb/CREDITS
/usr/share/doc/php5-adodb/README.txt
/usr/share/doc/php5-adodb/changelog.Debian.gz
/usr/share/doc/php5-adodb/copyright
/usr/share/lintian/overrides/php5-adodb

Changelog

2012-01-24 - Raphael Geissert <geissert@debian.org>
php-adodb (5.04-7) unstable; urgency=low
* Bump standards version, no change needed
* Include the full BSD licence text
* Add support for the 5.4 API
* Switch to source format 3.0 quilt
* Drop all quilt-related stuff
2010-03-14 - Raphael Geissert <geissert@debian.org>
php-adodb (5.04-6) unstable; urgency=low
* Use quilt as patch system
* Add support for the 5.3 API (Closes: #569414)
* Fix the URL to the AdoDB download page
2010-01-29 - Raphael Geissert <geissert@debian.org>
php-adodb (5.04-5) unstable; urgency=low
* Drop DM-UA field
* Update my email address
* Update standards version to 3.8.4, no changes needed
* Drop ORed dependency on php5 (Closes: #566298)
* Build with some hardening flags
* Bump copyright year
2009-03-28 - Raphael Geissert <atomo64@gmail.com>
php-adodb (5.04-4) unstable; urgency=low
* debian/rules: rewritten, now using cdbs
* debian/copyright: updated and clarified the package's licence
* debian/control:
+ build-depend on cdbs
+ bump versioned dependency on debhelper and cdbs, for dh_lintian
+ improved the package description
+ make the dependency on phpapi ORed, with the first possibility being php5
+ bump standards version, no change needed
+ change the VCS URLs, bye bye svn, hello git
+ section is now 'php' due to recent changes in the archive
* debian/lintian-overrides, override:
+ spelling-error-in-description mysql MySQL
- It is a reference to the driver name, not the product
2008-01-04 - Raphael Geissert <atomo64@gmail.com>
php-adodb (5.04-3) unstable; urgency=low
* debian/control: Added XS-DM-Upload-Allowed: yes
* Fixed a debian-changelog-line-too-long lintian false positive
2008-01-04 - Raphael Geissert <atomo64@gmail.com>
php-adodb (5.04-2) unstable; urgency=low
* Added debian/watch file
* Updated maintainer field (now maintained by the Debian PHP Maintainers)
* Added Homepage and Vcs-* fields
* Bumped Standards-Version: 3.7.3, no change needed
2007-05-03 - Raphael Geissert <atomo64@gmail.com>
php-adodb (5.04-1) unstable; urgency=low
* Initial release (Closes: #422159)

See Also

Package Description
php5-cgi_5.4.45-0+deb7u2_amd64.deb server-side, HTML-embedded scripting language (CGI binary)
php5-cli_5.4.45-0+deb7u2_amd64.deb command-line interpreter for the php5 scripting language
php5-common_5.4.45-0+deb7u2_amd64.deb Common files for packages built from the php5 source
php5-curl_5.4.45-0+deb7u2_amd64.deb CURL module for php5
php5-dev_5.4.45-0+deb7u2_amd64.deb Files for PHP5 module development
php5-enchant_5.4.45-0+deb7u2_amd64.deb Enchant module for php5
php5-exactimage_0.8.5-5+deb7u4_amd64.deb fast image manipulation library (PHP bindings)
php5-ffmpeg_0.6.0-2.2_amd64.deb audio and video support via ffmpeg for php5
php5-fpm_5.4.45-0+deb7u2_amd64.deb server-side, HTML-embedded scripting language (FPM-CGI binary)
php5-gd_5.4.45-0+deb7u2_amd64.deb GD module for php5
php5-gdcm_2.2.0-14.1_amd64.deb Grassroots DICOM PHP5 bindings
php5-geoip_1.0.7-8_amd64.deb GeoIP module for php5
php5-gmp_5.4.45-0+deb7u2_amd64.deb GMP module for php5
php5-imagick_3.1.0~rc1-1+b2_amd64.deb ImageMagick module for php5
php5-imap_5.4.45-0+deb7u2_amd64.deb IMAP module for php5
Advertisement
Advertisement