php-crypt-cbc_1.0.1-1_all.deb


Advertisement

Description

php-crypt-cbc - PEAR class to emulate Perl's Crypt::CBC module

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name php-crypt-cbc
Package version 1.0.1
Package release 1
Package architecture all
Package type deb
Installed size 51 B
Download size 6.97 KB
Official Mirror ftp.br.debian.org
This package provides an implementation of a class to emulate Perl's
Crypt::CBC module. This is particularly important when you want to deal with
any SRS compatible domain name registration API like the one of Tucows and
others, that are using CBC as a mean of encrypted data transport.

Alternatives

Package Version Architecture Repository
php-crypt-cbc_1.0.1-1_all.deb 1.0.1 all Debian Main
php-crypt-cbc - - -

Requires

Name Value
php-pear -

Download

Type URL
Binary Package php-crypt-cbc_1.0.1-1_all.deb
Source Package php-crypt-cbc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-crypt-cbc deb package:
    # sudo apt-get install php-crypt-cbc

Files

Path
/usr/share/doc/php-crypt-cbc/changelog.Debian.gz
/usr/share/doc/php-crypt-cbc/changelog.gz
/usr/share/doc/php-crypt-cbc/copyright
/usr/share/doc/php-crypt-cbc/package.xml
/usr/share/php/.registry/crypt_cbc.reg
/usr/share/php/Crypt/CBC.php

Changelog

2012-01-27 - Thomas Goirand <zigo@debian.org>
php-crypt-cbc (1.0.1-1) unstable; urgency=low
* New upstream release, with a new BSD license.
* Now using the PKG PHP team as maintainer (me as uploader).
* Section is now php.
* Added a debian/gbp.conf.
* Switched to source format 3.0 (quilt).
* Switched to pkg-php-tools and dh 8 auto-sequencer.
* Standards-Version: is now 3.9.2 (no changes).
* Switched debian/copyright to DEP5.
* Edited short description.
* Using PKG-PHP-PEAR team <pkg-php-pear@lists.alioth.debian.org> as
maintainer.
* Fixed the lintian overwrite thing.
* Removes the LICENSE file from packaging.
2010-07-27 - Thomas Goirand <zigo@debian.org>
php-crypt-cbc (1.0.0.1-1) unstable; urgency=low
* Uploading a new 1.0.0.1 as the orig.tar.gz for 1.0.0 was wrong, and even
making the build of the package fail (Closes: #590395).
* Corrected Vcs-Browser to the correct URL.
* Added a debian/source/format.
* Bumped Standard-Version.
2009-12-26 - Thomas Goirand <zigo@debian.org>
php-crypt-cbc (1.0.0-1) unstable; urgency=low
* New upstream release.
* Bumped Standard-Version.
* Updated long description.
* Cleaned debian/rules of arch-specific targets.
* Moved php-pear from Build-Depends: to Build-Depends-Indep:.
* Added a lintian override for the PHP 2.x license, as Crypt_CBC is part of
PHP, so it's fine to use that license.
* Added a ${misc:Depends} dependency.
* debian/compat level is now 7.
2007-08-05 - Thomas Goirand <thomas@goirand.fr>
php-crypt-cbc (0.4-3) unstable; urgency=low
* Not using CDBS anymore (rewrote debian/rules).
* Now packaging the pear .reg file so pear install continues to work.
* The watch file works now.
* The debian/copyright is now consistent.
2007-05-18 - Thomas Goirand <thomas@goirand.fr>
php-crypt-cbc (0.4-2) unstable; urgency=low
* Removed php4 dependency as php4 will soon be removed (Closes: #424815)
2006-12-15 - Thomas Goirand <thomas@goirand.fr>
php-crypt-cbc (0.4-1) unstable; urgency=low
* Initial release (Closes: #403447)

See Also

Package Description
php-date_1.4.7-1_all.deb PHP PEAR module for date and time manipulation
php-db_1.7.14-2_all.deb PHP PEAR Database Abstraction Layer
php-doc_20100521-2_all.deb Documentation for PHP5
php-elisp_1.5.0-1.1_all.deb Emacs support for php files
php-event-dispatcher_1.1.0-3_all.deb Dispatch notifications using PHP callbacks
php-file-iterator_1.3.1-2_all.deb FilterIterator implementation for PHP
php-file_1.3.0-1_all.deb PHP Pear modules for common file and directory routines
php-fpdf_1.7.dfsg-1_all.deb PHP class to generate PDF files
php-geshi_1.0.8.4-2_all.deb Generic Syntax Highlighter
php-getid3_1.9.3-1+deb7u2_all.deb PHP script to extract informations from multimedia files
php-gettext_1.0.11-1_all.deb read gettext MO files directly, without requiring anything other than PHP
php-html-common_1.2.5-2_all.deb base class for other HTML classes
php-html-safe_0.10.1-1_all.deb strip down all potentially dangerous content within HTML
php-html-template-it_1.2.1-3_all.deb PEAR HTML Isotemplate API
php-htmlpurifier_4.4.0+dfsg1-1_all.deb Standards-compliant HTML filter
Advertisement
Advertisement