pgadmin3_1.14.2-2_amd64.deb


Advertisement

Description

pgadmin3 - graphical administration tool for PostgreSQL

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: pgadmin3
Package version: 1.14.2
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 7.05 KB
Download size: 2.25 MB
Official Mirror: ftp.br.debian.org
pgAdmin III is a database design and management application for use with PostgreSQL. The application can be used to manage PostgreSQL 7.3 and above running on any platform. pgAdmin III is designed to answer the needs of all users, from writing simple SQL queries to developing complex databases. The graphical interface supports all PostgreSQL features and makes administration easy. The application also includes a syntax highlighting SQL editor, a server-side code editor, an SQL/batch/shell job scheduling agent, support for the Slony-I replication engine and much more. Server connection may be made using TCP/IP or Unix Domain Sockets (on *nix platforms), and may be SSL encrypted for security. No additional drivers are required to communicate with the database server.

Alternatives

    Download

    Source package: pgadmin3

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pgadmin3 deb package:
      # sudo apt-get install pgadmin3

    Files

    • /usr/bin/pgadmin3
    • /usr/bin/png2c
    • /usr/share/applications/pgadmin3.desktop
    • /usr/share/doc/pgadmin3
    • /usr/share/man/man1/pgadmin3.1.gz
    • /usr/share/menu/pgadmin3
    • /usr/share/pixmaps/pgadmin3.svg
    • /usr/share/pixmaps/pgadmin3.xpm

    Changelog

    2012-06-11 - Gerfried Fuchs <rhonda@debian.org> pgadmin3 (1.14.2-2) unstable; urgency=low * Using --enable-debug and B-D on libwxgtk2.8-dbg was the wrong approach, reverting that. This makes it work again (closes: #676626) * Using -g2 for CFLAGS to make the debug symbols really appear in the -dbg package (closes: #676538)

    2012-05-29 - Gerfried Fuchs <rhonda@debian.org> pgadmin3 (1.14.2-1) unstable; urgency=low * New upstream release which includes the ftbfs fix, thus removing the patch. * Bump Standards-Version to 3.9.3. * configure with --enable-debug, Build-Depends on libwxgtk2.8-dbg (closes: #652099)

    2011-12-08 - Gerfried Fuchs <rhonda@debian.org> pgadmin3 (1.14.0-2) unstable; urgency=low * Pull 41ed1ae from upstream to fix FTBFS (closes: #646454) * Create a pgadmin3-dbg package (closes: #647916) * Also install png2c, and the ini files below /usr/share/pgadmin3.

    2011-09-11 - Gerfried Fuchs <rhonda@debian.org> pgadmin3 (1.14.0-1) unstable; urgency=low * New upstream release. * Removed quilt Build-Depends again and drop the patch that got incorporated upstream. * Add recommended targets build-arch and build-indep to debian/rules.

    2011-06-07 - Gerfried Fuchs <rhonda@debian.org> pgadmin3 (1.14.0~beta1-1) experimental; urgency=low * New upstream development release, adding Build-Depends on postgresql-server-dev-all >= 117~. * Add Build-Depends on quilt, (un)patch to debian/rules and patch for fixing the include for kwlist.h in pgadmin/db/keywords.c. * Add pg_config --includedir-server output to CPPFLAGS. * Remove unrecognized configure options: --with-wx-config, --with-pgsql-include, --enable-gtk2, --enable-unicode. * Clean up manually the files that are left behind after the broken distclean.

    2011-04-17 - Gerfried Fuchs <rhonda@debian.org> pgadmin3 (1.12.3-1) unstable; urgency=low * New upstream release. * Bump to Standards-Version 3.9.2.

    2011-04-05 - Gerfried Fuchs <rhonda@debian.org> pgadmin3 (1.12.2-2) unstable; urgency=low * Upload to unstable.

    2010-12-19 - Gerfried Fuchs <rhonda@debian.at> pgadmin3 (1.12.2-1) experimental; urgency=low * New upstream release.

    2010-10-27 - Gerfried Fuchs <rhonda@debian.at> pgadmin3 (1.12.1-1) experimental; urgency=low * New upstream release. * Removed BSD file reference from copyright file, the whole text is in there anyway.

    2010-09-22 - Gerfried Fuchs <rhonda@debian.at> pgadmin3 (1.12.0-1) experimental; urgency=low * New upstream release candidate, containing fixes for: - won't use IPv6-only server (closes: #576342, LP: #374656) - All files should be "*", not "*." (closes: #594593) * Fixed watchfile to not consider -rc versions higher than non-rc versions (thanks to Michael Fladischer)

    Advertisement
    Advertisement