perlprimer_1.1.21-1_all.deb


Advertisement

Description

perlprimer - Graphical design of primers for PCR

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: perlprimer
Package version: 1.1.21
Package release: 1
Package architecture: all
Package type: deb
Installed size: 488 B
Download size: 114.23 KB
Official Mirror: ftp.br.debian.org
PerlPrimer is a free, open-source GUI application written in Perl that designs primers for standard Polymerase Chain Reaction (PCR), bisulphite PCR, real-time PCR (QPCR) and sequencing. It aims to automate and simplify the process of primer design. If operated online, the tool nicely communicates with the Ensembl project for further insights into the gene structure, i.e., allowing for taking the location of exons and introns into account for the design of the primers. The sequences themselves can be retrieved, too.

Alternatives

Requires

    Download

    Source package: perlprimer

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install perlprimer deb package:
      # sudo apt-get install perlprimer

    Files

    • /usr/bin/perlprimer
    • /usr/lib/mime/packages/perlprimer
    • /usr/share/applications/perlprimer.desktop
    • /usr/share/doc/perlprimer/README.Debian
    • /usr/share/doc/perlprimer/ReadMe.gz
    • /usr/share/doc/perlprimer/changelog.Debian.gz
    • /usr/share/doc/perlprimer/changelog.gz
    • /usr/share/doc/perlprimer/copyright
    • /usr/share/doc/perlprimer/reference
    • /usr/share/doc/perlprimer/todo
    • /usr/share/man/man1/perlprimer.1.gz
    • /usr/share/menu/perlprimer
    • /usr/share/mime/packages/perlprimer.xml
    • /usr/share/perlprimer/gcg.603
    • /usr/share/pixmaps/perlprimer.xpm

    Changelog

    2011-11-25 - Charles Plessy <plessy@debian.org> perlprimer (1.1.21-1) unstable; urgency=low [0b963e8] New upstream release restoring Ensembl compatibility. [b212da5] Removed 10-perlprimer.diff, applied upstream, and whole patch system [ec6fcdf] Corrected VCS-Git URL in debian/control. [fa968ca] Mark the use of git-buildpackage by adding its configuration file. [ab18a22] Complies with Policy 3.9.2 (no changes needed). [bdb7ebb] Corrected and normalised Debian copyright file with config-edit.

    2011-02-27 - Charles Plessy <plessy@debian.org> perlprimer (1.1.20-1) unstable; urgency=low * New upstream release: - Ensembl compatibility restored again, - Error corrected in calculation of melting temperature. * Source package maintained with Git (debian/control). * Switch to format 3.0 (quilt) to use pristine upstream bzipped archive. * Incremented Standards-Version to 3.9.1 indicate conformance with the latest Policy (debian/control, no changes needed). * debian/copyright updated and reformatted to DEP-5 format. * Using Debhelper 8 (debian/control, debian/compat). * Added instructions and data for testing (test.ppr, README.test).

    2010-03-21 - Charles Plessy <plessy@debian.org> perlprimer (1.1.19-1) unstable; urgency=low * New upstream release: Ensembl compatibility restored again. * Incremented Standards-Version to 3.8.4 indicate conformance with the latest Policy (debian/control, no changes needed). * Corrected description of debian/patches/10-perlprimer.diff to comply with the DEP-3 standard. * Corrected debian/README.source (this package uses quilt, not dpatch).

    2009-10-12 - Charles Plessy <plessy@debian.org> perlprimer (1.1.18-1) unstable; urgency=low * New upstream release: - Ensembl compatibility once again restored. - Many new Ensembl genome species added. * Incremented Standards-Version to 3.8.3 to indicate conformance with the latest Policy (debian/control, no changes needed). * Added various informations in debian/upstream-metadata.yaml * Refreshed debian/copyright.

    2009-03-25 - Charles Plessy <plessy@debian.org> perlprimer (1.1.17-1) unstable; urgency=low * New upstream release: Ensembl compatibility restored for genomic sequence downloads. * debian/control: - incremented Standards-Version to 3.8.1 to indicate conformance with the latest Policy (no changes needed). - perlprimer-doc depends on dephelper's ${misc:Depends}. * debian/copyright: - Updated to the latest version of the machine-readable format. - Incremented years. - Point at the version 2 of the GPL.

    2008-12-20 - Charles Plessy <plessy@debian.org> perlprimer (1.1.16-1) unstable; urgency=low * New upstream release restoring URL compatibility with Ensembl. * debian/co{mpat,ntrol}: using Debhelper 7. * debian/reference: BibTeX reference. * debian/README.source, debian/control: added explanations about patch system, to comply with Policy 3.8.0. * debian/copyright: - updated Upstream's copyright years. - updated to latest version of the machine-readable format.

    2008-05-17 - Charles Plessy <plessy@debian.org> perlprimer (1.1.14-3) unstable; urgency=low * Changed the doc-base section according to the new policy. * Updated my email address. * Switched the packaging to cdbs. * Submitted debian/patches/10-perlprimer.diff upstream and documented this in its header.

    Advertisement
    Advertisement