paw_2.14.04.dfsg.2-8_amd64.deb


Advertisement

Description

paw - Physics Analysis Workstation - a graphical analysis program

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: paw
Package version: 2.14.04.dfsg.2
Package release: 8
Package architecture: amd64
Package type: deb
Installed size: 4.71 KB
Download size: 2.10 MB
Official Mirror: ftp.br.debian.org
CERNLIB is a suite of data analysis tools and libraries created for use in physics experiments, but also with applications to other fields such as the biological sciences. PAW is an interactive program providing interactive graphical presentation and statistical and mathematical analysis tools. It is designed to work on objects familiar to physicists such as histograms, event files (Ntuples), vectors, etc. The program is linked statically against the CERN libraries on 64-bit architectures in order to function properly, as its design is not very 64-bit clean.

Alternatives

Provides

  • paw-binary

Replaces

  • paw-common << 2005.05.09.dfsg-3

    Download

    Source package: paw

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install paw deb package:
      # sudo apt-get install paw

    Files

    • /usr/bin/pawX11
    • /usr/share/doc/paw/README.Debian
    • /usr/share/doc/paw/changelog.Debian.gz
    • /usr/share/doc/paw/copyright
    • /usr/share/lintian/overrides/paw
    • /usr/share/man/man1/pawX11.1.gz
    • /usr/share/menu/paw

    Changelog

    2012-02-18 - Ralf Treinen <treinen@debian.org> paw (1:2.14.04.dfsg.2-8) unstable; urgency=low * Team upload * debian/rules: set locale to C before including CERN makefile snippet (closes: #660246) * rename debian/debhelper to debian/dh, as indicated by maintainer. (closes: #640572)

    2011-03-28 - Lifeng Sun <lifongsun@gmail.com> paw (1:2.14.04.dfsg.2-7) unstable; urgency=low * New maintainer. Thanks Kevin B. McCarty for contributing to the HEP free software community over the years. (Closes: #619393) * Bump Standards-Version to 3.9.1 - debian/copyright: specify current version of GPL. - Add ${misc:Depends} to debian/control Depends for all binary packages. - debian/control.d/libpawlib{2,-lesstif3}-dev.control: change "Conflicts" to "Breaks". * Fix FTBFS #552905, thanks Steve Langasek <vorlon@debian.org>. * Remove duplicated section field from control files: - debian/control.d/debian/control.d/paw++.control - debian/control.d/paw-common.control - debian/control.d/paw-demos.control - debian/control.d/paw.control * debian/source/format: set source format to 1.0. * Add typo fixing patches 131 and 132. * Update patch 119: include stdlib.h to declare 'free' function. * Update patch 211: eliminate warning on incompatible pointers. * debian/rules: remove obsolete dh_desktop. * debian/control.d/0base.control: add Vcs-{Git,Browser} fields. * debian/lintian/paw: remove override menu-command-not-in-package. * debian/lintian/{libpawlib-lesstif3,libpawlib2-gfortran}: override no-symbols-control-file. [ Sylvestre Ledru ] * Switch to dpkg-source 3.0 (quilt) format

    2008-06-25 - Kevin B. McCarty <kmccarty@debian.org> paw (1:2.14.04.dfsg.2-6) unstable; urgency=low * Patch 302: minor fixes to paw script to allow it to properly call binaries in $CERNLIB/$CERN_LEVEL/bin if those environment variables are set. * Patch 804: fix Debian-specific bug that caused PAW to abort if the difference between two pointers used by COMIS was in the range given by INT_MAX < diff <= UINT_MAX. Thanks to Giuseppe Tagliente <Pino.Tagliente@ba.infn.it> for the bug report (by private email).

    2008-05-09 - Kevin B. McCarty <kmccarty@debian.org> paw (1:2.14.04.dfsg.2-5) unstable; urgency=low * Patch 804: omit "extern" from common block declaration since the "extern" is included in the cfortran.h COMMON_BLOCK_DEF macro as of cfortran.h version 4.4-12. * Build-Depend on cfortran (>= 4.4-12) for this change. * Patch 307: refresh internal copy of cfortran.h to 4.4-12 (although we do not use this internal copy in the build, it's best to be consistent).

    2008-04-21 - Kevin B. McCarty <kmccarty@debian.org> paw (1:2.14.04.dfsg.2-4) unstable; urgency=low * Create symlinks from /usr/share/icons/hicolor/{32x32,48x48}/apps/paw.xpm to /usr/share/pixmaps/paw{32x32,48x48}.xpm in paw-common package. * Apply patch to Paw++ desktop file from Patrice Dumas. * Run dh_icons in debian/rules binary-indep target. * Build-Depend on debhelper (>= 6.0.12) since we need fix for #448094.

    2008-02-25 - Kevin B. McCarty <kmccarty@debian.org> paw (1:2.14.04.dfsg.2-3) unstable; urgency=low * Fix unescaped hyphens in paw.1 man page. * Remove deprecated Encoding field from Paw++ desktop entry. * Upload to unstable.

    Advertisement
    Advertisement