parser3-cgi_3.4.2-2_amd64.deb


Advertisement

Description

parser3-cgi - Parser 3, HTML-embedded scripting language (CGI binary)

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: parser3-cgi
Package version: 3.4.2
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 1.09 KB
Download size: 458.41 KB
Official Mirror: ftp.br.debian.org
This package provides the /usr/lib/cgi-bin/parser3 CGI interpreter built for use in Apache 2 with mod_actions, or any other CGI httpd that supports a similar mechanism. Parser 3 - simple and convenient object-oriented language which allows creating good sites in short time. Available features: * XML, XSL, XPath and DOM support * Available in documented source code * Uniformed database support * Support of object-oriented programmers * Detailed language documentation (160 pages!) * UTF-8 support

Alternatives

    Download

    Source package: parser

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install parser3-cgi deb package:
      # sudo apt-get install parser3-cgi

    Files

    • /etc/parser3/auto.p
    • /usr/bin/parser3
    • /usr/lib/cgi-bin/parser3
    • /usr/share/doc/parser3-cgi
    • /usr/share/man/man1/parser.1.gz
    • /usr/share/man/man1/parser3.1.gz

    Changelog

    2012-06-28 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.2-2) unstable; urgency=low * Add -D_LARGEFILE64_SOURCE to fix FTBS of apache2 module for i386 * Drop quilt deps * Add versioned deps on g++

    2012-06-28 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.2-1) unstable; urgency=low * Imported Upstream version 3.4.2 * Adopt changes by Konstantin Morshnev for 3.4.2 * Change Build-Depends: - add g++, libltdl-dev - drop automake1.9, apache2-threaded-dev * Fix auto.p.dist installation * Fix mod_parser3.so path * Drop unused override's * Drop --disable-version-update option * Update debian/operators.ru.txt

    2012-06-01 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.1-7) unstable; urgency=low * Added patch 115 to call pa_setup_module_cells() while real request handling. * Fix syntax error for debian/copyright * Fix FTBFS: multiarch path for xml lib (Closes: #672054) * Refresh 199_reconfigure.patch * Change dh compat to 9, enable hardening support * Drop custom CFLAGS, LDFLAGS in debian/rules * Add -fPIC to CFLAGS/CXXFLAGS

    2012-03-05 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.1-4) unstable; urgency=low * Reformat debian/copyright according to accepted DEP5 spec * Bump up Standards-Version to 3.9.3 (no changes)

    2011-11-26 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.1-3) unstable; urgency=low * Added dependence on apache2.2-common for libapache2-mod-parser3 (fix puiparts installation error) * Fixed desc for libapache2-mod-parser3

    2011-11-24 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.1-2) unstable; urgency=low * Remove /etc/patser3/apache2/auto.p from CGI SAPI package (Closes: #649870)

    2011-11-20 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.1-1) unstable; urgency=low * Create default constructor for VVoid to make compiler happy (with - fpermissive). Closes: #625021. * Bump up Standards-Version to 3.9.2. * Added (tmp) override for embedded-library ltdl * Removed obsoleted overrides cannot-check-whether-usr-share-doc- symlink-points-to-foreign-package * Imported Upstream version 3.4.1 * Refresh patches for 3.4.1 version * Update debian/operators.ru.txt * Build with Apache2 shared module * Cleanup debian/rules * Patch to build both CGI & Apache2 SAPI for --with-apache * Install auto.p in /etc/parser3/apache2/ for Apache2 SAPI * Install parser3.load for apache2 module * Fix apache.conf for apache2 module * Clarify installation procedure for different SAPI * Added postinst/prerm scripts for libapache2-mod-parser3 package

    2011-03-19 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.0-4) unstable; urgency=low * Refresh patches with --no-index --no-timestamps -pab --diffstat * Update ltconfig & ltmain.sh to make lintian happy * Use tiny debian/rules, bump up debhelper compat level * Create links for docs (to parser3-common) * Add lintian overrides for cannot-check-whether-usr-share-doc- symlink-points-to-foreign-package (/usr/share/doc/<package> -> parser3-common)

    2011-03-04 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.0-3) unstable; urgency=low * Bump up Standards-Version * Add hints to enable mod_actions in doc * Use versioned LGPL license file in debian/copyright * Added "DM-Upload-Allowed: yes" control field

    2010-05-19 - Sergey B Kirpichev <skirpichev@gmail.com> parser (3.4.0-2) unstable; urgency=low * Add ${misc:Depends} for parser3. * Use "3.0 (quilt)" package format. * Update format of debian/copyright, copyright years. * Bump Standards-Version to 3.8.4. * Patch embedded copy ltdl.c from upstream branch-1-5 (CVE-2009-3736). Closes: #559837. * Use automake-1.9 for 199 patch (Closes: #560608).

    Advertisement
    Advertisement