pango-graphite_0.9.3-0.2_amd64.deb


Advertisement

Description

pango-graphite - SILGraphite support for pango

Distribution: Debian 7 (Wheezy)
Repository: Debian Main amd64
Package name: pango-graphite
Package version: 0.9.3
Package release: 0.2
Package architecture: amd64
Package type: deb
Installed size: 148 B
Download size: 23.19 KB
Official Mirror: ftp.br.debian.org
SILGraphite is a system that can be used to create and use "smart fonts" capable of displaying writing systems with various complex behaviors, such as: contextual shaping, ligatures, reordering, split glyphs, bidirectionality, stacking diacritics and complex positioning. This library was designed and developed by the NRSI (Non-Roman Script Initiative) within SIL International (www.sil.org) to act as a complement to other smart font rendering technologies with limited practical local extensability. Its purpose is to help meet the needs of a very large number of "minority language" communities for local extensibility of complex script behaviors. The behavior of the SILGraphite rendering engine for a given writing system is specified through extra tables added to a TrueType font. These tables are generated by compiling a GDL (Graphite Description Language) source file into a font using gdlcomp. This package contains a pango module so that apps that use pango get graphite capabilities.

Alternatives

    Download

    Source package: pango-graphite

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install pango-graphite deb package:
      # sudo apt-get install pango-graphite

    Files

    • /usr/lib/x86_64-linux-gnu/pango/1.6.0/module-files.d/pango-graphite.modules
    • /usr/lib/x86_64-linux-gnu/pango/1.6.0/modules/graphite/pango-graphite.so
    • /usr/share/doc/pango-graphite/README
    • /usr/share/doc/pango-graphite/changelog.Debian.gz
    • /usr/share/doc/pango-graphite/copyright

    Changelog

    2011-08-23 - Steve Langasek <vorlon@debian.org> pango-graphite (0.9.3-0.2) unstable; urgency=low * Non-maintainer upload. * Fixes package unusability with multiarch libpango. Closes: #619423. * debian/patches/pango-multiarch-compatibility.patch: Query our libdir directly from pango, so that we always install to the directory pango is looking for - there's no reason for us to set libdir independently of pango. * debian/control: set Multi-Arch: same unconditionally; if we're building against a multiarch-enabled pango then this will be accurate, and if we're not it doesn't matter anyway because there will be no way to satisfy the dependencies of more than one version of pango-graphite at a time. * debian/pango-graphite.install: handle installation of our module from either the multiarch or the classic lib directory. It's safe to just list both here since the package is at debhelper compat level 4.

    2010-06-12 - Arand Nash <ienorand@gmail.com> pango-graphite (0.9.3-0.1) unstable; urgency=low * Non-maintainer upload * New upstream release - Fixes induced crashes in iceweasel (Closes: #471642) * Created new orig.tar.gz including unchanged original upstream tarball due to usage of cdbs' tarball.mk

    2008-03-22 - Luk Claes <luk@debian.org> pango-graphite (0.9.2-3.1) unstable; urgency=medium * Non-maintainer upload. * Fix FTBFS with GCC 4.3 (Closes: #455314).

    2007-09-05 - Daniel Glassey <wdg@debian.org> pango-graphite (0.9.2-3) unstable; urgency=low * Upload to Debian with source this time * [pango-graphite] broken B-D: libgraphite-dev (Closes: #431382) pango-graphite now includes files as graphite/blah.h not just blah.h

    2007-08-31 - Daniel Glassey <wdg@debian.org> pango-graphite (0.9.2-2) unstable; urgency=low * Upload to Debian * [pango-graphite] broken B-D: libgraphite-dev (Closes: #431382) pango-graphite now includes files as graphite/blah.h not just blah.h * Build dep on libgraphite-dev >= 2.2.1-1

    2007-08-27 - Martin Hosken <martin_hosken@sil.org> pango-graphite (0.9.2-1) feisty; urgency=low * Fix RTL * Fix glyph metrics to handle double diacritics

    2007-05-31 - Daniel Glassey <wdg@debian.org> pango-graphite (0.9.0-1) unstable; urgency=low * Release ready for upload to Debian, Closes: #363105

    2007-05-26 - Daniel Glassey <wdg@debian.org> pango-graphite (0.0.0+0455svn-1) unstable; urgency=low * Rename package to pango-graphite * New svn version * Unreleased so changing version scheme * Policy 7.2.2, no changes * don't need preinst, postinst, prerm anymore because of dh_pangomodules * Include dbg package * Confirm package is lintian clean

    2006-04-17 - Daniel Glassey <wdg@debian.org> pangographite (233svn-1) unstable; urgency=low * New svn version * Fix custom pango-querymodules to check module directory not local * Ready to upload to Debian, Closes: #363105

    2006-04-17 - Daniel Glassey <wdg@debian.org> pangographite (231svn-1) unstable; urgency=low * New svn version * don't need to build-dep on gtk any more * includes a custom version of pango-querymodules that includes modules in the subdirectory of the default directory http://bugzilla.gnome.org/show_bug.cgi?id=323661 * divert pango-querymodules from libpango1.0-common to this custom version * Document the diversions in README.Debian * debian/rules use new --enable-querymod option

    Advertisement
    Advertisement