owl_2.2.2-1.1+b3_amd64.deb


Advertisement

Description

owl - A curses-based tty Zephyr client

Property Value
Distribution Debian 7 (Wheezy)
Repository Debian Main amd64
Package name owl
Package version 2.2.2
Package release 1.1+b3
Package architecture amd64
Package type deb
Installed size 492 B
Download size 221.12 KB
Official Mirror ftp.br.debian.org
An alternative standalone (doesn't use zwgc) Zephyr (instant
messaging) client.  Has perl hooks and a curses UI; supports Kerberos
if libzephyr3-krb is present. (Also supports AIM.)
ktools software -- The 'k' is for Quality!

Alternatives

Package Version Architecture Repository
owl_2.2.2-1.1+b3_i386.deb 2.2.2 i386 Debian Main
owl - - -

Requires

Name Value
libc6 >= 2.4
libcomerr2 >= 1.01
libglib2.0-0 >= 2.12.0
libncurses5 >= 5.5-5~
libperl5.14 >= 5.14.2
libssl1.0.0 >= 1.0.0
libtinfo5 -
libzephyr4 -
zephyr-clients -

Download

Type URL
Binary Package owl_2.2.2-1.1+b3_amd64.deb
Source Package owl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install owl deb package:
    # sudo apt-get install owl

Files

Path
/usr/bin/owl
/usr/share/doc/owl/README.Debian
/usr/share/doc/owl/changelog.Debian.gz
/usr/share/doc/owl/changelog.gz
/usr/share/doc/owl/copyright
/usr/share/doc/owl/intro.txt.gz
/usr/share/man/man1/owl.1.gz

Changelog

2009-07-23 - Sam Hartman <hartmans@debian.org>
owl (2.2.2-1.1) unstable; urgency=low
* Non-maintainer upload.
* Build depend on libzephyr-dev >= 3.0; this indicates a transition from
krb4-based zephyr to krb5-based zephyr, Closes: #538053
2009-04-13 - Mark W. Eichin <eichin@thok.org>
owl (2.2.2-1) unstable; urgency=low
* New upstream release.  The upstream author has become active again and
has worked with the barnowl developers on security issues. (Closes: #515118)
* configure.in, debian.control: barnowl updates via Sam Hartman
eliminate retro libkrb4 and des425 dependencies. (Closes: #517019)
* Do not link against libkrb4 or libkrb5; we use none of their symbols
* Support openssl DES for zcrypt so that we continue to have zcrypt
after libdes425 goes away
Note: ditched the KerberosIV test entirely to force this version,
allowing build/test on lenny.
* zcrypt.c: use des.h again, so we get the openssl one above.
* from unreleased 2.1.11-3:
* debian/control: version debhelper depends (lintian
package-lacks-versioned-build-depends-on-debhelper.)
* debian/watch: New file.
* debian/control: add libglib2.0-dev, per configure.in
2008-10-01 - Mark W. Eichin <eichin@thok.org>
owl (2.1.11-2) unstable; urgency=low
* debian/control, debian/rules, debian/compat: move to debhelper V7
(lintian debian-rules-sets-DH_COMPAT,
package-uses-deprecated-debhelper-compat-version.)
* debian/changelog: force my original name spelling to avoid false NMU
detection (lintian changelog-should-mention-nmu,
source-nmu-has-incorrect-version-number.)
* debian/rules: conditionalize distclean more narrowly (lintian
debian-rules-ignores-make-clean-error.)
2008-09-28 - Mark Eichin <eichin@thok.org>
owl (2.1.11-1) unstable; urgency=low
* New upstream release. (Closes: #454632)
* zephyr.c: report error in owl_zephyr_loadsubs too.
2008-09-27 - Mark Eichin <eichin@thok.org>
owl (2.1.8-4) unstable; urgency=low
* debian/copyright: fix lintian complaint about
copyright-lists-upstream-authors-with-dh_make-boilerplate.
* debian/control: fix lintian complaint about
description-synopsis-might-not-be-phrased-properly.  Also hint at
libzephyr3-krb, though I don't think it needs a Suggests.  Since the
code includes AIM support, grudgingly mention it in the Description.
* functions.c: support modern graphical browsers; doesn't implement the
full generic configuration due to the -remote issue, but particular
new browsers could be added directly in perl extension code.
(Closes: #152405)
2008-09-26 - Mark Eichin <eichin@thok.org>
owl (2.1.8-3) unstable; urgency=low
* Thanks to rra and dannf for the NMUs. (Closes: #477626)
* perlconfig.c: use PERL_SYS_INIT3 protocol as documented in perldoc
perlembed. (Closes: #495061)
2008-05-25 - Russ Allbery <rra@debian.org>
owl (2.1.8-2.2) unstable; urgency=low
* Non-maintainer upload.
* Sleep for 100ms instead of 10us when no key has been pressed to
avoid busy-waiting on input.  (Closes: #433027)
* More correctly remove the -E flag from Perl's ldflags to fix build
problems with Perl 5.10.  (Closes: #476013)
2005-10-11 - dann frazier <dannf@debian.org>
owl (2.1.8-2.1) unstable; urgency=low
* Non-maintainer upload.
* Include a patch from Andreas Jochens to fix compilation with gcc-4.0.
Closes: #287891
* Add some prototypes to perlglue.xs to avoid the implicit conversion of
return pointers from owl_zephyr_get_realm() & owl_zephyr_get_sender().
Closes: #326106
2004-08-29 - Mark W. Eichin <eichin@thok.org>
owl (2.1.8-2) unstable; urgency=low
* zcrypt.c: use kerberosIV/des.h, not the openafs one. Closes: #189108.
* configure.in: change it in the test, too.

See Also

Package Description
owserver_2.8p15-1_amd64.deb Backend server for 1-Wire control
owx_0~20110415-3.1_amd64.deb utility to program Wouxun dual-band handheld radios
oxref_0.90.10-1_amd64.deb cross reference utility
oxygen-icon-theme_4.8.4-1_all.deb Oxygen icon theme
oxygencursors_0.0.2012-06-kde4.8-2.1_all.deb Oxygen mouse cursor theme
p0f_2.0.8-2_amd64.deb Passive OS fingerprinting tool
p10cfgd_1.0-14_all.deb Remote configuration daemon for Gracilis Packeten
p11-kit_0.12-3_amd64.deb Utilities for working with the p11-glue library and proxy module
p3scan_2.3.2-8_amd64.deb transparent POP3-proxy with virus- and spam-scanning
p7zip-full_9.20.1~dfsg.1-4+deb7u1_amd64.deb 7z and 7za file archivers with high compression ratio
p7zip_9.20.1~dfsg.1-4+deb7u1_amd64.deb 7z file archiver with high compression ratio
p910nd_0.95-1_amd64.deb small printer daemon intended for diskless workstations
pacemaker-dev_1.1.7-1_amd64.deb HA cluster resource manager (development files)
pacemaker_1.1.7-1_amd64.deb HA cluster resource manager
pachi-data_1.0-6_all.deb Platform game featuring Pachi el marciano (data files)
Advertisement
Advertisement